summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-08-02 22:42:13 +0200
committerMatthias Maier <tamiko@gentoo.org>2016-08-02 23:12:04 -0500
commitffafa28c6ee27e16b8ebf09d9f94eda84b8a784d (patch)
tree745d603f6d7a8123318f366d00ff47581ca7c1ce /sci-libs/libqalculate/libqalculate-0.9.9.ebuild
parentdev-libs/beecrypt: Stable for HPPA (bug #577864). (diff)
downloadgentoo-ffafa28c6ee27e16b8ebf09d9f94eda84b8a784d.tar.gz
gentoo-ffafa28c6ee27e16b8ebf09d9f94eda84b8a784d.tar.bz2
gentoo-ffafa28c6ee27e16b8ebf09d9f94eda84b8a784d.zip
sci-libs/libqalculate: version bump
* EAPI=6 Package-Manager: portage-2.3.0 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-libs/libqalculate/libqalculate-0.9.9.ebuild')
-rw-r--r--sci-libs/libqalculate/libqalculate-0.9.9.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sci-libs/libqalculate/libqalculate-0.9.9.ebuild b/sci-libs/libqalculate/libqalculate-0.9.9.ebuild
new file mode 100644
index 000000000000..513479bf33da
--- /dev/null
+++ b/sci-libs/libqalculate/libqalculate-0.9.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A modern multi-purpose calculator library"
+HOMEPAGE="https://qalculate.github.io/"
+SRC_URI="https://github.com/Qalculate/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/6"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="gnuplot readline static-libs"
+
+COMMON_DEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ >=sci-libs/cln-1.2
+ sys-libs/zlib
+ readline? ( sys-libs/readline:0= )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ net-misc/wget
+ gnuplot? ( >=sci-visualization/gnuplot-3.7 )"
+
+src_prepare() {
+ default
+
+ cat >po/POTFILES.skip <<-EOF
+ # Required by make check
+ data/currencies.xml.in
+ data/datasets.xml.in
+ data/elements.xml.in
+ data/functions.xml.in
+ data/planets.xml.in
+ data/units.xml.in
+ data/variables.xml.in
+ src/defs2doc.cc
+ EOF
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with readline)
+}
+
+src_install() {
+ # docs/reference/Makefile.am -> referencedir=
+ emake \
+ DESTDIR="${D}" \
+ referencedir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ install
+
+ dodoc AUTHORS ChangeLog NEWS README* TODO
+
+ find "${ED}" -name '*.la' -delete || die
+}