summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-01-09 22:00:40 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-01-09 22:01:51 +0100
commit039569a06d53d37fdbb80bcff8bc47b6c6b7a62a (patch)
tree14e1370f97d2f5af08a93ceaff187d418cd0e205 /sci-libs/libqalculate
parentdev-ml/luv: drop unused inherit (diff)
downloadgentoo-039569a06d53d37fdbb80bcff8bc47b6c6b7a62a.tar.gz
gentoo-039569a06d53d37fdbb80bcff8bc47b6c6b7a62a.tar.bz2
gentoo-039569a06d53d37fdbb80bcff8bc47b6c6b7a62a.zip
sci-libs/libqalculate: Revert: "drop 3.21.0"
3.22.0 wasn't stabilized on arm64 yet. This reverts commit a6357437c4a345cf1696e95ce7cd27131e36e78f. Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'sci-libs/libqalculate')
-rw-r--r--sci-libs/libqalculate/Manifest1
-rw-r--r--sci-libs/libqalculate/libqalculate-3.21.0.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/sci-libs/libqalculate/Manifest b/sci-libs/libqalculate/Manifest
index 71996e1c2825..7fac31453330 100644
--- a/sci-libs/libqalculate/Manifest
+++ b/sci-libs/libqalculate/Manifest
@@ -1 +1,2 @@
+DIST libqalculate-3.21.0.tar.gz 2117414 BLAKE2B eaf8b886e716a6f8e9631dbda6533906cc7c5ed986233d75b9384aefb4123479914715d37268db5e1d403d1ee1835cde77314abe5380768fce5c266d1c253ca3 SHA512 7ca876ffe359ab2c6c6ae266007f489f9cd26f6650d6ace4e1d80cc660d16294cce601ed81046baca25cc4ec41668498af0a555fddc47c4118241e72af039614
DIST libqalculate-3.22.0.tar.gz 2150167 BLAKE2B 2023dc00e516f26d93e6acae66acb6211fb4dd234fba7e1e012c29ea224276040e75552b923b275e0cbe3e168ed419849f7f204aac3952a872ad0f1916470358 SHA512 2fc7e9e2edda0dfa221865050068eead29f9fecfef8eb8817bacc7493ed03215c60931b40e69165f565fc0574e370131ebebd9b247fedafc5821aae35b71dac9
diff --git a/sci-libs/libqalculate/libqalculate-3.21.0.ebuild b/sci-libs/libqalculate/libqalculate-3.21.0.ebuild
new file mode 100644
index 000000000000..ce8152e82e7b
--- /dev/null
+++ b/sci-libs/libqalculate/libqalculate-3.21.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Bump with sci-calculators/qalculate-gtk!
+
+inherit toolchain-funcs
+
+DESCRIPTION="A modern multi-purpose calculator library"
+HOMEPAGE="https://qalculate.github.io/"
+SRC_URI="https://github.com/Qalculate/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/22"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
+IUSE="curl icu gnuplot readline"
+
+DEPEND="
+ dev-libs/gmp:0=
+ dev-libs/libxml2:2
+ dev-libs/mpfr:0=
+ virtual/libiconv
+ curl? ( net-misc/curl )
+ icu? ( dev-libs/icu:= )
+ readline? ( sys-libs/readline:0= )"
+RDEPEND="${DEPEND}
+ gnuplot? ( >=sci-visualization/gnuplot-3.7 )"
+BDEPEND="dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ cat >po/POTFILES.skip <<-EOF || die
+ # Required by make check
+ data/currencies.xml.in
+ data/datasets.xml.in
+ data/elements.xml.in
+ data/functions.xml.in
+ data/planets.xml.in
+ data/prefixes.xml.in
+ data/units.xml.in
+ data/variables.xml.in
+ src/defs2doc.cc
+ EOF
+}
+
+src_configure() {
+ # Needed for po-defs/Makefile
+ export CXX_FOR_BUILD="$(tc-getBUILD_CXX)"
+ export CXXCPP_FOR_BUILD="$(tc-getBUILD_CXX) -E"
+
+ # bug #792027
+ tc-export CC
+
+ econf \
+ --disable-static \
+ $(use_with curl libcurl) \
+ $(use_with gnuplot gnuplot-call) \
+ $(use_with icu) \
+ $(use_with readline)
+}
+
+src_install() {
+ # docs/reference/Makefile.am -> referencedir=
+ emake \
+ DESTDIR="${D}" \
+ referencedir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ install
+
+ einstalldocs
+
+ find "${ED}" -name '*.la' -delete || die
+}