summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-01-23 11:43:30 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-23 11:43:30 +0100
commit1b1d99e9b4eaac771725b7b7c1c0477fed0dc9d0 (patch)
treee17d1ef1204e6d92f4d0c5fba57e4ab3a5b883b8 /sci-libs/libqalculate
parentsys-fs/mtd-utils: Remove old (EAPI 5) (diff)
downloadgentoo-1b1d99e9b4eaac771725b7b7c1c0477fed0dc9d0.tar.gz
gentoo-1b1d99e9b4eaac771725b7b7c1c0477fed0dc9d0.tar.bz2
gentoo-1b1d99e9b4eaac771725b7b7c1c0477fed0dc9d0.zip
sci-libs/libqalculate: Bump to 3.16.1
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/libqalculate')
-rw-r--r--sci-libs/libqalculate/Manifest1
-rw-r--r--sci-libs/libqalculate/libqalculate-3.16.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/sci-libs/libqalculate/Manifest b/sci-libs/libqalculate/Manifest
index 2469b09cc2b3..887d6f317165 100644
--- a/sci-libs/libqalculate/Manifest
+++ b/sci-libs/libqalculate/Manifest
@@ -1,3 +1,4 @@
DIST libqalculate-0.9.9.tar.gz 1509180 BLAKE2B 3f309add80ddb6b21730eab25d37c2d8fee163a79768a09ec5e7e5d329aa11ed9dafbf77f4ce194a96c2ac6a3b55a9c0d16755d5e106123cc2a5f931f6872d91 SHA512 c7692dcd91e0a7aea8184ca5366a3caf704b6e716c9e8552f4214ce7fc3157cf127daf7a063196383e4d5a99f8703486f2282c7fb01acafee5e1b3d8993de384
DIST libqalculate-2.8.1.tar.gz 1961535 BLAKE2B 074d83a44cbc6cb5d8afe5121e4c34cec46f2f6fecf046f6b4e67c6ebc612030ccbd0f42c303cc675267374502ecb3e831c9bbfca0f13d339e31fb8933a99b7a SHA512 a258bf4f67db70263626ac77822afc75fd7a9e5af2feb1930314daff219865b28c43e82fef6ceae4f3f23957447d6eaebdc709e606d28457bca0f47eefb9274a
DIST libqalculate-3.15.0.tar.gz 1747863 BLAKE2B eed4cf8f11546b80e9556cfdf09e48d8c4c29948e6bdc02b3f9efd9aa6dce8e6c5eecf440bf4b6243ddcdb59cb7176f1eb054a3ef73cc91444d86ed7645f3a37 SHA512 b8f2af83218a3f90326cb7f679b71cac328cf0591178ed718920cd491d682cf7341c702934b3a232bea5a67ec2d2e09b4321a7ac938c5bc1e221bee086ae4c36
+DIST libqalculate-3.16.1.tar.gz 1756176 BLAKE2B b09e06a4d89249bb3e38a47ed47acc7598bc62e966673a1eb175641b1018021199dbbcd38266301ec8b2d3c55747378adfde3db4e25e58771be162905cb493dc SHA512 3cc7ba66493252015b9d33835188c236b10afdce5f23021a5e686609609265aed81d592815ee6a172c269a0f144a3203c954435fea8ddb82637453d5c98cd05a
diff --git a/sci-libs/libqalculate/libqalculate-3.16.1.ebuild b/sci-libs/libqalculate/libqalculate-3.16.1.ebuild
new file mode 100644
index 000000000000..94aa33f3f886
--- /dev/null
+++ b/sci-libs/libqalculate/libqalculate-3.16.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A modern multi-purpose calculator library"
+HOMEPAGE="https://qalculate.github.io/"
+SRC_URI="https://github.com/Qalculate/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/21"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="curl icu gnuplot readline"
+
+DEPEND="
+ dev-libs/gmp:0=
+ dev-libs/libxml2:2
+ dev-libs/mpfr:0=
+ virtual/libiconv
+ curl? ( net-misc/curl )
+ icu? ( dev-libs/icu:= )
+ readline? ( sys-libs/readline:0= )"
+RDEPEND="${DEPEND}
+ gnuplot? ( >=sci-visualization/gnuplot-3.7 )"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ cat >po/POTFILES.skip <<-EOF || die
+ # Required by make check
+ data/currencies.xml.in
+ data/datasets.xml.in
+ data/elements.xml.in
+ data/functions.xml.in
+ data/planets.xml.in
+ data/prefixes.xml.in
+ data/units.xml.in
+ data/variables.xml.in
+ src/defs2doc.cc
+ EOF
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_with curl libcurl) \
+ $(use_with gnuplot gnuplot-call) \
+ $(use_with icu) \
+ $(use_with readline)
+}
+
+src_install() {
+ # docs/reference/Makefile.am -> referencedir=
+ emake \
+ DESTDIR="${D}" \
+ referencedir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ install
+ einstalldocs
+
+ find "${ED}" -name '*.la' -delete || die
+}