summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/libqalculate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/libqalculate')
-rw-r--r--sci-libs/libqalculate/Manifest1
-rw-r--r--sci-libs/libqalculate/libqalculate-0.9.7-r1.ebuild62
-rw-r--r--sci-libs/libqalculate/metadata.xml8
3 files changed, 71 insertions, 0 deletions
diff --git a/sci-libs/libqalculate/Manifest b/sci-libs/libqalculate/Manifest
new file mode 100644
index 000000000000..708c5fc82506
--- /dev/null
+++ b/sci-libs/libqalculate/Manifest
@@ -0,0 +1 @@
+DIST libqalculate-0.9.7.tar.gz 1256271 SHA256 9a6d97ce3339d104358294242c3ecd5e312446721e93499ff70acc1604607955 SHA512 9aae8540481df4aa1cb24b1c6e8e9424e87758444f0b9689cd809bdf4230c4b5257c74363e6f084cea4e3be1935f45c53e7fc592f76d25d709ad88c97884bc42 WHIRLPOOL 21259323d91a8d7dc746048a3ef52f435ad3ff0450c08238d6a1d246990c5144a3072826ae0d2f656f75fe3c3be51b5c93a90f81eec4c742188bb9e33f5c171f
diff --git a/sci-libs/libqalculate/libqalculate-0.9.7-r1.ebuild b/sci-libs/libqalculate/libqalculate-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..bd314e54bba6
--- /dev/null
+++ b/sci-libs/libqalculate/libqalculate-0.9.7-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A modern multi-purpose calculator library"
+HOMEPAGE="http://qalculate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${P/lib}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="gnuplot readline static-libs"
+
+COMMON_DEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ >=sci-libs/cln-1.2
+ sys-libs/zlib
+ readline? ( sys-libs/readline )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ net-misc/wget
+ gnuplot? ( >=sci-visualization/gnuplot-3.7 )"
+
+src_prepare() {
+ cat >po/POTFILES.skip <<-EOF
+ # Required by make check
+ data/currencies.xml.in
+ data/datasets.xml.in
+ data/elements.xml.in
+ data/functions.xml.in
+ data/planets.xml.in
+ data/units.xml.in
+ data/variables.xml.in
+ src/defs2doc.cc
+ EOF
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with readline)
+}
+
+src_install() {
+ # docs/reference/Makefile.am -> referencedir=
+ emake \
+ DESTDIR="${D}" \
+ referencedir="${EPREFIX}/usr/share/doc/${PF}/html/reference" \
+ install
+
+ dodoc AUTHORS ChangeLog NEWS README* TODO
+
+ prune_libtool_files
+}
diff --git a/sci-libs/libqalculate/metadata.xml b/sci-libs/libqalculate/metadata.xml
new file mode 100644
index 000000000000..b3409acc001f
--- /dev/null
+++ b/sci-libs/libqalculate/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <upstream>
+ <remote-id type="sourceforge">.tar.gz</remote-id>
+ </upstream>
+</pkgmetadata>