summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/libticalcs2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/libticalcs2')
-rw-r--r--sci-libs/libticalcs2/Manifest2
-rw-r--r--sci-libs/libticalcs2/files/libticalcs2-1.1.0-locale.patch11
-rw-r--r--sci-libs/libticalcs2/libticalcs2-1.1.7.ebuild40
-rw-r--r--sci-libs/libticalcs2/libticalcs2-1.1.8.ebuild41
-rw-r--r--sci-libs/libticalcs2/metadata.xml15
5 files changed, 109 insertions, 0 deletions
diff --git a/sci-libs/libticalcs2/Manifest b/sci-libs/libticalcs2/Manifest
new file mode 100644
index 000000000000..d1220840920b
--- /dev/null
+++ b/sci-libs/libticalcs2/Manifest
@@ -0,0 +1,2 @@
+DIST libticalcs2-1.1.7.tar.bz2 525111 SHA256 e16c79033c0eafa4ccda7fc56d018565bba1dfb70dd0b4c5f681bafe32a52ab0
+DIST libticalcs2-1.1.8.tar.bz2 524151 SHA256 a8286f8a2552bcad96beab99ce254e67b3dc1a03eb9d82f8de4bdf7b8efc3496 SHA512 0e09148006f5ee227d1b347ef44a6e755cb1dd757b8ff99e0f006aec0bc37c40dc5e293e44a0d91fc966b47da9113b4f00a71d9d9aa5cfbea4b01487232c1c08 WHIRLPOOL 3458fd04e791a174506d21930b1843aa204cf63c504dc93e1f81e8e71e4646fa45493d2056bc6be6b7495f9a9e8afbfe802c3d55c698a70f95d1172dcb73c0c1
diff --git a/sci-libs/libticalcs2/files/libticalcs2-1.1.0-locale.patch b/sci-libs/libticalcs2/files/libticalcs2-1.1.0-locale.patch
new file mode 100644
index 000000000000..4602dfdba3da
--- /dev/null
+++ b/sci-libs/libticalcs2/files/libticalcs2-1.1.0-locale.patch
@@ -0,0 +1,11 @@
+--- src/gettext.h~ 2007-02-23 16:05:21.000000000 +0000
++++ src/gettext.h 2009-02-03 12:41:31.584312058 +0000
+@@ -24,7 +24,7 @@
+
+ /* Get declarations of GNU message catalog functions. */
+ # include <libintl.h>
+-
++# include <locale.h>
+ #else
+
+ /* Solaris /usr/include/locale.h includes /usr/include/libintl.h, which
diff --git a/sci-libs/libticalcs2/libticalcs2-1.1.7.ebuild b/sci-libs/libticalcs2/libticalcs2-1.1.7.ebuild
new file mode 100644
index 000000000000..8456c70c1007
--- /dev/null
+++ b/sci-libs/libticalcs2/libticalcs2-1.1.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils multilib
+
+DESCRIPTION="Library for communication with TI calculators"
+HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
+SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc nls static-libs"
+
+RDEPEND="dev-libs/glib:2
+ >=sci-libs/libticables2-1.3.3
+ >=sci-libs/libticonv-1.1.3
+ >=sci-libs/libtifiles2-1.1.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
+
+src_configure() {
+ econf \
+ --disable-rpath \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use doc && dohtml docs/html/*
+ use static-libs || rm "${D}"/usr/$(get_libdir)/${PN}.la
+}
diff --git a/sci-libs/libticalcs2/libticalcs2-1.1.8.ebuild b/sci-libs/libticalcs2/libticalcs2-1.1.8.ebuild
new file mode 100644
index 000000000000..2dd8dce5103b
--- /dev/null
+++ b/sci-libs/libticalcs2/libticalcs2-1.1.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Library for communication with TI calculators"
+HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
+SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc nls static-libs"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=sci-libs/libticables2-1.3.3
+ >=sci-libs/libticonv-1.1.3
+ >=sci-libs/libtifiles2-1.1.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
+
+src_configure() {
+ local myeconfargs=(
+ --disable-rpath
+ $(use_enable nls)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dohtml docs/html/*
+}
diff --git a/sci-libs/libticalcs2/metadata.xml b/sci-libs/libticalcs2/metadata.xml
new file mode 100644
index 000000000000..020327555f5a
--- /dev/null
+++ b/sci-libs/libticalcs2/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ The libticalcs provides a set of functions to communicate with Texas
+ Instruments calculators. It implements the TI protocol for each type
+ of calculator, independently of the link cable used to establish the
+ link.
+ All graphing calculators from Texas Instruments are supported
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">tilp</remote-id>
+ </upstream>
+</pkgmetadata>