summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-14 23:30:25 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-14 23:30:25 +0200
commitd256fef3b17af38873642d5178a2582204cca728 (patch)
tree8074ef5d3bb4621c7e901130fdfa010844ae30cc /sci-libs/lis
parentsci-libs/libsvm: [QA] tc-has-openmp → tc-check-openmp (diff)
downloadgentoo-d256fef3b17af38873642d5178a2582204cca728.tar.gz
gentoo-d256fef3b17af38873642d5178a2582204cca728.tar.bz2
gentoo-d256fef3b17af38873642d5178a2582204cca728.zip
sci-libs/lis: [QA] tc-has-openmp → tc-check-openmp
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/lis')
-rw-r--r--sci-libs/lis/lis-1.6.5.ebuild21
1 files changed, 6 insertions, 15 deletions
diff --git a/sci-libs/lis/lis-1.6.5.ebuild b/sci-libs/lis/lis-1.6.5.ebuild
index 75c41a7dd9e8..27d638831af1 100644
--- a/sci-libs/lis/lis-1.6.5.ebuild
+++ b/sci-libs/lis/lis-1.6.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,21 +19,12 @@ DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}"/${PN}-1.6.2-autotools.patch )
-pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
- if ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected compiler"
-
- if tc-is-clang; then
- ewarn "OpenMP support in sys-devel/clang is provided by sys-libs/libomp,"
- ewarn "which you will need to build ${CATEGORY}/${PN} with USE=\"openmp\""
- fi
-
- die "need openmp capable compiler"
- fi
- FORTRAN_NEED_OPENMP=1
- fi
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp && FORTRAN_NEED_OPENMP=1
use fortran && fortran-2_pkg_setup
}