summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/lrslib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/lrslib')
-rw-r--r--sci-libs/lrslib/Manifest2
-rw-r--r--sci-libs/lrslib/lrslib-042c-r1.ebuild53
-rw-r--r--sci-libs/lrslib/lrslib-042c-r2.ebuild61
-rw-r--r--sci-libs/lrslib/lrslib-051.ebuild45
-rw-r--r--sci-libs/lrslib/metadata.xml15
5 files changed, 176 insertions, 0 deletions
diff --git a/sci-libs/lrslib/Manifest b/sci-libs/lrslib/Manifest
new file mode 100644
index 000000000000..ac64bbeb1733
--- /dev/null
+++ b/sci-libs/lrslib/Manifest
@@ -0,0 +1,2 @@
+DIST lrslib-042c.tar.gz 168765 SHA256 53f99b5271397bb5f317c96fa365edc1ac71fa7cba0295c8bd79e0882f5c3a4a SHA512 a5fdd65b2c4e4cadd5fb9679e0e94ddc6b3564cdb9bdfcb7304351fec943527d2dccf117148d8d418ad8bd4577c9f69dabd6ca07107c1c1555c8c6d17f38fa60 WHIRLPOOL 4c3c1d5a72f8ac91e3d6698a8409578f5c0a940562704adea6631e5f9fb738a24414806a4d4b3aedf4e32de49a8c09ec74058baef61e121ce54db7ef5d2f5c01
+DIST lrslib-051.tar.gz 179396 SHA256 500893df61631944bac14a76c6e13fc08e6e729727443fa5480b2510de0db635 SHA512 65e4752ae75f06bccb74b0e12e0b03943654cba048d54dbcf93a36bea7f73b32826babe066d5fe20d3c6609548dc957063558633affe64d795c240c1fe748927 WHIRLPOOL 54877f0432fef43989b5d7591cef6692dbb555fb0ccb8a634b82eefb06a20d478bbb1a62b2ef241c8cda74328da29bcbcdcf8031640d1e0455a1e57bf839125e
diff --git a/sci-libs/lrslib/lrslib-042c-r1.ebuild b/sci-libs/lrslib/lrslib-042c-r1.ebuild
new file mode 100644
index 000000000000..979695ee03af
--- /dev/null
+++ b/sci-libs/lrslib/lrslib-042c-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit toolchain-funcs
+
+DESCRIPTION="self-contained ANSI C implementation of the reverse search algorithm"
+HOMEPAGE="http://cgm.cs.mcgill.ca/~avis/C/lrs.html"
+SRC_URI="http://cgm.cs.mcgill.ca/~avis/C/lrslib/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="gmp"
+
+DEPEND="gmp? ( dev-libs/gmp )"
+RDEPEND="${DEPEND}"
+
+src_prepare(){
+ sed -i "s/gcc/$(tc-getCC)/g" makefile || die
+ sed -i "s/-O3/${CFLAGS} ${LDFLAGS}/g" makefile || die
+}
+
+src_compile () {
+ if use amd64 ; then
+ emake all64 || die "make failed"
+ else
+ emake || die "make failed"
+ fi
+ if use gmp ; then
+ emake gmp || die "make failed"
+ fi
+}
+
+src_install() {
+ dobin lrs redund redund1 || die
+ # Collides with sys-block/buffer
+ newbin buffer lrsbuffer || die
+ if use x86; then
+ dobin nash setupnash setupnash2 2nash || die
+ # Prevent clash with cddlib:
+ newbin fourier lrsfourier || die
+ fi
+ if use gmp; then
+ dobin glrs gredund gfourier || die
+ # Clash with www-plugins/gnash
+ newbin gnash lrsgnash || die
+ fi
+ dodoc readme || die
+ dohtml lrslib.html || die
+}
diff --git a/sci-libs/lrslib/lrslib-042c-r2.ebuild b/sci-libs/lrslib/lrslib-042c-r2.ebuild
new file mode 100644
index 000000000000..477beace74a9
--- /dev/null
+++ b/sci-libs/lrslib/lrslib-042c-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="self-contained ANSI C implementation of the reverse search algorithm"
+HOMEPAGE="http://cgm.cs.mcgill.ca/~avis/C/lrs.html"
+SRC_URI="http://cgm.cs.mcgill.ca/~avis/C/lrslib/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="gmp"
+
+DEPEND="gmp? ( dev-libs/gmp )"
+RDEPEND="${DEPEND}"
+
+src_prepare(){
+ sed -i "s/gcc/$(tc-getCC)/g" makefile || die
+ sed -i "s/-O3/${CFLAGS} ${LDFLAGS}/g" makefile || die
+ # We don't like static linking to gmp or anywhere.
+ if use amd64 ; then
+ # This macro may only change messages that the
+ # binary outputs, but just in case... (Bug 384195)
+ sed -i "s/-static/-DB64/g" makefile || die
+ else
+ sed -i "s/-static//g" makefile || die
+ fi
+}
+
+src_compile () {
+ if use amd64 ; then
+ emake all64
+ else
+ emake
+ fi
+ if use gmp ; then
+ emake gmp
+ fi
+}
+
+src_install() {
+ dobin lrs redund redund1
+ # Collides with sys-block/buffer
+ newbin buffer lrsbuffer
+ if use x86; then
+ dobin nash setupnash setupnash2 2nash
+ # Prevent clash with cddlib:
+ newbin fourier lrsfourier
+ fi
+ if use gmp; then
+ dobin glrs gredund gfourier
+ # Clash with www-plugins/gnash
+ newbin gnash lrsgnash
+ fi
+ dodoc readme
+ dohtml lrslib.html
+}
diff --git a/sci-libs/lrslib/lrslib-051.ebuild b/sci-libs/lrslib/lrslib-051.ebuild
new file mode 100644
index 000000000000..98cf0ce88582
--- /dev/null
+++ b/sci-libs/lrslib/lrslib-051.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="self-contained ANSI C implementation of the reverse search algorithm"
+HOMEPAGE="http://cgm.cs.mcgill.ca/~avis/C/lrs.html"
+SRC_URI="http://cgm.cs.mcgill.ca/~avis/C/lrslib/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gmp"
+
+DEPEND="gmp? ( dev-libs/gmp )"
+RDEPEND="${DEPEND}"
+
+src_prepare(){
+ sed -i "s/gcc/$(tc-getCC)/g" makefile || die
+ sed -i "s/-O3/${CFLAGS} ${LDFLAGS}/g" makefile || die
+ # Prefix for install
+ sed -i "s,/usr/local,/usr,g" makefile || die
+}
+
+src_compile () {
+ if use gmp ; then
+ emake all
+ emake all-shared
+ else
+ emake allmp
+ fi
+}
+
+src_install() {
+ dodoc readme
+ # Library
+ if use gmp ; then
+ emake DESTDIR="${D}" install-shared
+ fi
+ # Install default set of binaries
+ emake DESTDIR="${D}" install-common
+}
diff --git a/sci-libs/lrslib/metadata.xml b/sci-libs/lrslib/metadata.xml
new file mode 100644
index 000000000000..f8a5af1b110a
--- /dev/null
+++ b/sci-libs/lrslib/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tomka@gentoo.org</email>
+ <name>Thomas Kahle</name>
+ </maintainer>
+ <herd>sci</herd>
+ <longdescription>lrslib is a self-contained ANSI C implementation as a callable library of the
+ reverse search algorithm for vertex enumeration/convex hull problems and comes with a choice of
+ three arithmetic packages. Input file formats are compatible with Komei Fukuda's cdd package. All
+ computations are done exactly in either multiple precision or fixed integer arithmetic. Output is
+ not stored in memory, so even problems with very large output sizes can sometimes be
+ solved.</longdescription>
+</pkgmetadata>