summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2020-01-20 12:40:29 +1300
committerMichael Orlitzky <mjo@gentoo.org>2020-01-20 20:58:51 -0500
commit14c8a4597cb0906e3d6c4d52b3972d6dae51df91 (patch)
tree25a59a50363deb3c64d5f3f821b6dbf955ba80dd /sci-libs/m4ri
parentapp-portage/repoman: Remove old version 2.3.11 (diff)
downloadgentoo-14c8a4597cb0906e3d6c4d52b3972d6dae51df91.tar.gz
gentoo-14c8a4597cb0906e3d6c4d52b3972d6dae51df91.tar.bz2
gentoo-14c8a4597cb0906e3d6c4d52b3972d6dae51df91.zip
sci-libs/m4ri: New upstream release.
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: François René Pierre Bissey <frp.bissey@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/m4ri')
-rw-r--r--sci-libs/m4ri/Manifest1
-rw-r--r--sci-libs/m4ri/m4ri-20200115.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/sci-libs/m4ri/Manifest b/sci-libs/m4ri/Manifest
index b9e9242c6b5c..e0d3cfd6da7b 100644
--- a/sci-libs/m4ri/Manifest
+++ b/sci-libs/m4ri/Manifest
@@ -1 +1,2 @@
DIST m4ri-20140914.tar.gz 457978 BLAKE2B eadba6d1a751cb49cef25cc7726d87aa5746b23ad0a3b9bd274735a71da43ec4751fb655f91f3748f082369875508db365595f8443d77ae9645b3e4199d4f204 SHA512 efdd4ffa194d2d2b64a23a833420926613e74072ce62b2b06d768d157e134a615d88b93ed08d9f51f0fd14d686fd068523d1dc2c7cd9fb87108c96a4a11f4643
+DIST m4ri-20200115.tar.gz 510562 BLAKE2B 4522793ab61dd97dae5c8d82a4457364f437040c9c45c355007a3150bfebb5264e336b19a7416f62b5ef937480f15079d9c0e9711dd26a6f7c6f5ce66d699296 SHA512 4791576878097077bcda768c03a43ec9a5b05c29adaa9c5f1e737e798b3fc7d027f830183d57db7b8b6b75b25e01fb522eb8b2e5359efcb05054fc341cbb403c
diff --git a/sci-libs/m4ri/m4ri-20200115.ebuild b/sci-libs/m4ri/m4ri-20200115.ebuild
new file mode 100644
index 000000000000..27891c4fab19
--- /dev/null
+++ b/sci-libs/m4ri/m4ri-20200115.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Method of four russian for inversion (M4RI)"
+HOMEPAGE="https://bitbucket.org/malb/m4ri"
+SRC_URI="https://bitbucket.org/malb/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug openmp cpu_flags_x86_sse2 png static-libs"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="png? ( media-libs/libpng:= )"
+RDEPEND="${DEPEND}"
+
+# NEWS and ChangeLog are empty as of 2020-01-01, and README.md
+# didn't make it into the release tarball.
+DOCS=( AUTHORS )
+
+pkg_pretend() {
+ use openmp && tc-check-openmp
+}
+
+src_configure() {
+ # when using openmp and -O0 the testsuite fails
+ # https://github.com/cschwan/sage-on-gentoo/issues/475
+ # Still current as of 20200115
+ use openmp && replace-flags -O0 -O1
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable openmp) \
+ $(use_enable png) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable static-libs static)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}