summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-03-06 09:52:27 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-03-06 09:59:20 -0500
commit10c3378f2ec1f4f02d92d3ad4fc8bb4a548bc862 (patch)
tree4e0ccc1040b9f5cfbf3dcf29f6683426d39ea17e /sci-libs/m4rie/m4rie-20200115.ebuild
parentdev-python/django: Remove vulnerable (drop to ~arch) (diff)
downloadgentoo-10c3378f2ec1f4f02d92d3ad4fc8bb4a548bc862.tar.gz
gentoo-10c3378f2ec1f4f02d92d3ad4fc8bb4a548bc862.tar.bz2
gentoo-10c3378f2ec1f4f02d92d3ad4fc8bb4a548bc862.zip
sci-libs/m4rie: new package for matrices over GF(2^e) with "e" small.
The m4rie package is an extension of sci-libs/m4ri. It is used by SageMath, which can now detect and use the system copy of m4rie. Its inclusion therefore prevents pointless rebuilds of m4rie by users of SageMath on Gentoo. The ebuild was imported from the sage-on-gentoo overlay where François Bissey has been maintaining it. Closes: https://bugs.gentoo.org/711498 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/m4rie/m4rie-20200115.ebuild')
-rw-r--r--sci-libs/m4rie/m4rie-20200115.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-libs/m4rie/m4rie-20200115.ebuild b/sci-libs/m4rie/m4rie-20200115.ebuild
new file mode 100644
index 000000000000..676a82f2a93a
--- /dev/null
+++ b/sci-libs/m4rie/m4rie-20200115.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Fast dense matrix arithmetic over GF(2^e) for 2 <= e <= 16"
+HOMEPAGE="https://bitbucket.org/malb/m4rie/"
+SRC_URI="https://bitbucket.org/malb/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug static-libs"
+
+DEPEND=">=sci-libs/m4ri-20140914"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # m4rie doesn't actually have any openmp code. The configure flag
+ # stems from a mistaken belief that it needs to be there to use the
+ # openmp code in m4ri.
+ econf \
+ --disable-openmp \
+ $(use_enable debug) \
+ $(use_enable static-libs static)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}