summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-01-01 12:03:10 +0100
committerDavid Seifert <soap@gentoo.org>2020-01-01 12:03:10 +0100
commit09bf573ba60af609d172744fe89185ef58f76f0b (patch)
treebf882b8ee4bc90b886e0193d5fe4a095f04d46c3 /sci-libs/mpfi/mpfi-1.5.3.ebuild
parentsci-libs/proj: Drop 4.8.0 (diff)
downloadgentoo-09bf573ba60af609d172744fe89185ef58f76f0b.tar.gz
gentoo-09bf573ba60af609d172744fe89185ef58f76f0b.tar.bz2
gentoo-09bf573ba60af609d172744fe89185ef58f76f0b.zip
sci-libs/mpfi: Remove USE="static-libs"
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/mpfi/mpfi-1.5.3.ebuild')
-rw-r--r--sci-libs/mpfi/mpfi-1.5.3.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/sci-libs/mpfi/mpfi-1.5.3.ebuild b/sci-libs/mpfi/mpfi-1.5.3.ebuild
index f3981fb6316b..f1c184f6bfeb 100644
--- a/sci-libs/mpfi/mpfi-1.5.3.ebuild
+++ b/sci-libs/mpfi/mpfi-1.5.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,6 @@ SRC_URI="https://gforge.inria.fr/frs/download.php/37331/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs"
DEPEND="
>=dev-libs/gmp-4.1.2:0=
@@ -20,14 +19,12 @@ DEPEND="
RDEPEND="${DEPEND}"
my_src_configure() {
- ECONF_SOURCE="${S}" econf \
- $(use_enable static-libs static)
+ econf --disable-static
}
my_src_install() {
default
- if ! use static-libs; then
- find "${D}" -name '*.la' -delete || die
- fi
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}