summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-11-11 16:48:10 -0500
committerMike Gilbert <floppym@gentoo.org>2019-11-11 16:48:42 -0500
commit298d3c36aed5cdb79508f1527944cf2e64bf8686 (patch)
tree51d9cbc3ba67875692e761a3cfdf7074868509af /sci-libs/mpir/mpir-3.0.0.ebuild
parentwww-apps/moodle: version bumps to 3.7.3, 3.6.7, 3.5.9 (diff)
downloadgentoo-298d3c36aed5cdb79508f1527944cf2e64bf8686.tar.gz
gentoo-298d3c36aed5cdb79508f1527944cf2e64bf8686.tar.bz2
gentoo-298d3c36aed5cdb79508f1527944cf2e64bf8686.zip
sci-libs/mpir: pass --with-yasm=/bin/false on non-x86 archs
Closes: https://bugs.gentoo.org/661430 Package-Manager: Portage-2.3.78_p18, Repoman-2.3.17_p114 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sci-libs/mpir/mpir-3.0.0.ebuild')
-rw-r--r--sci-libs/mpir/mpir-3.0.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sci-libs/mpir/mpir-3.0.0.ebuild b/sci-libs/mpir/mpir-3.0.0.ebuild
index 9fd8a755b58d..6efc062bb0ad 100644
--- a/sci-libs/mpir/mpir-3.0.0.ebuild
+++ b/sci-libs/mpir/mpir-3.0.0.ebuild
@@ -59,12 +59,16 @@ src_configure() {
# beware that cpudetection aka fat binaries is x86/amd64 only.
# Place mpir in profiles/arch/$arch/package.use.mask
# when making it available on $arch.
- local myeconfargs+=(
+ local myeconfargs=(
$(use_enable cxx)
$(use_enable cpudetection fat)
$(use_enable static-libs static)
)
- econf ${myeconfargs[@]}
+ # https://bugs.gentoo.org/661430
+ if !use amd64 && !use x86; then
+ myeconfargs+=( --with-yasm=/bin/false )
+ fi
+ econf "${myeconfargs[@]}"
}
src_install() {