summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-01-23 20:51:15 +0100
committerDavid Seifert <soap@gentoo.org>2016-01-23 21:05:13 +0100
commit2ca5155c00e212a4ea8b6b4636b159baa5d917e3 (patch)
tree2b5477812b8c71bf17e799910bb239ea6dc50da7 /sci-libs/netcdf-cxx
parentsci-libs/netcdf: port to EAPI=6, remove 'autotools-utils' usage (diff)
downloadgentoo-2ca5155c00e212a4ea8b6b4636b159baa5d917e3.tar.gz
gentoo-2ca5155c00e212a4ea8b6b4636b159baa5d917e3.tar.bz2
gentoo-2ca5155c00e212a4ea8b6b4636b159baa5d917e3.zip
sci-libs/netcdf-cxx: Add USE=hdf5 dependency on sci-libs/netcdf
Gentoo-Bug: 566622 * EAPI=6 * Remove usage of 'autotools-utils' Package-Manager: portage-2.2.27
Diffstat (limited to 'sci-libs/netcdf-cxx')
-rw-r--r--sci-libs/netcdf-cxx/files/netcdf-cxx-4.2-config.patch8
-rw-r--r--sci-libs/netcdf-cxx/netcdf-cxx-4.2.1-r1.ebuild40
2 files changed, 44 insertions, 4 deletions
diff --git a/sci-libs/netcdf-cxx/files/netcdf-cxx-4.2-config.patch b/sci-libs/netcdf-cxx/files/netcdf-cxx-4.2-config.patch
index 7d83b6d0dfc1..50b6b478bdb1 100644
--- a/sci-libs/netcdf-cxx/files/netcdf-cxx-4.2-config.patch
+++ b/sci-libs/netcdf-cxx/files/netcdf-cxx-4.2-config.patch
@@ -1,5 +1,5 @@
---- ncxx4-config.in.orig 2013-01-10 10:47:00.595224631 -0800
-+++ ncxx4-config.in 2013-01-10 10:49:22.856926765 -0800
+--- netcdf-cxx4-4.2.1/ncxx4-config.in.orig 2013-01-10 10:47:00.595224631 -0800
++++ netcdf-cxx4-4.2.1/ncxx4-config.in 2013-01-10 10:49:22.856926765 -0800
@@ -5,7 +5,7 @@
prefix=@prefix@
@@ -18,8 +18,8 @@
flibs="-L${libdir} @NC_FLIBS@"
has_dap="@HAS_DAP@"
has_nc2="@HAS_NC2@"
---- netcdf-cxx4.pc.in.orig 2013-01-10 10:46:50.995177250 -0800
-+++ netcdf-cxx4.pc.in 2013-01-10 10:49:45.030036161 -0800
+--- netcdf-cxx4-4.2.1/netcdf-cxx4.pc.in.orig 2013-01-10 10:46:50.995177250 -0800
++++ netcdf-cxx4-4.2.1/netcdf-cxx4.pc.in 2013-01-10 10:49:45.030036161 -0800
@@ -10,4 +10,4 @@
Version: @PACKAGE_VERSION@
Libs: -L${libdir} @NC_LIBS@
diff --git a/sci-libs/netcdf-cxx/netcdf-cxx-4.2.1-r1.ebuild b/sci-libs/netcdf-cxx/netcdf-cxx-4.2.1-r1.ebuild
new file mode 100644
index 000000000000..39264444b673
--- /dev/null
+++ b/sci-libs/netcdf-cxx/netcdf-cxx-4.2.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+MYP=${PN}4-${PV}
+
+DESCRIPTION="C++ library for netCDF"
+HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="https://github.com/Unidata/netcdf-cxx4/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="UCAR-Unidata"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples static-libs"
+
+RDEPEND=">=sci-libs/netcdf-4.2:=[hdf5]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYP}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.2-config.patch"
+)
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+ prune_libtool_files
+}