summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-19 12:37:19 +0000
committerSam James <sam@gentoo.org>2021-02-19 12:45:43 +0000
commit89d76e7b713f6af83193c6a6d034b878bc49a414 (patch)
tree74f683dfadf8db9d5310ec1d1fb3546ab4fa4fed /sci-libs/netcdf-fortran
parentsci-libs/getdata: workaround gcc 10 (fortran) failure (diff)
downloadgentoo-89d76e7b713f6af83193c6a6d034b878bc49a414.tar.gz
gentoo-89d76e7b713f6af83193c6a6d034b878bc49a414.tar.bz2
gentoo-89d76e7b713f6af83193c6a6d034b878bc49a414.zip
sci-libs/netcdf-fortran: workaround gcc 10 (fortran) failure
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/netcdf-fortran')
-rw-r--r--sci-libs/netcdf-fortran/netcdf-fortran-4.4.3.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sci-libs/netcdf-fortran/netcdf-fortran-4.4.3.ebuild b/sci-libs/netcdf-fortran/netcdf-fortran-4.4.3.ebuild
index b4fd58838d7b..07be294b26c9 100644
--- a/sci-libs/netcdf-fortran/netcdf-fortran-4.4.3.ebuild
+++ b/sci-libs/netcdf-fortran/netcdf-fortran-4.4.3.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
FORTRAN_STANDARD="77 90"
-inherit autotools eutils fortran-2 ltprune
+inherit autotools eutils fortran-2 flag-o-matic ltprune
DESCRIPTION="Scientific library and interface for array oriented data access"
HOMEPAGE="https://www.unidata.ucar.edu/software/netcdf/"
@@ -30,6 +30,10 @@ src_prepare() {
}
src_configure() {
+ # GCC 10 workaround
+ # bug #723274
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
econf $(use_enable static-libs static)
}