summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2017-01-17 21:04:21 -0700
committerChristoph Junghans <junghans@gentoo.org>2017-01-17 21:04:21 -0700
commit27391030a177df42543e32afd77abbbabbd0073d (patch)
tree5836c44033c88fb2046173ccb489bef4ac4ca229 /sci-libs/nfft
parentmedia-libs/t1lib: security cleanup wrt bug #358667 (diff)
downloadgentoo-27391030a177df42543e32afd77abbbabbd0073d.tar.gz
gentoo-27391030a177df42543e32afd77abbbabbd0073d.tar.bz2
gentoo-27391030a177df42543e32afd77abbbabbd0073d.zip
sci-libs/nfft: version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-libs/nfft')
-rw-r--r--sci-libs/nfft/Manifest2
-rw-r--r--sci-libs/nfft/metadata.xml5
-rw-r--r--sci-libs/nfft/nfft-3.2.3.ebuild32
-rw-r--r--sci-libs/nfft/nfft-3.3.2.ebuild50
4 files changed, 55 insertions, 34 deletions
diff --git a/sci-libs/nfft/Manifest b/sci-libs/nfft/Manifest
index 51833b3917aa..8f1d341ed232 100644
--- a/sci-libs/nfft/Manifest
+++ b/sci-libs/nfft/Manifest
@@ -1 +1 @@
-DIST nfft-3.2.3.tar.gz 3977407 SHA256 5c920f4be63230083756f36ad78bbdd083c4c2298ec361741dc74243c4d67818 SHA512 d7b3345e0917e8dad9931adc5974f3412a82feda2d43925fe83fa4027f36cf037d4e185da85c53c87dc2e56a72f28c52b6b6a7ac56275d96888238a95610949e WHIRLPOOL 83e3445ed58a3b711762664f1776672239b51e085a4b52b90c47b2643445963697243ca6e36250f3a15576b36fb4dccb2772e867190393f0e7e9dc09873cc0dd
+DIST nfft-3.3.2.tar.gz 2821259 SHA256 9dcebd905a82c4f0a339d0d5e666b68c507169d9173b66d5ac588aae5d50b57c SHA512 66bcd2439c9ba27063aa1db01c526a580c5c67938e2db332068ce20035ede1d8766e8f134a0e5dac5263aca14121573ca4f5a906b452c43f218636f5f6161c02 WHIRLPOOL 9e15d7517d504a37b15b221a850e0b6574aeefc9af70d2a265bd0f2aa37f8a498462697c5ab73c47a4487f58978cf0cdd74d58e3073dc2b54361f0a216aba8c5
diff --git a/sci-libs/nfft/metadata.xml b/sci-libs/nfft/metadata.xml
index bcb918201969..b759151e3dc4 100644
--- a/sci-libs/nfft/metadata.xml
+++ b/sci-libs/nfft/metadata.xml
@@ -5,8 +5,11 @@
<email>junghans@gentoo.org</email>
<name>Christoph Junghans</name>
</maintainer>
-<maintainer type="project">
+ <maintainer type="project">
<email>sci@gentoo.org</email>
<name>Gentoo Science Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">NFFT/nfft</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/sci-libs/nfft/nfft-3.2.3.ebuild b/sci-libs/nfft/nfft-3.2.3.ebuild
deleted file mode 100644
index e6f5802bab27..000000000000
--- a/sci-libs/nfft/nfft-3.2.3.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit autotools-utils toolchain-funcs
-
-DESCRIPTION="library for nonequispaced discrete Fourier transformations"
-HOMEPAGE="http://www-user.tu-chemnitz.de/~potts/nfft"
-SRC_URI="http://www-user.tu-chemnitz.de/~potts/nfft/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="openmp static-libs"
-
-RDEPEND="sci-libs/fftw:3.0[threads,openmp?]"
-DEPEND="${RDEPEND}"
-
-pkg_pretend() {
- use openmp && ! tc-has-openmp && \
- die "Please switch to an openmp compatible compiler"
-}
-
-src_configure() {
- local myeconfargs=(
- --enable-all
- $(use_enable openmp)
- )
- autotools-utils_src_configure
-}
diff --git a/sci-libs/nfft/nfft-3.3.2.ebuild b/sci-libs/nfft/nfft-3.3.2.ebuild
new file mode 100644
index 000000000000..46c22173244f
--- /dev/null
+++ b/sci-libs/nfft/nfft-3.3.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="library for nonequispaced discrete Fourier transformations"
+HOMEPAGE="http://www-user.tu-chemnitz.de/~potts/nfft"
+SRC_URI="https://github.com/NFFT/nfft/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc openmp static-libs"
+
+RDEPEND="sci-libs/fftw:3.0[threads,openmp?]"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ if ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected compiler"
+
+ if tc-is-clang; then
+ ewarn "OpenMP support in sys-devel/clang is provided by sys-libs/libomp,"
+ ewarn "which you will need to build ${CATEGORY}/${PN} with USE=\"openmp\""
+ fi
+
+ die "need openmp capable compiler"
+ fi
+ fi
+}
+
+src_configure() {
+ econf \
+ --enable-all \
+ --enable-shared \
+ $(use_enable openmp) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use doc || rm -r "${ED}/usr/share/doc/${P}/html" || die
+
+ # infft uses pkg-config to record its private dependencies
+ find "${ED}" -name '*.la' -delete || die
+}