summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-28 11:53:39 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-28 12:26:51 +0100
commit6a4b07fb26999efa7b5627ed31fad3732fa0860c (patch)
tree3f44a6a411de2400d616a32bbe0567c60494ae49 /sci-libs/octomap/octomap-9999.ebuild
parentdev-ros/urdf_parser_plugin: remove old (diff)
downloadgentoo-6a4b07fb26999efa7b5627ed31fad3732fa0860c.tar.gz
gentoo-6a4b07fb26999efa7b5627ed31fad3732fa0860c.tar.bz2
gentoo-6a4b07fb26999efa7b5627ed31fad3732fa0860c.zip
sci-libs/octomap: Bump to 1.8.1 and install package.xml in our custom gentoo path from ebuild instead of patching.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-libs/octomap/octomap-9999.ebuild')
-rw-r--r--sci-libs/octomap/octomap-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sci-libs/octomap/octomap-9999.ebuild b/sci-libs/octomap/octomap-9999.ebuild
index 19df370fdb02..a80cadce5c00 100644
--- a/sci-libs/octomap/octomap-9999.ebuild
+++ b/sci-libs/octomap/octomap-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -40,7 +40,6 @@ DEPEND="${RDEPEND}
media-gfx/graphviz
)
"
-PATCHES=( "${FILESDIR}/gentoo.patch" )
src_prepare() {
sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
@@ -79,4 +78,11 @@ src_install() {
doins -r "${S}/dynamicEDT3D/doc/html/"*
fi
fi
+
+ insinto /usr/share/ros_packages/${PN}
+ doins "${ED}/usr/share/${PN}/package.xml"
+ if use qt4; then
+ insinto /usr/share/ros_packages/octovis
+ doins "${ED}/usr/share/octovis/package.xml"
+ fi
}