summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-01-13 10:51:50 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-01-13 13:16:22 +0100
commitf542cb05a15eb621c5fab56789558cd29955ac4b (patch)
tree16a539090fe73689be1050d4784732ee7f639ae1 /sci-libs/octomap/octomap-9999.ebuild
parentx11-libs/libQGLViewer: bump to 2.7.1. (diff)
downloadgentoo-f542cb05a15eb621c5fab56789558cd29955ac4b.tar.gz
gentoo-f542cb05a15eb621c5fab56789558cd29955ac4b.tar.bz2
gentoo-f542cb05a15eb621c5fab56789558cd29955ac4b.zip
sci-libs/octomap: bump to 1.9.0 and port to qt5
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-libs/octomap/octomap-9999.ebuild')
-rw-r--r--sci-libs/octomap/octomap-9999.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/sci-libs/octomap/octomap-9999.ebuild b/sci-libs/octomap/octomap-9999.ebuild
index 30141845c394..f5c2b0c615ac 100644
--- a/sci-libs/octomap/octomap-9999.ebuild
+++ b/sci-libs/octomap/octomap-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -21,15 +21,16 @@ fi
DESCRIPTION="An Efficient Probabilistic 3D Mapping Framework Based on Octrees"
HOMEPAGE="http://octomap.github.io/"
-IUSE="qt4 dynamicEDT3D doc"
-LICENSE="BSD qt4? ( GPL-2 )"
-SLOT="0"
+IUSE="qt5 dynamicEDT3D doc"
+LICENSE="BSD qt5? ( GPL-2 )"
+SLOT="0/19"
RDEPEND="
- qt4? (
+ qt5? (
virtual/opengl
- dev-qt/qtcore:4
- dev-qt/qtgui:4
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
x11-libs/libQGLViewer:=
)
"
@@ -44,12 +45,15 @@ src_prepare() {
sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
-i */CMakeLists.txt \
-i */CMakeModules/InstallPkgConfigFile.cmake || die
+ sed -e 's/iewer-qt4/iewer-qt5/g' \
+ -i octovis/CMakeModules/FindQGLViewer.cmake || die
cmake-utils_src_prepare
}
src_configure() {
local mycmakeargs=(
- "-DBUILD_OCTOVIS_SUBPROJECT=$(usex qt4 ON OFF)"
+ "-DBUILD_OCTOVIS_SUBPROJECT=$(usex qt5 ON OFF)"
+ "-DOCTOVIS_QT5=TRUE"
"-DBUILD_DYNAMICETD3D_SUBPROJECT=$(usex dynamicEDT3D ON OFF)"
)
cmake-utils_src_configure
@@ -80,7 +84,7 @@ src_install() {
insinto /usr/share/ros_packages/${PN}
doins "${ED}/usr/share/${PN}/package.xml"
- if use qt4; then
+ if use qt5; then
insinto /usr/share/ros_packages/octovis
doins "${ED}/usr/share/octovis/package.xml"
fi