summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-06-29 16:28:45 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-06-29 16:32:01 +0200
commitce028372069fd6bd77c1d6081452601dc1392ed0 (patch)
tree5595448504e074b3e28d555943839e8012be1993 /sci-libs/octomap
parentsci-mathematics/why3-for-spark: disable hypothesis-selection (diff)
downloadgentoo-ce028372069fd6bd77c1d6081452601dc1392ed0.tar.gz
gentoo-ce028372069fd6bd77c1d6081452601dc1392ed0.tar.bz2
gentoo-ce028372069fd6bd77c1d6081452601dc1392ed0.zip
sci-libs/octomap: bump to 1.9.7
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'sci-libs/octomap')
-rw-r--r--sci-libs/octomap/Manifest2
-rw-r--r--sci-libs/octomap/files/qglqt5.patch231
-rw-r--r--sci-libs/octomap/octomap-1.9.7.ebuild (renamed from sci-libs/octomap/octomap-1.9.5.ebuild)3
3 files changed, 1 insertions, 235 deletions
diff --git a/sci-libs/octomap/Manifest b/sci-libs/octomap/Manifest
index bd5f56925609..86ee75a8455f 100644
--- a/sci-libs/octomap/Manifest
+++ b/sci-libs/octomap/Manifest
@@ -1 +1 @@
-DIST octomap-1.9.5.tar.gz 1682781 BLAKE2B 1ced023160d10c424d4bff76a0481ffe6c87c5bf8133480afe6c47ee0ee116304a811293cc0af0b303ebcad370b7ce433e85212f070ac921a9c5be41905a94ea SHA512 e58c6d33c351b14e9596e18a8702715d167c136fd029b1078ddd13a5926fe451d3b619231b5a8ccfb64b6e5fc6db8b57e6ef329099828d2f5195c0988700b581
+DIST octomap-1.9.7.tar.gz 1684088 BLAKE2B 357b574f770d553a51c936c84772c729754a822e1c1e840a179a2cb3d3ef1b15f1c7173a4333b1262b10aa5d2f64d1b1c063ad90d4cc0edfcbaee9799ceb24a8 SHA512 639ff65cf020865d5302ba9785089782aec1e46496982c11bbf86919b6938c01c7921d84e60880091b89a949dd05f4d1151871f63503d19342462b74e6791ddd
diff --git a/sci-libs/octomap/files/qglqt5.patch b/sci-libs/octomap/files/qglqt5.patch
deleted file mode 100644
index 3fad0a0fc63f..000000000000
--- a/sci-libs/octomap/files/qglqt5.patch
+++ /dev/null
@@ -1,231 +0,0 @@
-Index: octomap-1.9.0/octovis/src/ViewerGui.cpp
-===================================================================
---- octomap-1.9.0.orig/octovis/src/ViewerGui.cpp
-+++ octomap-1.9.0/octovis/src/ViewerGui.cpp
-@@ -286,7 +286,7 @@ void ViewerGui::showOcTree() {
- m_mapSizeStatus->setText(size);
- //}
-
-- m_glwidget->updateGL();
-+ m_glwidget->update();
-
- // generate cubes -> display
- // timeval start;
-@@ -299,7 +299,7 @@ void ViewerGui::showOcTree() {
- // gettimeofday(&stop, NULL); // stop timer
- // double time_to_generate = (stop.tv_sec - start.tv_sec) + 1.0e-6 *(stop.tv_usec - start.tv_usec);
- // fprintf(stderr, "setOcTree took %f sec\n", time_to_generate);
-- m_glwidget->updateGL();
-+ m_glwidget->update();
- }
-
-
-@@ -983,7 +983,7 @@ void ViewerGui::on_actionSelection_box_t
- m_glwidget->enableSelectionBox(checked);
-
-
-- m_glwidget->updateGL();
-+ m_glwidget->update();
- }
-
- void ViewerGui::on_actionHeight_map_toggled(bool checked){
-@@ -1040,7 +1040,7 @@ void ViewerGui::on_actionAxes_toggled(bo
- it != m_octrees.end(); ++it) {
- it->second.octree_drawer->enableAxes(checked);
- }
-- m_glwidget->updateGL();
-+ m_glwidget->update();
- }
-
- void ViewerGui::on_actionHideBackground_toggled(bool checked) {
-@@ -1048,7 +1048,7 @@ void ViewerGui::on_actionHideBackground_
- if (getOctreeRecord(DEFAULT_OCTREE_ID, r)) {
- if (checked) m_glwidget->removeSceneObject(r->octree_drawer);
- else m_glwidget->addSceneObject(r->octree_drawer);
-- m_glwidget->updateGL();
-+ m_glwidget->update();
- }
- }
-
-@@ -1142,7 +1142,7 @@ void ViewerGui::on_actionOctree_cells_to
- it != m_octrees.end(); ++it) {
- it->second.octree_drawer->enableOcTreeCells(enabled);
- }
-- m_glwidget->updateGL();
-+ m_glwidget->update();
- }
-
- void ViewerGui::on_actionOctree_structure_toggled(bool enabled) {
-@@ -1150,7 +1150,7 @@ void ViewerGui::on_actionOctree_structur
- it != m_octrees.end(); ++it) {
- it->second.octree_drawer->enableOcTree(enabled);
- }
-- m_glwidget->updateGL();
-+ m_glwidget->update();
- }
-
- void ViewerGui::on_actionFree_toggled(bool enabled) {
-@@ -1158,7 +1158,7 @@ void ViewerGui::on_actionFree_toggled(bo
- it != m_octrees.end(); ++it) {
- it->second.octree_drawer->enableFreespace(enabled);
- }
-- m_glwidget->updateGL();
-+ m_glwidget->update();
-
- }
-
-@@ -1176,24 +1176,21 @@ void ViewerGui::on_actionSelected_toggle
- // } else{
- // m_octreeDrawer->clearOcTreeSelection();
- // }
-- // m_glwidget->updateGL();
-+ // m_glwidget->update();
- // }
- }
-
-
- void ViewerGui::on_action_bg_black_triggered() {
- m_glwidget->setBackgroundColor( QColor(0,0,0) );
-- m_glwidget->qglClearColor( m_glwidget->backgroundColor() );
- }
-
- void ViewerGui::on_action_bg_white_triggered() {
- m_glwidget->setBackgroundColor( QColor(255,255,255) );
-- m_glwidget->qglClearColor( m_glwidget->backgroundColor() );
- }
-
- void ViewerGui::on_action_bg_gray_triggered() {
- m_glwidget->setBackgroundColor( QColor(117,117,117) );
-- m_glwidget->qglClearColor( m_glwidget->backgroundColor() );
- }
-
- void ViewerGui::on_savecampose_triggered() {
-Index: octomap-1.9.0/octovis/src/ViewerWidget.cpp
-===================================================================
---- octomap-1.9.0.orig/octovis/src/ViewerWidget.cpp
-+++ octomap-1.9.0/octovis/src/ViewerWidget.cpp
-@@ -67,13 +67,12 @@ void ViewerWidget::init() {
-
- // background color defaults to white
- this->setBackgroundColor( QColor(255,255,255) );
-- this->qglClearColor( this->backgroundColor() );
- }
-
- void ViewerWidget::resetView(){
- this->camera()->setOrientation((float) -M_PI_2, (float) M_PI_2);
- this->showEntireScene();
-- updateGL();
-+ update();
- }
-
-
-@@ -98,7 +97,7 @@ void ViewerWidget::enableHeightColorMode
- for(std::vector<SceneObject*>::iterator it = m_sceneObjects.begin(); it != m_sceneObjects.end(); it++) {
- (*it)->enableHeightColorMode(enabled);
- }
-- updateGL();
-+ update();
- }
-
- void ViewerWidget::enablePrintoutMode(bool enabled) {
-@@ -106,7 +105,7 @@ void ViewerWidget::enablePrintoutMode(bo
- for(std::vector<SceneObject*>::iterator it = m_sceneObjects.begin(); it != m_sceneObjects.end(); it++) {
- (*it)->enablePrintoutMode(enabled);
- }
-- updateGL();
-+ update();
- }
-
- void ViewerWidget::enableSemanticColoring (bool enabled) {
-@@ -114,12 +113,12 @@ void ViewerWidget::enableSemanticColorin
- for(std::vector<SceneObject*>::iterator it = m_sceneObjects.begin(); it != m_sceneObjects.end(); it++) {
- (*it)->enableSemanticColoring(enabled);
- }
-- updateGL();
-+ update();
- }
-
- void ViewerWidget::enableSelectionBox(bool enabled) {
- m_drawSelectionBox = enabled;
-- updateGL();
-+ update();
- }
-
-
-@@ -145,7 +144,7 @@ void ViewerWidget::setCamPosition(double
- camera()->setPosition(qglviewer::Vec(x, y, z));
- camera()->lookAt(qglviewer::Vec(lookX, lookY, lookZ));
- camera()->setUpVector(qglviewer::Vec(0.0, 0.0, 1.0));
-- updateGL();
-+ update();
- }
-
- void ViewerWidget::setCamPose(const octomath::Pose6D& pose){
-@@ -161,12 +160,12 @@ void ViewerWidget::jumpToCamFrame(int id
- } else {
- std::cerr << "Error: Could not jump to frame " << frame << " of " << kfi->numberOfKeyFrames() << std::endl;
- }
-- updateGL();
-+ update();
- }
-
- void ViewerWidget::deleteCameraPath(int id) {
- if(camera()->keyFrameInterpolator(id)) {
-- disconnect(camera()->keyFrameInterpolator(id), SIGNAL(interpolated()), this, SLOT(updateGL()));
-+ disconnect(camera()->keyFrameInterpolator(id), SIGNAL(interpolated()), this, SLOT(update()));
- disconnect(camera()->keyFrameInterpolator(id), SIGNAL(interpolated()), this, SLOT(cameraPathInterpolated()));
- disconnect(camera()->keyFrameInterpolator(id), SIGNAL(endReached()), this, SLOT(cameraPathFinished()));
- camera()->deletePath(id);
-@@ -243,7 +242,7 @@ void ViewerWidget::playCameraPath(int id
- m_current_camera_frame = start_frame;
- kfi->setInterpolationTime(kfi->keyFrameTime(start_frame));
- std::cout << "Playing path of length " << kfi->numberOfKeyFrames() << ", start time " << kfi->keyFrameTime(start_frame) << std::endl;
-- connect(kfi, SIGNAL(interpolated()), this, SLOT(updateGL()));
-+ connect(kfi, SIGNAL(interpolated()), this, SLOT(update()));
- connect(kfi, SIGNAL(interpolated()), this, SLOT(cameraPathInterpolated()));
- connect(kfi, SIGNAL(endReached()), this, SLOT(cameraPathFinished()));
- kfi->startInterpolation();
-@@ -252,7 +251,7 @@ void ViewerWidget::playCameraPath(int id
-
- void ViewerWidget::stopCameraPath(int id) {
- if(camera()->keyFrameInterpolator(id) && camera()->keyFrameInterpolator(id)->interpolationIsStarted()) {
-- disconnect(camera()->keyFrameInterpolator(id), SIGNAL(interpolated()), this, SLOT(updateGL()));
-+ disconnect(camera()->keyFrameInterpolator(id), SIGNAL(interpolated()), this, SLOT(update()));
- disconnect(camera()->keyFrameInterpolator(id), SIGNAL(interpolated()), this, SLOT(cameraPathInterpolated()));
- disconnect(camera()->keyFrameInterpolator(id), SIGNAL(endReached()), this, SLOT(cameraPathFinished()));
- camera()->keyFrameInterpolator(id)->stopInterpolation();
-@@ -261,7 +260,7 @@ void ViewerWidget::stopCameraPath(int id
-
- void ViewerWidget::cameraPathFinished() {
- if(camera()->keyFrameInterpolator(m_current_camera_path)) {
-- disconnect(camera()->keyFrameInterpolator(m_current_camera_path), SIGNAL(interpolated()), this, SLOT(updateGL()));
-+ disconnect(camera()->keyFrameInterpolator(m_current_camera_path), SIGNAL(interpolated()), this, SLOT(update()));
- disconnect(camera()->keyFrameInterpolator(m_current_camera_path), SIGNAL(interpolated()), this, SLOT(cameraPathInterpolated()));
- disconnect(camera()->keyFrameInterpolator(m_current_camera_path), SIGNAL(endReached()), this, SLOT(cameraPathFinished()));
- emit cameraPathStopped(m_current_camera_path);
-@@ -292,7 +291,7 @@ void ViewerWidget::setSceneBoundingBox(c
- void ViewerWidget::addSceneObject(SceneObject* obj){
- assert (obj);
- m_sceneObjects.push_back(obj);
-- updateGL();
-+ update();
- }
-
- void ViewerWidget::removeSceneObject(SceneObject* obj){
-@@ -304,7 +303,7 @@ void ViewerWidget::removeSceneObject(Sce
- else
- ++it;
- }
-- updateGL();
-+ update();
- }
-
- void ViewerWidget::clearAll(){
-@@ -364,7 +363,6 @@ void ViewerWidget::postDraw(){
- glPushAttrib(GL_ALL_ATTRIB_BITS);
-
- glDisable(GL_COLOR_MATERIAL);
-- qglColor(foregroundColor());
-
- if (gridIsDrawn()){
- glLineWidth(1.0);
diff --git a/sci-libs/octomap/octomap-1.9.5.ebuild b/sci-libs/octomap/octomap-1.9.7.ebuild
index b38b3ab44bfe..9d9bd32c85f7 100644
--- a/sci-libs/octomap/octomap-1.9.5.ebuild
+++ b/sci-libs/octomap/octomap-1.9.7.ebuild
@@ -30,9 +30,6 @@ BDEPEND="${RDEPEND}
)
"
-# https://github.com/OctoMap/octomap/issues/194
-PATCHES=( "${FILESDIR}/qglqt5.patch" )
-
src_prepare() {
rm -r octovis/src/extern