summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2021-10-22 10:53:12 +0200
committerSam James <sam@gentoo.org>2021-10-24 04:06:04 +0000
commit5480f8d93ea900ea085b9de0be2f6b14f668eacf (patch)
tree22e2a6ccd52482a351c4024b36fe31172c45c353 /sci-libs/opencascade
parentmedia-libs/libavif: sync live ebuild (diff)
downloadgentoo-5480f8d93ea900ea085b9de0be2f6b14f668eacf.tar.gz
gentoo-5480f8d93ea900ea085b9de0be2f6b14f668eacf.tar.bz2
gentoo-5480f8d93ea900ea085b9de0be2f6b14f668eacf.zip
sci-libs/opencascade: bump to 7.5.3
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/22669 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/opencascade')
-rw-r--r--sci-libs/opencascade/Manifest1
-rw-r--r--sci-libs/opencascade/opencascade-7.5.3.ebuild171
2 files changed, 172 insertions, 0 deletions
diff --git a/sci-libs/opencascade/Manifest b/sci-libs/opencascade/Manifest
index 29f10ccec88c..a6e46ffdc98b 100644
--- a/sci-libs/opencascade/Manifest
+++ b/sci-libs/opencascade/Manifest
@@ -1,3 +1,4 @@
DIST opencascade-7.4.0.tar.gz 49210449 BLAKE2B c92afe7551e9a066ad0940dcf49278b556a726f0534131706b3a11cb0986ba32818e162df3982283f6815eb9d67d7e91f909485d78f2b8d638da1934ffbc2f7f SHA512 eb0d47848d48f42a159ae5d7a4144483ba1f59f634844bd2053e48e04af30a30ba7056112cd38a1730d193a8d736b898f9608dd574cbe6829dbe7257a002772a
DIST opencascade-7.5.1.tar.gz 47807222 BLAKE2B b5ef30ea7c373250db3e0863f3c7fde84256b37957a482f10a462a4c4ed1a21cffbbeb10e9fc140325022d7582efbd292ed6d1016d14cb67ccf5c84d14060d5a SHA512 ebb937254ac165041ef7e1a80df8f9d2ac1d518f01b3d4b0fd6d203fe0d80bd474b85a462cccc1c74a513bd257c0b0ab7002632573f38bf72170363c7e42ed2f
DIST opencascade-7.5.2.tar.gz 47812603 BLAKE2B 86995ea60e24329f91a2cbede26112a70794fb091b34d33614bef412b05b8cc9f1e770aecf78272b54a241c2524422c86f8ff722b3f27b54bf10fa5eda626288 SHA512 f951a941043a56f381cfd25e4d78bb9ae08e5cc29a894e6c0c35daf30aeabf1e44ee09af65bb6b7d62d9325be67741ddcf52266b7186b4c336c70ed8bcfa1676
+DIST opencascade-7.5.3.tar.gz 47817862 BLAKE2B be438a08997c18c3cb2c08c520fff2f439cc8a406cc3f471be3b24f874ac3bd892c4afe6fa37f742ffb5da21b5a29f9c8f737e3160dcbda35a217286218eb5e1 SHA512 2d7cf284a1b3ce8d05151085b41579cc2f4e29489b7920769cd04f86a6d76e49f533b570226d3cf041c75582894ed8a6aff889312c7c507fffae47d3e57c5c47
diff --git a/sci-libs/opencascade/opencascade-7.5.3.ebuild b/sci-libs/opencascade/opencascade-7.5.3.ebuild
new file mode 100644
index 000000000000..23b32a161225
--- /dev/null
+++ b/sci-libs/opencascade/opencascade-7.5.3.ebuild
@@ -0,0 +1,171 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+MY_PV="$(ver_rs 1- '_')"
+PV_MAJ="$(ver_cut 1-2)"
+
+DESCRIPTION="Development platform for CAD/CAE, 3D surface/solid modeling and data exchange"
+HOMEPAGE="https://www.opencascade.com"
+SRC_URI="https://git.dev.opencascade.org/gitweb/?p=occt.git;a=snapshot;h=refs/tags/V${MY_PV};sf=tgz -> ${P}.tar.gz"
+S="${WORKDIR}/occt-V${MY_PV}"
+
+LICENSE="|| ( Open-CASCADE-LGPL-2.1-Exception-1.0 LGPL-2.1 )"
+SLOT="${PV_MAJ}"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="debug doc examples ffmpeg freeimage gles2 json optimize tbb vtk"
+
+REQUIRED_USE="?? ( optimize tbb )"
+
+# There's no easy way to test. Testing needs a rather big environment
+# properly set up.
+RESTRICT="test"
+
+RDEPEND="
+ app-eselect/eselect-opencascade
+ dev-lang/tcl:=
+ dev-lang/tk:=
+ dev-tcltk/itcl
+ dev-tcltk/itk
+ dev-tcltk/tix
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/ftgl
+ virtual/glu
+ virtual/opengl
+ x11-libs/libXmu
+ examples? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ )
+ ffmpeg? ( media-video/ffmpeg:= )
+ freeimage? ( media-libs/freeimage )
+ tbb? ( dev-cpp/tbb )
+ vtk? ( sci-libs/vtk:=[rendering] )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/eigen
+ dev-libs/rapidjson
+"
+BDEPEND="
+ app-eselect/eselect-opencascade
+ doc? ( app-doc/doxygen )
+ examples? ( dev-qt/linguist-tools:5 )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.5.1-0001-allow-default-search-path-for-Qt5.patch
+ "${FILESDIR}"/${PN}-7.5.1-0002-remove-unnecessary-Qt5-check.patch
+ "${FILESDIR}"/${PN}-7.5.1-0003-add-Gentoo-configuration-type.patch
+ "${FILESDIR}"/${PN}-7.5.1-0004-fix-installation-of-cmake-config-files.patch
+ "${FILESDIR}"/${PN}-7.5.1-0005-fix-write-permissions-on-scripts.patch
+ "${FILESDIR}"/${PN}-7.5.1-0006-fix-creation-of-custom.sh-script.patch
+ "${FILESDIR}"/${PN}-7.5.1-fix-AllValues-name-collision-with-vtk-9.0.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ use debug && append-cppflags -DDEBUG
+
+ sed -e 's|/lib\$|/'$(get_libdir)'\$|' \
+ -i adm/templates/OpenCASCADEConfig.cmake.in || die
+
+ # There is an OCCT_UPDATE_TARGET_FILE cmake macro that fails due to some
+ # assumptions it makes about installation paths. Rather than fixing it, just
+ # get rid of the mechanism altogether - its purpose is to allow a
+ # side-by-side installation of release and debug libraries.
+ sed -e 's|\\${OCCT_INSTALL_BIN_LETTER}||' \
+ -i adm/cmake/occt_toolkit.cmake || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOC_Overview=$(usex doc)
+ -DBUILD_Inspector=$(usex examples)
+ -DBUILD_WITH_DEBUG=$(usex debug)
+ -DINSTALL_DIR_BIN="$(get_libdir)/${P}/bin"
+ -DINSTALL_DIR_CMAKE="$(get_libdir)/cmake/${P}"
+ -DINSTALL_DIR_DOC="share/doc/${PF}"
+ -DINSTALL_DIR_LIB="$(get_libdir)/${P}"
+ -DINSTALL_DIR_SCRIPT="$(get_libdir)/${P}/bin"
+ -DINSTALL_DIR_WITH_VERSION=ON
+ -DINSTALL_SAMPLES=$(usex examples)
+ -DINSTALL_TEST_CASES=NO
+ -DUSE_D3D=NO
+ -DUSE_FFMPEG=$(usex ffmpeg)
+ -DUSE_FREEIMAGE=$(usex freeimage)
+ -DUSE_FREETYPE=ON
+ -DUSE_GLES2=$(usex gles2)
+ -DUSE_RAPIDJSON=$(usex json)
+ -DUSE_TBB=$(usex tbb)
+ -DUSE_VTK=$(usex vtk)
+ )
+
+ use doc && mycmakeargs+=( -DINSTALL_DOC_Overview=ON )
+
+ if use examples; then
+ mycmakeargs+=(
+ -D3RDPARTY_QT_DIR="${ESYSROOT}"/usr
+ -DBUILD_SAMPLES_QT=ON
+ )
+ fi
+
+ if use vtk; then
+ if has_version ">=sci-libs/vtk-9.0.0"; then
+ mycmakeargs+=(
+ -D3RDPARTY_VTK_DIR="${ESYSROOT}"/usr
+ -D3RDPARTY_VTK_INCLUDE_DIR="${ESYSROOT}"/usr/include/vtk-9.0
+ -D3RDPARTY_VTK_LIBRARY_DIR="${ESYSROOT}"/usr/$(get_libdir)
+ )
+ fi
+ fi
+
+ cmake_src_configure
+
+ # prepare /etc/env.d file
+ sed -e "s|lib/|$(get_libdir)/|" \
+ -e "s|VAR_PV|${PV}|" \
+ -e "s|VAR_CASROOT|${ESYSROOT}/usr|" \
+ < "${FILESDIR}"/${PN}-${PV_MAJ}.env.in > "${T}"/${PV_MAJ} || die
+
+ # use TBB for memory allocation optimizations
+ if use tbb; then
+ sed -e 's|^#MMGT_OPT=0$|MMGT_OPT=2|' -i "${T}"/${PV_MAJ} || die
+ fi
+
+ # use internal optimized memory manager and don't clear memory with this
+ # memory manager.
+ if use optimize ; then
+ sed -e 's|^#MMGT_OPT=0$|MMGT_OPT=1|' \
+ -e 's|^#MMGT_CLEAR=1$|MMGT_CLEAR=0|' \
+ -i "${T}"/${PV_MAJ} || die
+ fi
+}
+
+src_install() {
+ cmake_src_install
+
+ # respect slotting
+ insinto "/etc/env.d/${PN}"
+ doins "${T}/${PV_MAJ}"
+
+ # remove examples
+ if use !examples; then
+ rm -r "${ED}/usr/share/${P}/samples" || die
+ fi
+
+ docompress -x /usr/share/doc/${PF}/overview/html
+}
+
+pkg_postinst() {
+ eselect ${PN} set ${PV_MAJ} || die "failed to switch to updated implementation"
+ einfo "You can switch between available ${PN} implementations using eselect ${PN}"
+}