summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/openfoam-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/openfoam-bin')
-rw-r--r--sci-libs/openfoam-bin/Manifest4
-rw-r--r--sci-libs/openfoam-bin/metadata.xml16
-rw-r--r--sci-libs/openfoam-bin/openfoam-bin-1.6.ebuild107
3 files changed, 127 insertions, 0 deletions
diff --git a/sci-libs/openfoam-bin/Manifest b/sci-libs/openfoam-bin/Manifest
new file mode 100644
index 000000000000..cd8a5f1b744c
--- /dev/null
+++ b/sci-libs/openfoam-bin/Manifest
@@ -0,0 +1,4 @@
+DIST OpenFOAM-1.6-compile.patch.bz2 5835 SHA256 633966faf70ffb0acbb1684075630cf9a3028b7099e3fcee549d8c850d55b794
+DIST OpenFOAM-1.6.General.tgz 241760751 SHA256 a752d8e70ad26b84d6939e32e443e341f4cafecaff0068c0cc85c43562d21f9a
+DIST OpenFOAM-1.6.linux64GccDPOpt.tgz 44957838 SHA256 58b825423a3fcc7015aa60905c7e65a344908e7e5f8740baeed6cd17fb5bb14d
+DIST OpenFOAM-1.6.linuxGccDPOpt.tgz 41587474 SHA256 3c551134c0e1a8700c1257e549820d4cf6cbe50c6435ab5dbddb1e4b6123dac0
diff --git a/sci-libs/openfoam-bin/metadata.xml b/sci-libs/openfoam-bin/metadata.xml
new file mode 100644
index 000000000000..283d23bb5561
--- /dev/null
+++ b/sci-libs/openfoam-bin/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <maintainer>
+ <email>oli.borm@web.de</email>
+ <name>Oliver Borm</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">foam</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/openfoam-bin/openfoam-bin-1.6.ebuild b/sci-libs/openfoam-bin/openfoam-bin-1.6.ebuild
new file mode 100644
index 000000000000..7216f7e80a0c
--- /dev/null
+++ b/sci-libs/openfoam-bin/openfoam-bin-1.6.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils versionator multilib toolchain-funcs
+
+MY_PN="OpenFOAM"
+MY_PV=$(get_version_component_range 1-2)
+MY_P="${MY_PN}-${MY_PV}"
+
+use x86 && WM_OPTIONS="linuxGccDPOpt"
+use amd64 && WM_OPTIONS="linux64GccDPOpt"
+
+DESCRIPTION="Open Field Operation and Manipulation - CFD Simulation Toolbox"
+HOMEPAGE="http://www.opencfd.co.uk/openfoam/"
+SRC_URI="mirror://sourceforge/foam/${MY_P}.General.gtgz -> ${MY_P}.General.tgz
+ x86? ( mirror://sourceforge/foam/${MY_P}.linuxGccDPOpt.gtgz -> ${MY_P}.linuxGccDPOpt.tgz )
+ amd64? ( mirror://sourceforge/foam/${MY_P}.linux64GccDPOpt.gtgz -> ${MY_P}.linux64GccDPOpt.tgz )
+ mirror://gentoo/${MY_P}-compile.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="1.6"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="examples doc"
+
+DEPEND="!=sci-libs/openfoam-${MY_PV}*
+ !=sci-libs/openfoam-kernel-${MY_PV}*
+ !=sci-libs/openfoam-meta-${MY_PV}*
+ !=sci-libs/openfoam-solvers-${MY_PV}*
+ !=sci-libs/openfoam-utilities-${MY_PV}*
+ !=sci-libs/openfoam-wmake-${MY_PV}*
+ sci-visualization/opendx
+ virtual/mpi"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+INSDIR="/usr/$(get_libdir)/${MY_PN}/${MY_P}"
+
+pkg_setup() {
+ ## binaries are compiled with gcc-4.3.3
+ if ! version_is_at_least 4.3 $(gcc-version) ; then
+ die "${PN} requires >=sys-devel/gcc-4.3 in order to run."
+ fi
+
+ elog
+ elog "In order to use ${MY_PN} you should add the following line to ~/.bashrc :"
+ elog
+ elog "alias startOF$(delete_all_version_separators ${MY_PV})='source ${INSDIR}/etc/bashrc'"
+ elog
+ elog "And everytime you want to use OpenFOAM you have to execute startOF$(delete_all_version_separators ${MY_PV})"
+ ewarn
+ ewarn "FoamX is deprecated since ${MY_PN}-1.5! "
+ ewarn
+}
+
+src_prepare() {
+ epatch "${WORKDIR}"/${MY_P}-compile.patch
+}
+
+src_configure() {
+ if has_version sys-cluster/mpich2 ; then
+ export WM_MPLIB=MPICH
+ export MPI_VERSION=mpich
+ elif has_version sys-cluster/openmpi ; then
+ export WM_MPLIB=OPENMPI
+ export MPI_VERSION=openmpi
+ else
+ die "You need one of the following mpi implementations: openmpi, mpich2"
+ fi
+
+ sed -i -e "s|WM_MPLIB:=OPENMPI|WM_MPLIB:="${WM_MPLIB}"|" etc/bashrc
+ sed -i -e "s|setenv WM_MPLIB OPENMPI|setenv WM_MPLIB "${WM_MPLIB}"|" etc/cshrc
+
+ mv lib/${WM_OPTIONS}/$MPI_VERSION* lib/${WM_OPTIONS}/$MPI_VERSION
+}
+
+src_test() {
+ cd bin
+ ./foamInstallationTest
+}
+
+src_install() {
+ insinto ${INSDIR}
+ doins -r etc
+
+ use examples && doins -r tutorials
+
+ insopts -m0755
+ doins -r bin
+
+ insinto ${INSDIR}/applications/bin
+ doins -r applications/bin/${WM_OPTIONS}/*
+
+ insinto ${INSDIR}/lib
+ doins -r lib/${WM_OPTIONS}/*
+
+ insinto ${INSDIR}/wmake
+ doins -r wmake/*
+
+ dodoc {doc/Guides-a4/*.pdf,README}
+
+ if use doc ; then
+ dohtml -r doc/Doxygen
+ fi
+}