summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/plplot/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/plplot/files')
-rw-r--r--sci-libs/plplot/files/plplot-5.10.0-cmake.patch18
-rw-r--r--sci-libs/plplot/files/plplot-5.10.0-have-config-h.patch117
-rw-r--r--sci-libs/plplot/files/plplot-5.11.0-multiarch.patch60
-rw-r--r--sci-libs/plplot/files/plplot-5.11.0-ocaml.patch40
-rw-r--r--sci-libs/plplot/files/plplot-5.11.0-octave.patch16
-rw-r--r--sci-libs/plplot/files/plplot-5.9.11-multiarch.patch50
-rw-r--r--sci-libs/plplot/files/plplot-5.9.11-ocaml.patch34
-rw-r--r--sci-libs/plplot/files/plplot-5.9.11-octave.patch12
-rw-r--r--sci-libs/plplot/files/plplot-5.9.6-python.patch13
9 files changed, 360 insertions, 0 deletions
diff --git a/sci-libs/plplot/files/plplot-5.10.0-cmake.patch b/sci-libs/plplot/files/plplot-5.10.0-cmake.patch
new file mode 100644
index 000000000000..dbb0f829147b
--- /dev/null
+++ b/sci-libs/plplot/files/plplot-5.10.0-cmake.patch
@@ -0,0 +1,18 @@
+diff --git a/cmake/modules/pkg-config.cmake b/cmake/modules/pkg-config.cmake
+index 3f842aa..4d269bd 100644
+--- a/cmake/modules/pkg-config.cmake
++++ b/cmake/modules/pkg-config.cmake
+@@ -94,7 +94,12 @@ macro(pkg_check_pkgconfig _package _include_DIR _link_DIR _link_FLAGS _cflags _v
+ set(_xprefix ${_prefix})
+ endif(FORCE_EXTERNAL_STATIC)
+
+- _pkg_check_modules_internal(0 0 ${_prefix} "${_package}")
++ if(CMAKE_VERSION VERSION_LESS "3.1")
++ _pkg_check_modules_internal(0 0 ${_prefix} "${_package}")
++ else(CMAKE_VERSION VERSION_LESS "3.1")
++ _pkg_check_modules_internal(0 0 0 0 ${_prefix} "${_package}")
++ endif(CMAKE_VERSION VERSION_LESS "3.1")
++
+ if(${_prefix}_FOUND)
+ cmake_link_flags(${_link_FLAGS} "${${_xprefix}_LDFLAGS}")
+ # If libraries cannot be not found, then that is equivalent to whole
diff --git a/sci-libs/plplot/files/plplot-5.10.0-have-config-h.patch b/sci-libs/plplot/files/plplot-5.10.0-have-config-h.patch
new file mode 100644
index 000000000000..8c02df13941f
--- /dev/null
+++ b/sci-libs/plplot/files/plplot-5.10.0-have-config-h.patch
@@ -0,0 +1,117 @@
+Apply upstream patch http://sourceforge.net/p/plplot/bugs/146/
+to fix conflicting macros in installed header files.
+
+diff -Nur plplot-5.10.0.orig/CMakeLists.txt plplot-5.10.0/CMakeLists.txt
+--- plplot-5.10.0.orig/CMakeLists.txt 2014-04-07 09:51:53.732857993 -0700
++++ plplot-5.10.0/CMakeLists.txt 2014-04-07 09:54:03.739699328 -0700
+@@ -125,7 +125,7 @@
+ ${CMAKE_CURRENT_BINARY_DIR}/plplot_config.h
+ )
+ # Allow access to the generated plplot_config.h for this build.
+-add_definitions("-DHAVE_CONFIG_H")
++add_definitions("-DPLPLOT_HAVE_CONFIG_H")
+ # Install top-level files
+
+ # Enable testing framework for examples
+diff -Nur plplot-5.10.0.orig/bindings/ocaml/CMakeLists.txt plplot-5.10.0/bindings/ocaml/CMakeLists.txt
+--- plplot-5.10.0.orig/bindings/ocaml/CMakeLists.txt 2014-04-07 09:51:53.629857267 -0700
++++ plplot-5.10.0/bindings/ocaml/CMakeLists.txt 2014-04-07 09:54:03.934700592 -0700
+@@ -99,7 +99,7 @@
+ ${CMAKE_CURRENT_BINARY_DIR}/dllplplot_stubs.so
+ ${CMAKE_CURRENT_BINARY_DIR}/libplplot_stubs.a
+ COMMAND ${OCAMLC} -ccopt -I${CAMLIDL_LIB_DIR} -c ${CMAKE_CURRENT_BINARY_DIR}/plplot_core_stubs.c
+- COMMAND ${OCAMLC} -ccopt -I${CMAKE_SOURCE_DIR}/include -ccopt -I${CMAKE_BINARY_DIR}/include -ccopt -I${CMAKE_SOURCE_DIR}/lib/qsastime -ccopt -I${CMAKE_BINARY_DIR} -ccopt -I${CAMLIDL_LIB_DIR} -ccopt -DHAVE_CONFIG_H -c ${CMAKE_CURRENT_SOURCE_DIR}/plplot_impl.c
++ COMMAND ${OCAMLC} -ccopt -I${CMAKE_SOURCE_DIR}/include -ccopt -I${CMAKE_BINARY_DIR}/include -ccopt -I${CMAKE_SOURCE_DIR}/lib/qsastime -ccopt -I${CMAKE_BINARY_DIR} -ccopt -I${CAMLIDL_LIB_DIR} -ccopt -DPLPLOT_HAVE_CONFIG_H -c ${CMAKE_CURRENT_SOURCE_DIR}/plplot_impl.c
+ COMMAND ${OCAMLMKLIB} -o plplot_stubs -L${CAMLIDL_LIB_DIR} -lcamlidl -L${CMAKE_BINARY_DIR}/src -lplplot${LIB_TAG} ${CMAKE_CURRENT_BINARY_DIR}/plplot_core_stubs.o ${CMAKE_CURRENT_BINARY_DIR}/plplot_impl.o ${ocaml_STATIC_FLAGS}
+ DEPENDS
+ ${CMAKE_CURRENT_BINARY_DIR}/plplot_core_stubs.c
+diff -Nur plplot-5.10.0.orig/bindings/ocaml/plcairo/CMakeLists.txt plplot-5.10.0/bindings/ocaml/plcairo/CMakeLists.txt
+--- plplot-5.10.0.orig/bindings/ocaml/plcairo/CMakeLists.txt 2014-04-07 09:51:53.629857267 -0700
++++ plplot-5.10.0/bindings/ocaml/plcairo/CMakeLists.txt 2014-04-07 09:54:03.934700592 -0700
+@@ -36,7 +36,7 @@
+ ${CMAKE_CURRENT_BINARY_DIR}/plcairo_impl.o
+ ${CMAKE_CURRENT_BINARY_DIR}/dllplcairo_stubs.so
+ ${CMAKE_CURRENT_BINARY_DIR}/libplcairo_stubs.a
+- COMMAND ${OCAMLC} -ccopt "${CAIRO_COMPILE_FLAGS}" -cclib "${CAIRO_LINK_FLAGS}" -ccopt -I${CMAKE_SOURCE_DIR}/include -ccopt -I${CMAKE_BINARY_DIR}/include -ccopt -I${CMAKE_SOURCE_DIR}/lib/qsastime -ccopt -I${CMAKE_BINARY_DIR} -ccopt -DHAVE_CONFIG_H -c ${CMAKE_CURRENT_SOURCE_DIR}/plcairo_impl.c
++ COMMAND ${OCAMLC} -ccopt "${CAIRO_COMPILE_FLAGS}" -cclib "${CAIRO_LINK_FLAGS}" -ccopt -I${CMAKE_SOURCE_DIR}/include -ccopt -I${CMAKE_BINARY_DIR}/include -ccopt -I${CMAKE_SOURCE_DIR}/lib/qsastime -ccopt -I${CMAKE_BINARY_DIR} -ccopt -DPLPLOT_HAVE_CONFIG_H -c ${CMAKE_CURRENT_SOURCE_DIR}/plcairo_impl.c
+ COMMAND ${OCAMLMKLIB} -o plcairo_stubs ${CAIRO_LINK_FLAGS_LIST} -L${CMAKE_BINARY_DIR}/src -lplplot${LIB_TAG} ${CMAKE_CURRENT_BINARY_DIR}/plcairo_impl.o
+ DEPENDS
+ ${CMAKE_CURRENT_SOURCE_DIR}/plcairo_impl.c
+diff -Nur plplot-5.10.0.orig/doc/doxygen/html/plConfig_8h_source.html plplot-5.10.0/doc/doxygen/html/plConfig_8h_source.html
+--- plplot-5.10.0.orig/doc/doxygen/html/plConfig_8h_source.html 2014-04-07 09:51:53.712857853 -0700
++++ plplot-5.10.0/doc/doxygen/html/plConfig_8h_source.html 2014-04-07 09:54:03.935700600 -0700
+@@ -136,7 +136,7 @@
+ <div class="line"><a name="l00030"></a><span class="lineno"> 30</span>&#160;<span class="comment">// any user applications). Therefore, the configured plConfig.h</span></div>
+ <div class="line"><a name="l00031"></a><span class="lineno"> 31</span>&#160;<span class="comment">// should be installed. In contrast, plplot_config.h.in (note,</span></div>
+ <div class="line"><a name="l00032"></a><span class="lineno"> 32</span>&#160;<span class="comment">// plConfig.h #includes plplot_config.h for the core build because</span></div>
+-<div class="line"><a name="l00033"></a><span class="lineno"> 33</span>&#160;<span class="comment">// HAVE_CONFIG_H is #defined in that case) contains configured macros</span></div>
++<div class="line"><a name="l00033"></a><span class="lineno"> 33</span>&#160;<span class="comment">// PLPLOT_HAVE_CONFIG_H is #defined in that case) contains configured macros</span></div>
+ <div class="line"><a name="l00034"></a><span class="lineno"> 34</span>&#160;<span class="comment">// that are only required for the core build. Therefore, in contrast</span></div>
+ <div class="line"><a name="l00035"></a><span class="lineno"> 35</span>&#160;<span class="comment">// to plConfig.h, plplot_config.h should not be installed.</span></div>
+ <div class="line"><a name="l00036"></a><span class="lineno"> 36</span>&#160;<span class="comment">//</span></div>
+@@ -150,7 +150,7 @@
+ <div class="line"><a name="l00044"></a><span class="lineno"> 44</span>&#160;<span class="preprocessor">#ifndef __PLCONFIG_H__</span></div>
+ <div class="line"><a name="l00045"></a><span class="lineno"> 45</span>&#160;<span class="preprocessor"></span><span class="preprocessor">#define __PLCONFIG_H__</span></div>
+ <div class="line"><a name="l00046"></a><span class="lineno"> 46</span>&#160;<span class="preprocessor"></span></div>
+-<div class="line"><a name="l00047"></a><span class="lineno"> 47</span>&#160;<span class="preprocessor">#ifdef HAVE_CONFIG_H</span></div>
++<div class="line"><a name="l00047"></a><span class="lineno"> 47</span>&#160;<span class="preprocessor">#ifdef PLPLOT_HAVE_CONFIG_H</span></div>
+ <div class="line"><a name="l00048"></a><span class="lineno"> 48</span>&#160;<span class="preprocessor"></span><span class="preprocessor"># include &lt;<a class="code" href="plplot__config_8h.html">plplot_config.h</a>&gt;</span></div>
+ <div class="line"><a name="l00049"></a><span class="lineno"> 49</span>&#160;<span class="preprocessor">#endif</span></div>
+ <div class="line"><a name="l00050"></a><span class="lineno"> 50</span>&#160;<span class="preprocessor"></span></div>
+diff -Nur plplot-5.10.0.orig/doc/doxygen/html/plplot__config_8h_source.html plplot-5.10.0/doc/doxygen/html/plplot__config_8h_source.html
+--- plplot-5.10.0.orig/doc/doxygen/html/plplot__config_8h_source.html 2014-04-07 09:51:53.708857825 -0700
++++ plplot-5.10.0/doc/doxygen/html/plplot__config_8h_source.html 2014-04-07 09:54:03.935700600 -0700
+@@ -109,7 +109,7 @@
+ <div class="line"><a name="l00003"></a><span class="lineno"> 3</span>&#160;<span class="comment">// examples (and presumably any user applications). Therefore, the</span></div>
+ <div class="line"><a name="l00004"></a><span class="lineno"> 4</span>&#160;<span class="comment">// configured plplot_config.h should not be installed. In contrast,</span></div>
+ <div class="line"><a name="l00005"></a><span class="lineno"> 5</span>&#160;<span class="comment">// include/plConfig.h.in (note, the configured plConfig.h result</span></div>
+-<div class="line"><a name="l00006"></a><span class="lineno"> 6</span>&#160;<span class="comment">// #includes plplot_config.h for the core build because HAVE_CONFIG_H</span></div>
++<div class="line"><a name="l00006"></a><span class="lineno"> 6</span>&#160;<span class="comment">// #includes plplot_config.h for the core build because PLPLOT_HAVE_CONFIG_H</span></div>
+ <div class="line"><a name="l00007"></a><span class="lineno"> 7</span>&#160;<span class="comment">// is #defined in that case) contains configured macros that are</span></div>
+ <div class="line"><a name="l00008"></a><span class="lineno"> 8</span>&#160;<span class="comment">// required for the core build, installed examples build, and build of</span></div>
+ <div class="line"><a name="l00009"></a><span class="lineno"> 9</span>&#160;<span class="comment">// user applications. Therefore, in contrast to plplot_config.h,</span></div>
+diff -Nur plplot-5.10.0.orig/examples/CMakeLists.txt plplot-5.10.0/examples/CMakeLists.txt
+--- plplot-5.10.0.orig/examples/CMakeLists.txt 2014-04-07 09:51:53.610857133 -0700
++++ plplot-5.10.0/examples/CMakeLists.txt 2014-04-07 09:54:03.938700634 -0700
+@@ -414,7 +414,7 @@
+ endif(CORE_BUILD)
+
+ if(CORE_BUILD AND BUILD_TEST)
+- remove_definitions("-DHAVE_CONFIG_H")
++ remove_definitions("-DPLPLOT_HAVE_CONFIG_H")
+ endif(CORE_BUILD AND BUILD_TEST)
+
+ # Decide on device to be used for generic interactive tests.
+diff -Nur plplot-5.10.0.orig/include/plConfig.h.in plplot-5.10.0/include/plConfig.h.in
+--- plplot-5.10.0.orig/include/plConfig.h.in 2014-04-07 09:51:53.616857175 -0700
++++ plplot-5.10.0/include/plConfig.h.in 2014-04-07 09:54:03.938700634 -0700
+@@ -30,7 +30,7 @@
+ // any user applications). Therefore, the configured plConfig.h
+ // should be installed. In contrast, plplot_config.h.in (note,
+ // plConfig.h #includes plplot_config.h for the core build because
+-// HAVE_CONFIG_H is #defined in that case) contains configured macros
++// PLPLOT_HAVE_CONFIG_H is #defined in that case) contains configured macros
+ // that are only required for the core build. Therefore, in contrast
+ // to plConfig.h, plplot_config.h should not be installed.
+ //
+@@ -44,7 +44,7 @@
+ #ifndef __PLCONFIG_H__
+ #define __PLCONFIG_H__
+
+-#ifdef HAVE_CONFIG_H
++#ifdef PLPLOT_HAVE_CONFIG_H
+ # include <plplot_config.h>
+ #endif
+
+diff -Nur plplot-5.10.0.orig/plplot_config.h.in plplot-5.10.0/plplot_config.h.in
+--- plplot-5.10.0.orig/plplot_config.h.in 2014-04-07 09:51:53.732857993 -0700
++++ plplot-5.10.0/plplot_config.h.in 2014-04-07 09:54:03.938700634 -0700
+@@ -3,7 +3,7 @@
+ // examples (and presumably any user applications). Therefore, the
+ // configured plplot_config.h should not be installed. In contrast,
+ // include/plConfig.h.in (note, the configured plConfig.h result
+-// #includes plplot_config.h for the core build because HAVE_CONFIG_H
++// #includes plplot_config.h for the core build because PLPLOT_HAVE_CONFIG_H
+ // is #defined in that case) contains configured macros that are
+ // required for the core build, installed examples build, and build of
+ // user applications. Therefore, in contrast to plplot_config.h,
diff --git a/sci-libs/plplot/files/plplot-5.11.0-multiarch.patch b/sci-libs/plplot/files/plplot-5.11.0-multiarch.patch
new file mode 100644
index 000000000000..cb6f7d01cf16
--- /dev/null
+++ b/sci-libs/plplot/files/plplot-5.11.0-multiarch.patch
@@ -0,0 +1,60 @@
+ examples/c++/Makefile.examples.in | 3 ---
+ examples/c/Makefile.examples.in | 2 --
+ examples/f95/Makefile.examples.in | 2 --
+ examples/tk/Makefile.examples.in | 2 --
+ 4 files changed, 9 deletions(-)
+
+diff --git a/examples/c++/Makefile.examples.in b/examples/c++/Makefile.examples.in
+index bb067e7..176706b 100644
+--- a/examples/c++/Makefile.examples.in
++++ b/examples/c++/Makefile.examples.in
+@@ -25,10 +25,7 @@ SHELL = @SH_EXECUTABLE@
+ CXX = @CXX@
+ EXEEXT = @EXEEXT@
+
+-PKG_CONFIG_ENV = @PKG_CONFIG_ENV@
+-RPATHCMD = @RPATHCMD@
+ @qt_gui_true@QT_MOC_EXECUTABLE = @QT_MOC_EXECUTABLE@
+-@qt_gui_true@qt_RPATHCMD = @qt_RPATHCMD@
+
+ @wxwidgets_true@PLPLOTWXWIDGETS_EXECUTABLES_list = \
+ @wxwidgets_true@ wxPLplotDemo$(EXEEXT)
+diff --git a/examples/c/Makefile.examples.in b/examples/c/Makefile.examples.in
+index bc47762..56d1f49 100644
+--- a/examples/c/Makefile.examples.in
++++ b/examples/c/Makefile.examples.in
+@@ -25,8 +25,6 @@ SHELL = @SH_EXECUTABLE@
+ CC = @CC@
+ EXEEXT = @EXEEXT@
+
+-PKG_CONFIG_ENV = @PKG_CONFIG_ENV@
+-RPATHCMD = @RPATHCMD@
+
+ @gcw_true@PLPLOTCANVAS_EXECUTABLES_list = \
+ @gcw_true@ plplotcanvas_demo$(EXEEXT) \
+diff --git a/examples/f95/Makefile.examples.in b/examples/f95/Makefile.examples.in
+index 29631b7..32823d6 100644
+--- a/examples/f95/Makefile.examples.in
++++ b/examples/f95/Makefile.examples.in
+@@ -25,8 +25,6 @@ SHELL = @SH_EXECUTABLE@
+ F95 = @FC@
+ EXEEXT = @EXEEXT@
+
+-PKG_CONFIG_ENV = @PKG_CONFIG_ENV@
+-RPATHCMD = @RPATHCMD@
+
+ EXECUTABLES_list = \
+ x00f$(EXEEXT) \
+diff --git a/examples/tk/Makefile.examples.in b/examples/tk/Makefile.examples.in
+index 98407fa..c15c94a 100644
+--- a/examples/tk/Makefile.examples.in
++++ b/examples/tk/Makefile.examples.in
+@@ -24,8 +24,6 @@ SHELL = @SH_EXECUTABLE@
+ CC = @CC@
+ EXEEXT = @EXEEXT@
+
+-PKG_CONFIG_ENV = @PKG_CONFIG_ENV@
+-plplottcltk_Main_RPATHCMD = @plplottcltk_Main_RPATHCMD@
+
+ EXECUTABLES_list = xtk01$(EXEEXT)
+ # Second and fourth examples depend on itk.
diff --git a/sci-libs/plplot/files/plplot-5.11.0-ocaml.patch b/sci-libs/plplot/files/plplot-5.11.0-ocaml.patch
new file mode 100644
index 000000000000..32841825f0de
--- /dev/null
+++ b/sci-libs/plplot/files/plplot-5.11.0-ocaml.patch
@@ -0,0 +1,40 @@
+ bindings/ocaml/CMakeLists.txt | 4 ++--
+ bindings/ocaml/plcairo/CMakeLists.txt | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/bindings/ocaml/CMakeLists.txt b/bindings/ocaml/CMakeLists.txt
+index 93d073a..d31a64f 100644
+--- a/bindings/ocaml/CMakeLists.txt
++++ b/bindings/ocaml/CMakeLists.txt
+@@ -154,11 +154,11 @@ if(ENABLE_ocaml)
+ DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/plplot.cmo
+ )
+
+- # ocamlc -a -custom builds a *.cma library from *.cmo
++ # ocamlc -a builds a *.cma library from *.cmo
+ add_custom_command(
+ OUTPUT
+ ${CMAKE_CURRENT_BINARY_DIR}/plplot.cma
+- COMMAND ${OCAMLC} -a -custom -o ${CMAKE_CURRENT_BINARY_DIR}/plplot.cma ${CMAKE_CURRENT_BINARY_DIR}/plplot_core.cmo ${CMAKE_CURRENT_BINARY_DIR}/plplot.cmo -dllib -lplplot_stubs -ccopt -L${CMAKE_CURRENT_BINARY_DIR} -cclib -lplplot_stubs -ccopt -L${CAMLIDL_LIB_DIR} -cclib -lcamlidl -ccopt -L${CMAKE_BINARY_DIR}/src -cclib -lplplot -dllpath ${CMAKE_BINARY_DIR}/src ${ocaml_STATIC_FLAGS}
++ COMMAND ${OCAMLC} -a -o ${CMAKE_CURRENT_BINARY_DIR}/plplot.cma ${CMAKE_CURRENT_BINARY_DIR}/plplot_core.cmo ${CMAKE_CURRENT_BINARY_DIR}/plplot.cmo -dllib -lplplot_stubs -ccopt -L${CMAKE_CURRENT_BINARY_DIR} -cclib -lplplot_stubs -ccopt -L${CAMLIDL_LIB_DIR} -cclib -lcamlidl -ccopt -L${CMAKE_BINARY_DIR}/src -cclib -lplplot -dllpath ${CMAKE_BINARY_DIR}/src ${ocaml_STATIC_FLAGS}
+ DEPENDS
+ ${CMAKE_CURRENT_BINARY_DIR}/plplot_core.cmo
+ ${CMAKE_CURRENT_BINARY_DIR}/plplot.cmo
+diff --git a/bindings/ocaml/plcairo/CMakeLists.txt b/bindings/ocaml/plcairo/CMakeLists.txt
+index c4b4a41..ce1dc92 100644
+--- a/bindings/ocaml/plcairo/CMakeLists.txt
++++ b/bindings/ocaml/plcairo/CMakeLists.txt
+@@ -84,11 +84,11 @@ if(ENABLE_ocaml AND OCAML_HAS_CAIRO)
+ DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/plcairo.cmo
+ )
+
+- # ocamlc -a -custom builds a *.cma library from *.cmo
++ # ocamlc -a builds a *.cma library from *.cmo
+ add_custom_command(
+ OUTPUT
+ ${CMAKE_CURRENT_BINARY_DIR}/plcairo.cma
+- COMMAND ${OCAMLC} -a -custom -o ${CMAKE_CURRENT_BINARY_DIR}/plcairo.cma -I ${PATH_TO_PLPLOT_CMA} plplot.cma ${CMAKE_CURRENT_BINARY_DIR}/plcairo.cmo -dllib -lplcairo_stubs -ccopt -L${CMAKE_CURRENT_BINARY_DIR} -cclib -lplcairo_stubs -ccopt -L${CMAKE_BINARY_DIR}/src -cclib -lplplot -dllpath ${CMAKE_BINARY_DIR}/src
++ COMMAND ${OCAMLC} -a -o ${CMAKE_CURRENT_BINARY_DIR}/plcairo.cma -I ${PATH_TO_PLPLOT_CMA} plplot.cma ${CMAKE_CURRENT_BINARY_DIR}/plcairo.cmo -dllib -lplcairo_stubs -ccopt -L${CMAKE_CURRENT_BINARY_DIR} -cclib -lplcairo_stubs -ccopt -L${CMAKE_BINARY_DIR}/src -cclib -lplplot -dllpath ${CMAKE_BINARY_DIR}/src
+ DEPENDS
+ ${CMAKE_CURRENT_BINARY_DIR}/plcairo.cmo
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
diff --git a/sci-libs/plplot/files/plplot-5.11.0-octave.patch b/sci-libs/plplot/files/plplot-5.11.0-octave.patch
new file mode 100644
index 000000000000..a2a41c96da7a
--- /dev/null
+++ b/sci-libs/plplot/files/plplot-5.11.0-octave.patch
@@ -0,0 +1,16 @@
+ plplot_test/test_octave.sh.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/plplot_test/test_octave.sh.in b/plplot_test/test_octave.sh.in
+index 8a50d8b..8eb35fc 100755
+--- a/plplot_test/test_octave.sh.in
++++ b/plplot_test/test_octave.sh.in
+@@ -35,7 +35,7 @@ echo "$TOPDIR"
+ export LD_LIBRARY_PATH="$TOPDIR"/src:"$TOPDIR"/lib/csa:"$TOPDIR"/lib/nn
+
+ # Launch an Octave script that exercises all the demos
+-$octave -f -q <<EOF 2> test.error
++$octave -f -q $octaveopts -p "$octavedir" <<EOF 2> test.error
+
+ # Disable warnings about shadowed functions - PLplot is _supposed_ to shadow the core functions
+ warning("off","Octave:shadowed-function");
diff --git a/sci-libs/plplot/files/plplot-5.9.11-multiarch.patch b/sci-libs/plplot/files/plplot-5.9.11-multiarch.patch
new file mode 100644
index 000000000000..8f4512b976fc
--- /dev/null
+++ b/sci-libs/plplot/files/plplot-5.9.11-multiarch.patch
@@ -0,0 +1,50 @@
+diff -up plplot-5.9.11/examples/c++/Makefile.examples.in.multiarch plplot-5.9.11/examples/c++/Makefile.examples.in
+--- plplot-5.9.11/examples/c++/Makefile.examples.in.multiarch 2013-04-24 14:36:28.000000000 -0600
++++ plplot-5.9.11/examples/c++/Makefile.examples.in 2013-12-29 19:48:17.574496673 -0700
+@@ -25,10 +25,7 @@ CXX = @CXX@
+ EXEEXT = @EXEEXT@
+
+ LIB_TAG = @LIB_TAG@
+-PKG_CONFIG_ENV = @PKG_CONFIG_ENV@
+-RPATHCMD = @RPATHCMD@
+ @qt_gui_true@QT_MOC_EXECUTABLE = @QT_MOC_EXECUTABLE@
+-@qt_gui_true@qt_RPATHCMD = @qt_RPATHCMD@
+
+ @wxwidgets_true@PLPLOTWXWIDGETS_EXECUTABLES_list = \
+ @wxwidgets_true@ wxPLplotDemo$(EXEEXT)
+diff -up plplot-5.9.11/examples/c/Makefile.examples.in.multiarch plplot-5.9.11/examples/c/Makefile.examples.in
+--- plplot-5.9.11/examples/c/Makefile.examples.in.multiarch 2012-01-05 06:59:36.000000000 -0700
++++ plplot-5.9.11/examples/c/Makefile.examples.in 2013-12-29 19:48:17.574496673 -0700
+@@ -25,8 +25,6 @@ CC = @CC@
+ EXEEXT = @EXEEXT@
+
+ LIB_TAG = @LIB_TAG@
+-PKG_CONFIG_ENV = @PKG_CONFIG_ENV@
+-RPATHCMD = @RPATHCMD@
+
+ @gcw_true@PLPLOTCANVAS_EXECUTABLES_list = \
+ @gcw_true@ plplotcanvas_demo$(EXEEXT) \
+diff -up plplot-5.9.11/examples/f95/Makefile.examples.in.multiarch plplot-5.9.11/examples/f95/Makefile.examples.in
+--- plplot-5.9.11/examples/f95/Makefile.examples.in.multiarch 2012-02-19 11:33:33.000000000 -0700
++++ plplot-5.9.11/examples/f95/Makefile.examples.in 2013-12-29 19:48:20.960557580 -0700
+@@ -25,8 +25,6 @@ F95 = @FC@
+ EXEEXT = @EXEEXT@
+
+ LIB_TAG = @LIB_TAG@
+-PKG_CONFIG_ENV = @PKG_CONFIG_ENV@
+-RPATHCMD = @RPATHCMD@
+
+ EXECUTABLES_list = \
+ x00f$(EXEEXT) \
+diff -up plplot-5.9.11/examples/tk/Makefile.examples.in.multiarch plplot-5.9.11/examples/tk/Makefile.examples.in
+--- plplot-5.9.11/examples/tk/Makefile.examples.in.multiarch 2013-12-29 19:48:20.961557593 -0700
++++ plplot-5.9.11/examples/tk/Makefile.examples.in 2013-12-29 19:49:19.876587409 -0700
+@@ -24,8 +24,6 @@ CC = @CC@
+ EXEEXT = @EXEEXT@
+
+ LIB_TAG = @LIB_TAG@
+-PKG_CONFIG_ENV = @PKG_CONFIG_ENV@
+-plplottcltk_Main_RPATHCMD = @plplottcltk_Main_RPATHCMD@
+
+ EXECUTABLES_list = xtk01$(EXEEXT)
+ # Second and fourth examples depend on itk.
diff --git a/sci-libs/plplot/files/plplot-5.9.11-ocaml.patch b/sci-libs/plplot/files/plplot-5.9.11-ocaml.patch
new file mode 100644
index 000000000000..c10710c2e653
--- /dev/null
+++ b/sci-libs/plplot/files/plplot-5.9.11-ocaml.patch
@@ -0,0 +1,34 @@
+diff -up plplot-5.9.10/bindings/ocaml/CMakeLists.txt.ocaml plplot-5.9.10/bindings/ocaml/CMakeLists.txt
+--- plplot-5.9.10/bindings/ocaml/CMakeLists.txt.ocaml 2013-09-28 10:52:20.000000000 -0600
++++ plplot-5.9.10/bindings/ocaml/CMakeLists.txt 2013-10-24 09:35:47.093185622 -0600
+@@ -155,11 +155,11 @@ if(ENABLE_ocaml)
+ DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/plplot.cmo
+ )
+
+- # ocamlc -a -custom builds a *.cma library from *.cmo
++ # ocamlc -a builds a *.cma library from *.cmo
+ add_custom_command(
+ OUTPUT
+ ${CMAKE_CURRENT_BINARY_DIR}/plplot.cma
+- COMMAND ${OCAMLC} -a -custom -o ${CMAKE_CURRENT_BINARY_DIR}/plplot.cma ${CMAKE_CURRENT_BINARY_DIR}/plplot_core.cmo ${CMAKE_CURRENT_BINARY_DIR}/plplot.cmo -dllib -lplplot_stubs -ccopt -L${CMAKE_CURRENT_BINARY_DIR} -cclib -lplplot_stubs -ccopt -L${CAMLIDL_LIB_DIR} -cclib -lcamlidl -ccopt -L${CMAKE_BINARY_DIR}/src -cclib -lplplot${LIB_TAG} -dllpath ${CMAKE_BINARY_DIR}/src ${ocaml_STATIC_FLAGS}
++ COMMAND ${OCAMLC} -a -o ${CMAKE_CURRENT_BINARY_DIR}/plplot.cma ${CMAKE_CURRENT_BINARY_DIR}/plplot_core.cmo ${CMAKE_CURRENT_BINARY_DIR}/plplot.cmo -dllib -lplplot_stubs -ccopt -L${CMAKE_CURRENT_BINARY_DIR} -cclib -lplplot_stubs -ccopt -L${CAMLIDL_LIB_DIR} -cclib -lcamlidl -ccopt -L${CMAKE_BINARY_DIR}/src -cclib -lplplot${LIB_TAG} -dllpath ${CMAKE_BINARY_DIR}/src ${ocaml_STATIC_FLAGS}
+ DEPENDS
+ ${CMAKE_CURRENT_BINARY_DIR}/plplot_core.cmo
+ ${CMAKE_CURRENT_BINARY_DIR}/plplot.cmo
+diff -up plplot-5.9.10/bindings/ocaml/plcairo/CMakeLists.txt.ocaml plplot-5.9.10/bindings/ocaml/plcairo/CMakeLists.txt
+--- plplot-5.9.10/bindings/ocaml/plcairo/CMakeLists.txt.ocaml 2011-10-19 16:46:13.000000000 -0600
++++ plplot-5.9.10/bindings/ocaml/plcairo/CMakeLists.txt 2013-10-24 09:45:36.884193889 -0600
+@@ -84,11 +84,11 @@ if(ENABLE_ocaml AND OCAML_HAS_CAIRO)
+ DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/plcairo.cmo
+ )
+
+- # ocamlc -a -custom builds a *.cma library from *.cmo
++ # ocamlc -a builds a *.cma library from *.cmo
+ add_custom_command(
+ OUTPUT
+ ${CMAKE_CURRENT_BINARY_DIR}/plcairo.cma
+- COMMAND ${OCAMLC} -a -custom -o ${CMAKE_CURRENT_BINARY_DIR}/plcairo.cma -I ${PATH_TO_PLPLOT_CMA} plplot.cma ${CMAKE_CURRENT_BINARY_DIR}/plcairo.cmo -dllib -lplcairo_stubs -ccopt -L${CMAKE_CURRENT_BINARY_DIR} -cclib -lplcairo_stubs -ccopt -L${CMAKE_BINARY_DIR}/src -cclib -lplplot${LIB_TAG} -dllpath ${CMAKE_BINARY_DIR}/src
++ COMMAND ${OCAMLC} -a -o ${CMAKE_CURRENT_BINARY_DIR}/plcairo.cma -I ${PATH_TO_PLPLOT_CMA} plplot.cma ${CMAKE_CURRENT_BINARY_DIR}/plcairo.cmo -dllib -lplcairo_stubs -ccopt -L${CMAKE_CURRENT_BINARY_DIR} -cclib -lplcairo_stubs -ccopt -L${CMAKE_BINARY_DIR}/src -cclib -lplplot${LIB_TAG} -dllpath ${CMAKE_BINARY_DIR}/src
+ DEPENDS
+ ${CMAKE_CURRENT_BINARY_DIR}/plcairo.cmo
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
diff --git a/sci-libs/plplot/files/plplot-5.9.11-octave.patch b/sci-libs/plplot/files/plplot-5.9.11-octave.patch
new file mode 100644
index 000000000000..f21b4d2c4f8e
--- /dev/null
+++ b/sci-libs/plplot/files/plplot-5.9.11-octave.patch
@@ -0,0 +1,12 @@
+diff -up plplot-5.9.9/plplot_test/test_octave.sh.in.octave plplot-5.9.9/plplot_test/test_octave.sh.in
+--- plplot-5.9.9/plplot_test/test_octave.sh.in.octave 2011-10-12 18:43:01.000000000 -0600
++++ plplot-5.9.9/plplot_test/test_octave.sh.in 2012-01-16 08:29:46.551852247 -0700
+@@ -35,7 +35,7 @@ echo "$TOPDIR"
+ export LD_LIBRARY_PATH="$TOPDIR"/src:"$TOPDIR"/lib/csa:"$TOPDIR"/lib/nn
+
+ # Launch an Octave script that exercises all the demos
+-$octave -f -q -p "$octavedir" <<EOF 2> test.error
++$octave -f -q $octaveopts -p "$octavedir" <<EOF 2> test.error
+
+ # Check verbose_test variable
+ if (strcmp(getenv("verbose_test"),"on") == 1)
diff --git a/sci-libs/plplot/files/plplot-5.9.6-python.patch b/sci-libs/plplot/files/plplot-5.9.6-python.patch
new file mode 100644
index 000000000000..d62ece2ec416
--- /dev/null
+++ b/sci-libs/plplot/files/plplot-5.9.6-python.patch
@@ -0,0 +1,13 @@
+diff --git a/examples/python/CMakeLists.txt b/examples/python/CMakeLists.txt
+index 7599164..8457490 100644
+--- a/examples/python/CMakeLists.txt
++++ b/examples/python/CMakeLists.txt
+@@ -214,7 +214,7 @@ if(CORE_BUILD)
+ @ONLY
+ )
+
+- set(python_location1 ${PYTHON_INSTDIR})
++ set(python_location1)
+ set(python_location2)
+ set(python_location3)
+ set(python_location4)