summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-25 06:27:28 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-25 06:27:28 +0200
commit800a6f0f896180c1be8d9e83f026ef17c6d2e411 (patch)
tree562af03c95a730a79018d394e034df85a3adb7af /sci-libs/scikit-learn
parentapp-admin/awscli: Bump to 1.19.100 (diff)
downloadgentoo-800a6f0f896180c1be8d9e83f026ef17c6d2e411.tar.gz
gentoo-800a6f0f896180c1be8d9e83f026ef17c6d2e411.tar.bz2
gentoo-800a6f0f896180c1be8d9e83f026ef17c6d2e411.zip
sci-libs/scikit-learn: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-libs/scikit-learn')
-rw-r--r--sci-libs/scikit-learn/Manifest1
-rw-r--r--sci-libs/scikit-learn/scikit-learn-0.22.2_p1-r1.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/sci-libs/scikit-learn/Manifest b/sci-libs/scikit-learn/Manifest
index ca041d4e5182..f406527664be 100644
--- a/sci-libs/scikit-learn/Manifest
+++ b/sci-libs/scikit-learn/Manifest
@@ -1,2 +1 @@
-DIST scikit-learn-0.22.2_p1.tar.gz 7034850 BLAKE2B 41c362ef6594e837a9fc798837e666fbb51e33954fdf700292650204fd9d1ab4fc4d1695890d02a24ad68f4dcc2d3cde8f0827eca70c6fb9a6f0e5c0d9c04fd5 SHA512 20bcda5c65f76bce9b71c5b5fb1b499f7f3a7a3f6fa5fade80a38dc658cb434e16e9d5a4906a9657157a5cc90a6d51080575d6e510207baa9f8b06c4fa761d5b
DIST scikit-learn-0.24.2.tar.gz 7589697 BLAKE2B a5a32db690e76d6ecfcb12d57a7f84ebcc7e67ecb73258c1d923f9b98a9d87c46aac96918ef7c3d8741f5dbeb46f169c73a7744fb7b92e6ab5cf42101a6bc2f1 SHA512 2159baf63414b9594918b40e1b72af2ab47349335ad4e3afd9756921f786737ed41d6deb333881e8c5c6e1f7ce9cfa10691b966dc2476c48c051621f9049d2ee
diff --git a/sci-libs/scikit-learn/scikit-learn-0.22.2_p1-r1.ebuild b/sci-libs/scikit-learn/scikit-learn-0.22.2_p1-r1.ebuild
deleted file mode 100644
index 65589e8274da..000000000000
--- a/sci-libs/scikit-learn/scikit-learn-0.22.2_p1-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-inherit distutils-r1
-
-MY_PV="${PV//_p/.post}"
-
-DESCRIPTION="Machine learning library for Python"
-HOMEPAGE="https://scikit-learn.org/stable/"
-SRC_URI="https://github.com/scikit-learn/scikit-learn/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-#ffhttps://github.com/scikit-learn/scikit-learn/archive/0.22.2.post1.tar.gz
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc64 x86"
-IUSE="examples"
-
-RDEPEND="
- dev-python/wheel[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/joblib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- virtual/blas:=
- virtual/cblas:=
-"
-DEPEND="
- virtual/blas:=
- virtual/cblas:=
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # scikits-learn now uses the horrible numpy.distutils automagic
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
-
- # remove bundled cblas
- rm -rf sklearn/src || die "failed to remove bundled cblas"
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- distutils-r1_python_compile ${SCIPY_FCONFIG}
-}
-
-python_test() {
- distutils_install_for_testing ${SCIPY_FCONFIG}
- pushd "${TEST_DIR}/lib" >/dev/null || die
- pytest -vv || die "testing failed with ${EPYTHON}"
- popd >/dev/null || die
-}
-
-python_install() {
- distutils-r1_python_install ${SCIPY_FCONFIG}
-}
-
-python_install_all() {
- find "${S}" -name \*LICENSE.txt -delete
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
-}