summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-01-23 12:06:06 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-01-23 12:06:06 +0100
commitd170b295bc553e2e290c228b3fd0aecc6f5b60f6 (patch)
treeb27b87d273a5b8f615cc53faf9342eeebc6b7448 /sci-libs/shapelib
parentmedia-video/ffmpeg: bump zimg dep and add := in live ebuild. (diff)
downloadgentoo-d170b295bc553e2e290c228b3fd0aecc6f5b60f6.tar.gz
gentoo-d170b295bc553e2e290c228b3fd0aecc6f5b60f6.tar.bz2
gentoo-d170b295bc553e2e290c228b3fd0aecc6f5b60f6.zip
sci-libs/shapelib: Add missing RDEPEND
Gentoo-bug: 606884 Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-libs/shapelib')
-rw-r--r--sci-libs/shapelib/shapelib-1.4.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-libs/shapelib/shapelib-1.4.0-r1.ebuild b/sci-libs/shapelib/shapelib-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..259db714712b
--- /dev/null
+++ b/sci-libs/shapelib/shapelib-1.4.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Library for manipulating ESRI Shapefiles"
+HOMEPAGE="http://shapelib.maptools.org/"
+SRC_URI="http://download.osgeo.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND="sci-libs/proj"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ rm -r m4/* || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --includedir=/usr/include/libshp
+}
+
+src_install() {
+ use doc && HTML_DOCS=( web/. )
+ default
+
+ if ! use static-libs; then
+ find "${D}" \( -name '*.la' -o -name '*.a' \) -delete || die
+ fi
+}