summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-06-04 13:24:44 +0800
committerJason Zaman <perfinion@gentoo.org>2019-06-05 00:32:49 +0800
commitcce849c3c581c45f7d9d6deb09c07cb55c96a421 (patch)
tree8abe15e40fe1eae9479b8647c923ea8b30770668 /sci-libs/tensorflow-estimator
parentsci-libs/tensorflow: bump 1.14.0_rc0 (diff)
downloadgentoo-cce849c3c581c45f7d9d6deb09c07cb55c96a421.tar.gz
gentoo-cce849c3c581c45f7d9d6deb09c07cb55c96a421.tar.bz2
gentoo-cce849c3c581c45f7d9d6deb09c07cb55c96a421.zip
sci-libs/tensorflow-estimator: bump 1.14.0_rc0
Signed-off-by: Jason Zaman <perfinion@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'sci-libs/tensorflow-estimator')
-rw-r--r--sci-libs/tensorflow-estimator/Manifest1
-rw-r--r--sci-libs/tensorflow-estimator/tensorflow-estimator-1.14.0_rc0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sci-libs/tensorflow-estimator/Manifest b/sci-libs/tensorflow-estimator/Manifest
index f3b39cff7767..ec758432097c 100644
--- a/sci-libs/tensorflow-estimator/Manifest
+++ b/sci-libs/tensorflow-estimator/Manifest
@@ -1 +1,2 @@
DIST tensorflow-estimator-1.13.0.tar.gz 530871 BLAKE2B 4f208ed20e10fa68e06d21c9865cd07623e14362bdcff456bc9b412431c8f12f289c8a8f8ad89cb1f0ec98b1432844632d7e1097ea29d40bf6f67b90b4968f93 SHA512 e4be92b805776d2be5f391f737f1043b994f42721173c4d4a7dbf3fac9b00121cb072091a474bf71c7dcd952fc8b330cf9254c7a5ad9d096ba1cdc12ba12078b
+DIST tensorflow-estimator-1.14.0_rc0.tar.gz 669520 BLAKE2B 876f55b3f35b12ed81f7e978b92daa5fe250d3c45bee236565bbf437664c338a5de6d16eb829d7d3c502089c10f13d5d502c903a970f375aa03fcce3ecdd9a1e SHA512 046d8fd276d77dbc611c8aa7f73d33255222c027f538c5e688ab7a1898b0d8ef4462624368842352aadee711b81111fa38ccb219ce10cb143f8662c8b26c6285
diff --git a/sci-libs/tensorflow-estimator/tensorflow-estimator-1.14.0_rc0.ebuild b/sci-libs/tensorflow-estimator/tensorflow-estimator-1.14.0_rc0.ebuild
new file mode 100644
index 000000000000..d72026f052a2
--- /dev/null
+++ b/sci-libs/tensorflow-estimator/tensorflow-estimator-1.14.0_rc0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Jason Zaman
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python{3_5,3_6,3_7} )
+MY_PN="estimator"
+MY_PV=${PV/_rc/-rc}
+MY_P=${MY_PN}-${MY_PV}
+
+inherit bazel distutils-r1 flag-o-matic toolchain-funcs
+
+DESCRIPTION="A high-level TensorFlow API that greatly simplifies machine learning programming"
+HOMEPAGE="https://www.tensorflow.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+SRC_URI="https://github.com/tensorflow/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+RDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-java/java-config"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+src_prepare() {
+ bazel_setup_bazelrc
+ default
+}
+
+src_compile() {
+ export JAVA_HOME=$(java-config --jre-home)
+
+ ebazel build //tensorflow_estimator/tools/pip_package:build_pip_package
+ ebazel shutdown
+
+ local srcdir="${T}/src"
+ mkdir -p "${srcdir}" || die
+ bazel-bin/tensorflow_estimator/tools/pip_package/build_pip_package --src "${srcdir}" || die
+}
+
+src_install() {
+ do_install() {
+ cd "${T}/src" || die
+ esetup.py install
+ python_optimize
+ }
+ python_foreach_impl do_install
+
+ cd "${S}" || die
+ einstalldocs
+}