summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2020-07-10 10:42:25 -0600
committerChristoph Junghans <junghans@gentoo.org>2020-07-10 10:43:22 -0600
commit0ba92a30fc30e69af6567c45be5ef43c9382a951 (patch)
tree369e5bf9c09b0842ade0bb5368c9dc509ca79172 /sci-libs
parentdev-ros/navfn: fixup patch (diff)
downloadgentoo-0ba92a30fc30e69af6567c45be5ef43c9382a951.tar.gz
gentoo-0ba92a30fc30e69af6567c45be5ef43c9382a951.tar.bz2
gentoo-0ba92a30fc30e69af6567c45be5ef43c9382a951.zip
sci-libs/bliss: fix clang build (bug #731930)
Closes: https://bugs.gentoo.org/731930 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/bliss/bliss-0.73-r2.ebuild49
-rw-r--r--sci-libs/bliss/files/bliss-0.73-clang.patch11
-rw-r--r--sci-libs/bliss/metadata.xml4
3 files changed, 60 insertions, 4 deletions
diff --git a/sci-libs/bliss/bliss-0.73-r2.ebuild b/sci-libs/bliss/bliss-0.73-r2.ebuild
new file mode 100644
index 000000000000..9293ac0a67aa
--- /dev/null
+++ b/sci-libs/bliss/bliss-0.73-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+SRC_URI="http://www.tcs.hut.fi/Software/${PN}/${P}.zip"
+DESCRIPTION="Compute Automorphism Groups and Canonical Labelings of Graphs"
+HOMEPAGE="http://www.tcs.hut.fi/Software/bliss/"
+
+LICENSE="LGPL-3"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc gmp static-libs"
+
+RDEPEND="gmp? ( dev-libs/gmp:0= )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ doc? ( app-doc/doxygen )"
+
+#patches from http://pkgs.fedoraproject.org/cgit/rpms/bliss.git/tree/
+PATCHES=(
+ "${FILESDIR}"/${P}-error.patch
+ "${FILESDIR}"/${P}-rehn.patch
+ "${FILESDIR}"/${P}-clang.patch
+ "${FILESDIR}"/${P}-autotools.patch
+)
+
+src_prepare() {
+ default
+ cp "${FILESDIR}/${P}.1.in" "${PN}.1.in" || die
+ rm Makefile || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with gmp) $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake all $(usex doc html "")
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.la' -delete
+ use doc && dodoc -r html
+}
diff --git a/sci-libs/bliss/files/bliss-0.73-clang.patch b/sci-libs/bliss/files/bliss-0.73-clang.patch
new file mode 100644
index 000000000000..8a2e4bb6ca47
--- /dev/null
+++ b/sci-libs/bliss/files/bliss-0.73-clang.patch
@@ -0,0 +1,11 @@
+--- ./bliss.cc.orig 2020-07-10 10:34:44.946000000 -0600
++++ ./bliss.cc 2020-07-10 10:35:36.076000000 -0600
+@@ -59,7 +59,7 @@
+ else program_name = argv0;
+ if(!program_name or *program_name == 0) program_name = "bliss";
+
+- fprintf(fp, "bliss version %s (compiled "__DATE__")\n", bliss::version);
++ fprintf(fp, "bliss version %s (compiled %s)\n", bliss::version, __DATE__);
+ fprintf(fp, "Copyright 2003-2015 Tommi Junttila\n");
+ fprintf(fp,
+ "\n"
diff --git a/sci-libs/bliss/metadata.xml b/sci-libs/bliss/metadata.xml
index 0668c1ada0d5..9b3cd6685a18 100644
--- a/sci-libs/bliss/metadata.xml
+++ b/sci-libs/bliss/metadata.xml
@@ -1,10 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>junghans@gentoo.org</email>
- <name>Christoph Junghans</name>
- </maintainer>
<maintainer type="project">
<email>sci@gentoo.org</email>
<name>Gentoo Science Project</name>