summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-24 23:21:48 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-01 10:52:54 +0100
commit0cb0fddc5b08bdc7dad1c31993941e6219482b2b (patch)
tree6856aa88d5ab9ee24e451ea8d8371f01c2f929ba /sci-libs
parentsci-libs/rocPRIM: drop 5.0.2 (diff)
downloadgentoo-0cb0fddc5b08bdc7dad1c31993941e6219482b2b.tar.gz
gentoo-0cb0fddc5b08bdc7dad1c31993941e6219482b2b.tar.bz2
gentoo-0cb0fddc5b08bdc7dad1c31993941e6219482b2b.zip
sci-libs/rocRAND: drop 5.0.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/rocRAND/Manifest1
-rw-r--r--sci-libs/rocRAND/rocRAND-5.0.2.ebuild73
2 files changed, 0 insertions, 74 deletions
diff --git a/sci-libs/rocRAND/Manifest b/sci-libs/rocRAND/Manifest
index c26b309dd23b..0016770f25d1 100644
--- a/sci-libs/rocRAND/Manifest
+++ b/sci-libs/rocRAND/Manifest
@@ -1,3 +1,2 @@
DIST hipRAND-de941a7eb9ede2a862d719cd3ca23234a3692d07.tar.gz 80820 BLAKE2B f2894187455cf1da70c486e9efc336a01dc53589c56afe994858b2344c1e74e8d35260f70ad9cd80c5da1103dd9e98da6f5f2bf8e1ddf97023effc8a434a76ce SHA512 cdc70799ddca456c37c2a65875b98acff74800aa2b4f28d77b27c38c32428dd5edb2837bf88bfb6fcc32bdae7f2b27f1b547831bad98101b04959b7ba6b74a85
-DIST rocRAND-5.0.2.tar.gz 11765778 BLAKE2B f93c3530fba2b416c5ef3d227ebe65f3ee36607e6b4e1d0584c410768b9d71f86c40468bfad0935afb8ca13c7c87b20ee23f1ea89bdedcb6b3149fd932cbdbe6 SHA512 c19beb0eef8dcf4e090e53cb544f21adb61f8c9cb463c74da1c9767b1d75539bb3e296e7b8a70dee517817d181abd8c713e22770a1a4f66363150a879cbb3e48
DIST rocRAND-5.1.3.tar.gz 11729425 BLAKE2B f61aaedb7b72ceba3868a2069c93db1e2cd88a7a0188a9d5a33f520af3b42235c0dca62495460fd5e7abbca5fe7acc01acfdc90e53ae9a6e45128df5da472f49 SHA512 12859e52b79e40fcd1fb97d0915c191bbbc24e31e00aac4dbeecb625f9978a00ece3d7a42d0f9d37516031c1fbeb66e14dcd476ea83fe32fb13e0dd5c3964a28
diff --git a/sci-libs/rocRAND/rocRAND-5.0.2.ebuild b/sci-libs/rocRAND/rocRAND-5.0.2.ebuild
deleted file mode 100644
index aa2a6bdbd3ec..000000000000
--- a/sci-libs/rocRAND/rocRAND-5.0.2.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Generate pseudo-random and quasi-random numbers"
-HOMEPAGE="https://github.com/ROCmSoftwarePlatform/rocRAND"
-SRC_URI="https://github.com/ROCmSoftwarePlatform/rocRAND/archive/rocm-${PV}.tar.gz -> rocRAND-${PV}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~amd64"
-SLOT="0/$(ver_cut 1-2)"
-IUSE="benchmark test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-util/hip"
-DEPEND="${RDEPEND}
-dev-util/rocm-cmake
-test? ( dev-cpp/gtest )"
-BDEPEND="dev-util/rocm-cmake
->=dev-util/cmake-3.22"
-
-S="${WORKDIR}/rocRAND-rocm-${PV}"
-
-src_prepare() {
- sed -r -e "s:(hip|roc)rand/lib:\${CMAKE_INSTALL_LIBDIR}:" \
- -e "s:(hip|roc)rand/include:include/\1rand:" \
- -e "/INSTALL_RPATH/d" -i library/CMakeLists.txt || die
-
- # remove GIT dependency
- sed -e "/find_package(Git/,+4d" -i cmake/Dependencies.cmake || die
-
- eapply_user
- cmake_src_prepare
-}
-
-src_configure() {
- # Grant access to the device
- addwrite /dev/kfd
- addpredict /dev/dri/
-
- # Compiler to use
- export CXX=hipcc
-
- local mycmakeargs=(
- -DBUILD_TEST=$(usex test ON OFF)
- -DBUILD_BENCHMARK=$(usex benchmark ON OFF)
- -DCMAKE_SKIP_RPATH=TRUE
- ${AMDGPU_TARGETS+-DAMDGPU_TARGETS="${AMDGPU_TARGETS}"}
- )
-
- cmake_src_configure
- # do not rerun cmake and the build process in src_install
- sed '/RERUN/,+1d' -i "${BUILD_DIR}"/build.ninja || die
-}
-
-src_test() {
- # Grant access to the device
- addwrite /dev/kfd
- addwrite /dev/dri/
- LD_LIBRARY_PATH="${BUILD_DIR}/library" cmake_src_test
-}
-
-src_install() {
- cmake_src_install
-
- if use benchmark; then
- cd "${BUILD_DIR}"/benchmark
- dobin benchmark_rocrand_*
- fi
-}