summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2017-09-03 08:38:12 -0600
committerChristoph Junghans <junghans@gentoo.org>2017-09-03 08:54:54 -0600
commit0dfe99169e129ebbe61dd74cca12878ea11538ef (patch)
treed6bc968fe72ec8f074ab69569ebb0594f2f14c1e /sci-libs
parentsci-chemistry/votca-csg: live ebuild update (diff)
downloadgentoo-0dfe99169e129ebbe61dd74cca12878ea11538ef.tar.gz
gentoo-0dfe99169e129ebbe61dd74cca12878ea11538ef.tar.bz2
gentoo-0dfe99169e129ebbe61dd74cca12878ea11538ef.zip
sci-libs/votca-moo: initial commit
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/votca-moo/metadata.xml15
-rw-r--r--sci-libs/votca-moo/votca-moo-9999.ebuild41
2 files changed, 56 insertions, 0 deletions
diff --git a/sci-libs/votca-moo/metadata.xml b/sci-libs/votca-moo/metadata.xml
new file mode 100644
index 000000000000..25ad85ea7535
--- /dev/null
+++ b/sci-libs/votca-moo/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>junghans@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-chemistry@gentoo.org</email>
+ <name>Gentoo Chemistry Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">votca/moo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/votca-moo/votca-moo-9999.ebuild b/sci-libs/votca-moo/votca-moo-9999.ebuild
new file mode 100644
index 000000000000..01f3524290df
--- /dev/null
+++ b/sci-libs/votca-moo/votca-moo-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils multilib
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ S="${WORKDIR}/${P#votca-}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN/-//}.git"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Votca Molecular orbital library"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ =sci-libs/votca-tools-${PV}[sqlite]
+ dev-db/sqlite:3"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( NOTICE README )
+
+src_configure() {
+ mycmakeargs=(
+ -DLIB=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}