summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2020-10-13 10:45:38 -0600
committerChristoph Junghans <junghans@gentoo.org>2020-10-13 10:45:54 -0600
commit0ffa139642ef161505e6d9582df70f1a3eb0f8b2 (patch)
tree34b0d662d0ecf10a45eef9bd321289b79f4fb465 /sci-libs
parentdev-python/pylint: bump to 2.6.0 (diff)
downloadgentoo-0ffa139642ef161505e6d9582df70f1a3eb0f8b2.tar.gz
gentoo-0ffa139642ef161505e6d9582df70f1a3eb0f8b2.tar.bz2
gentoo-0ffa139642ef161505e6d9582df70f1a3eb0f8b2.zip
sci-libs/libint: compile with support derivatives
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libint/libint-2.6.0-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sci-libs/libint/libint-2.6.0-r1.ebuild b/sci-libs/libint/libint-2.6.0-r1.ebuild
new file mode 100644
index 000000000000..cdda6546357c
--- /dev/null
+++ b/sci-libs/libint/libint-2.6.0-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools eutils fortran-2 toolchain-funcs
+
+DESCRIPTION="Matrix elements (integrals) evaluation over Cartesian Gaussian functions"
+HOMEPAGE="https://github.com/evaleev/libint"
+SRC_URI="https://github.com/evaleev/libint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs doc"
+
+DEPEND="
+ dev-libs/boost
+ dev-libs/gmp[cxx]
+ doc? (
+ dev-texlive/texlive-latex
+ dev-tex/latex2html
+ )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-cxx=$(tc-getCXX) \
+ --with-cxx-optflags="${CXXFLAGS}" \
+ --with-cxxgen-optflags="${CXXFLAGS}" \
+ --with-cxxdepend=$(tc-getCXX) \
+ --with-ranlib=$(tc-getRANLIB) \
+ --with-ar=$(tc-getAR) \
+ --with-ld=$(tc-getLD) \
+ --enable-eri3=1
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}"
+
+ use doc && emake html pdf
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ DOCS=( doc/progman/progman.pdf )
+ HTML_DOCS=( doc/progman/progman/*.{html,png,css} )
+ einstalldocs
+ fi
+}