summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-06-23 17:11:47 +0200
committerDavid Seifert <soap@gentoo.org>2016-06-23 18:46:42 +0200
commit1d95ac432c2f5b6c44b37d7a8be3cc39854975f7 (patch)
tree108f8c4dab3139b22fa4cbc0a3b3ef0b89e6d2f4 /sci-libs
parentnet-libs/libaccounts-glib: reset XDG environment (diff)
downloadgentoo-1d95ac432c2f5b6c44b37d7a8be3cc39854975f7.tar.gz
gentoo-1d95ac432c2f5b6c44b37d7a8be3cc39854975f7.tar.bz2
gentoo-1d95ac432c2f5b6c44b37d7a8be3cc39854975f7.zip
sci-libs/matio: Version bump + bump to EAPI=6
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1726 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/matio/Manifest1
-rw-r--r--sci-libs/matio/matio-1.5.7.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sci-libs/matio/Manifest b/sci-libs/matio/Manifest
index e7dbf6da01fb..6a20cb7c0a47 100644
--- a/sci-libs/matio/Manifest
+++ b/sci-libs/matio/Manifest
@@ -1,2 +1,3 @@
DIST matio-1.5.1.tar.gz 8160893 SHA256 7d94a1433f67ce21f08fbbfc8af677f3838964b2b07565dce6f65e878394cd2f SHA512 bd1e49bcbfe3e073d2339bc3dff803b222c007aad19759ee9b666438fa59ec2b2750b52ffb3b5e911145cf2977538447f5db977fc056a624c5878ddbcf564b26 WHIRLPOOL 54c5191c9b4b15e54f25d435a7ea680c84c94f1f5c9e432e3340a7a0821b743c95a08c4e77d65dece3768147c7b5e9e9057bc7ad9b8cde358951f5728d81879b
DIST matio-1.5.2.tar.gz 8179926 SHA256 db02d0fb3373c3d766a606309b17e64a5d8da55610e921a9f1a0ec171e911d45 SHA512 47ee7457db3f2138ecb1db9d7a04bf91d8277024631694e5f5a49b77829d60ce9dd95a1db33cd8eeaa8271e942acf60b522f40e4d7f4cae90f0a7caee7eb6efc WHIRLPOOL 31796367020078b06cefa10ccfad00526a04c12c158f581d8b4c134071647f01ae55b39e1c738cc3a9ac6211f36cd59041130edd208f001a28fb9f770e0fe8b0
+DIST matio-1.5.7.tar.gz 8502196 SHA256 84b9a17ada1ee08374fb47cc2d0e10a95b8f7f603b58576239f90b8c576fad48 SHA512 03ba3732aeb9f8d7f94d7e95d409ae7abbed5172f033b6a5752dfb74a2c1fdf61e4f3a9a34bccae1d37e9dbfb3ef6415420b7ea0533265fb338cc6600b758e90 WHIRLPOOL 3bf2512682ef0299c1a4d3f99539e170894af129de485af04eb4f16c271a762fe52a6fe697e4acecedc661e9a4b0d50d702fa7ad127f425ae51e18dc34bbbb78
diff --git a/sci-libs/matio/matio-1.5.7.ebuild b/sci-libs/matio/matio-1.5.7.ebuild
new file mode 100644
index 000000000000..b9181ad52a9c
--- /dev/null
+++ b/sci-libs/matio/matio-1.5.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Library for reading and writing matlab files"
+HOMEPAGE="http://sourceforge.net/projects/matio/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples hdf5 sparse static-libs"
+
+RDEPEND="
+ sys-libs/zlib
+ hdf5? ( sci-libs/hdf5 )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ doc? ( virtual/latex-base )"
+
+src_configure() {
+ econf \
+ $(use_enable hdf5 mat73) \
+ $(use_enable sparse extended-sparse)
+}
+
+src_compile() {
+ default
+ use doc && emake -C documentation pdf
+}
+
+src_install() {
+ default
+ use doc && dodoc documentation/matio_user_guide.pdf
+ if use examples; then
+ docinto examples
+ dodoc test/test*
+ insinto /usr/share/${PN}
+ doins share/test*
+ fi
+}