summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-01 21:34:54 +0100
committerAaron Bauman <bman@gentoo.org>2019-12-02 23:17:51 -0500
commit1ed8a5f919e3df02f8600e860cc82a575776edd4 (patch)
treeffddc175847ce86fddc1ab6425511bcd4ba8500a /sci-libs
parentsys-devel/gdb: arm64 stable (bug #701824) (diff)
downloadgentoo-1ed8a5f919e3df02f8600e860cc82a575776edd4.tar.gz
gentoo-1ed8a5f919e3df02f8600e860cc82a575776edd4.tar.bz2
gentoo-1ed8a5f919e3df02f8600e860cc82a575776edd4.zip
sci-libs/Shapely: python3_8, EAPI-7 bump
Tests passed. Dropping python2_7 for dev-python/numpy dependency. Closes: https://bugs.gentoo.org/701746 Package-Manager: Portage-2.3.80, Repoman-2.3.18 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/Shapely/Shapely-1.6.4_p2-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sci-libs/Shapely/Shapely-1.6.4_p2-r1.ebuild b/sci-libs/Shapely/Shapely-1.6.4_p2-r1.ebuild
new file mode 100644
index 000000000000..488e7c29a06e
--- /dev/null
+++ b/sci-libs/Shapely/Shapely-1.6.4_p2-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="https://pypi.org/project/Shapely/"
+
+MY_PV="$(ver_cut 1-3).post$(ver_cut 5)"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/Toblerity/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ >=sci-libs/geos-3.3"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}/${P}-test_operations.patch" ) # bug 701624
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+python_prepare_all() {
+ # fix install path for Cython definition file
+ sed -i \
+ -e "s|\(data_files.*\)'shapely'|\1'share/shapely'|" \
+ setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}/lib" || die
+ cp -r "${S}/tests" . || die
+ py.test tests || die
+}