summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-21 08:31:31 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-21 08:31:31 +0200
commit3016ae1cd6d05cc11cb09847178fd07db080ba2b (patch)
tree9894aef02ed470a338c8bf1119abc087e6463f15 /sci-libs
parentsci-physics/h2o-gtk: Remove last-rited pkg (diff)
downloadgentoo-3016ae1cd6d05cc11cb09847178fd07db080ba2b.tar.gz
gentoo-3016ae1cd6d05cc11cb09847178fd07db080ba2b.tar.bz2
gentoo-3016ae1cd6d05cc11cb09847178fd07db080ba2b.zip
sci-libs/plotmm: Remove last-rited pkg
Closes: https://bugs.gentoo.org/744073 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/plotmm/Manifest1
-rw-r--r--sci-libs/plotmm/files/plotmm-0.1.2-libsigc++-2.2.patch100
-rw-r--r--sci-libs/plotmm/metadata.xml8
-rw-r--r--sci-libs/plotmm/plotmm-0.1.2.ebuild58
4 files changed, 0 insertions, 167 deletions
diff --git a/sci-libs/plotmm/Manifest b/sci-libs/plotmm/Manifest
deleted file mode 100644
index 48e7b7bd43a8..000000000000
--- a/sci-libs/plotmm/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST plotmm-0.1.2.tar.gz 473175 BLAKE2B f024abbe77e208443cdf58a7817cdea9d1a93435b55e62d4579c341ca773fc2199def0e93fbba980891dd38c0085515e01833a11fd37f87bdeb0b2737a8ff809 SHA512 68484d7ed3b4d6520782735e05ad3cf9a5749f723285a2a3d0d1fabe3b23df57856d24addb31c23e3f23174655095f55b9b9a8d10316812d7a80fe13e204fab6
diff --git a/sci-libs/plotmm/files/plotmm-0.1.2-libsigc++-2.2.patch b/sci-libs/plotmm/files/plotmm-0.1.2-libsigc++-2.2.patch
deleted file mode 100644
index a9aa53190d5f..000000000000
--- a/sci-libs/plotmm/files/plotmm-0.1.2-libsigc++-2.2.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-diff -ur plotmm-0.1.2-old/plotmm/compat.h plotmm-0.1.2/plotmm/compat.h
---- plotmm-0.1.2-old/plotmm/compat.h 2005-11-09 17:36:02.000000000 +0100
-+++ plotmm-0.1.2/plotmm/compat.h 2008-07-25 00:13:55.000000000 +0200
-@@ -58,7 +58,7 @@
- #else
-
- namespace PlotMM {
-- typedef SigC::ObjectBase ObjectBase;
-+ typedef sigc::ObjectBase ObjectBase;
- }
-
- #endif
-diff -ur plotmm-0.1.2-old/plotmm/curve.h plotmm-0.1.2/plotmm/curve.h
---- plotmm-0.1.2-old/plotmm/curve.h 2005-11-09 17:47:21.000000000 +0100
-+++ plotmm-0.1.2/plotmm/curve.h 2008-07-25 00:24:02.000000000 +0200
-@@ -140,7 +140,7 @@
- int from = 0, int to = -1);
-
- //! Signals that this curve has changed in some way or the other
-- SigC::Signal0<void> signal_curve_changed;
-+ sigc::signal0<void> signal_curve_changed;
-
- protected:
- virtual void init(const Glib::ustring &title);
-diff -ur plotmm-0.1.2-old/plotmm/plot.cc plotmm-0.1.2/plotmm/plot.cc
---- plotmm-0.1.2-old/plotmm/plot.cc 2005-11-09 17:59:48.000000000 +0100
-+++ plotmm-0.1.2/plotmm/plot.cc 2008-07-25 00:24:30.000000000 +0200
-@@ -322,7 +322,7 @@
- connect(sigc::mem_fun(*this,&Plot::on_canvas_expose_event));
- #else
- canvas_.signal_expose_event().
-- connect(SigC::slot(*this,&Plot::on_canvas_expose_event));
-+ connect(sigc::slot(*this,&Plot::on_canvas_expose_event));
- #endif
-
- show_all();
-@@ -406,19 +406,19 @@
- }
-
- //! Return the signal owned by plot canvas
--SigC::Signal3<void,int,int,GdkEventButton*> Plot::signal_plot_mouse_press()
-+sigc::signal3<void,int,int,GdkEventButton*> Plot::signal_plot_mouse_press()
- {
- return canvas_.signal_plot_mouse_press;
- }
-
- //! Return the signal owned by plot canvas
--SigC::Signal3<void,int,int,GdkEventButton*> Plot::signal_plot_mouse_release()
-+sigc::signal3<void,int,int,GdkEventButton*> Plot::signal_plot_mouse_release()
- {
- return canvas_.signal_plot_mouse_release;
- }
-
- //! Return the signal owned by plot canvas
--SigC::Signal3<void,int,int,GdkEventMotion*> Plot::signal_plot_mouse_move()
-+sigc::signal3<void,int,int,GdkEventMotion*> Plot::signal_plot_mouse_move()
- {
- return canvas_.signal_plot_mouse_move;
- }
-diff -ur plotmm-0.1.2-old/plotmm/plot.h plotmm-0.1.2/plotmm/plot.h
---- plotmm-0.1.2-old/plotmm/plot.h 2004-03-09 10:51:55.000000000 +0100
-+++ plotmm-0.1.2/plotmm/plot.h 2008-07-25 00:25:17.000000000 +0200
-@@ -79,9 +79,9 @@
- virtual void clear();
- virtual void end_replot();
-
-- SigC::Signal3<void,int,int,GdkEventButton*> signal_plot_mouse_press;
-- SigC::Signal3<void,int,int,GdkEventButton*> signal_plot_mouse_release;
-- SigC::Signal3<void,int,int,GdkEventMotion*> signal_plot_mouse_move;
-+ sigc::signal3<void,int,int,GdkEventButton*> signal_plot_mouse_press;
-+ sigc::signal3<void,int,int,GdkEventButton*> signal_plot_mouse_release;
-+ sigc::signal3<void,int,int,GdkEventMotion*> signal_plot_mouse_move;
-
- protected:
- virtual bool on_expose_event(GdkEventExpose* event);
-@@ -141,9 +141,9 @@
- Scale *scale(PlotAxisID id) { return tickMark_[id]; }
- PlotLabel *label(PlotAxisID id) { return axisLabel_[id]; }
-
-- SigC::Signal3<void,int,int,GdkEventButton*> signal_plot_mouse_press();
-- SigC::Signal3<void,int,int,GdkEventButton*> signal_plot_mouse_release();
-- SigC::Signal3<void,int,int,GdkEventMotion*> signal_plot_mouse_move();
-+ sigc::signal3<void,int,int,GdkEventButton*> signal_plot_mouse_press();
-+ sigc::signal3<void,int,int,GdkEventButton*> signal_plot_mouse_release();
-+ sigc::signal3<void,int,int,GdkEventMotion*> signal_plot_mouse_move();
-
- void set_selection(const Rectangle &r);
- Rectangle get_selection() { return select_; }
-diff -ur plotmm-0.1.2-old/plotmm/scale.h plotmm-0.1.2/plotmm/scale.h
---- plotmm-0.1.2-old/plotmm/scale.h 2004-03-05 16:25:43.000000000 +0100
-+++ plotmm-0.1.2/plotmm/scale.h 2008-07-25 00:25:30.000000000 +0200
-@@ -133,7 +133,7 @@
- /*! This signal is thrown whenever the scale is enabled or disabled
- * \sa set_enabled, enabled
- */
-- SigC::Signal1<void,bool> signal_enabled;
-+ sigc::signal1<void,bool> signal_enabled;
-
- protected:
- virtual void on_realize();
diff --git a/sci-libs/plotmm/metadata.xml b/sci-libs/plotmm/metadata.xml
deleted file mode 100644
index 6907b0a4da6b..000000000000
--- a/sci-libs/plotmm/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="sourceforge">plotmm</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/sci-libs/plotmm/plotmm-0.1.2.ebuild b/sci-libs/plotmm/plotmm-0.1.2.ebuild
deleted file mode 100644
index 5cf316ca2678..000000000000
--- a/sci-libs/plotmm/plotmm-0.1.2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils flag-o-matic
-
-DESCRIPTION="Plot widget for GTKmm"
-HOMEPAGE="http://plotmm.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~x86"
-IUSE="doc examples"
-
-RDEPEND="dev-cpp/gtkmm:2.4"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-# NOTES:
-# somewhat, there is a dep on libsigc++ but it's much more via gtkmm
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-libsigc++-2.2.patch"
-
- if ! use examples; then
- sed -i -e "s:examples::" Makefile.in || die "sed failed"
- fi
-}
-
-src_configure() {
- append-cxxflags -std=c++11
- econf \
- --disable-maintainer-mode \
- --enable-fast-install \
- --disable-libtool-lock
-}
-
-src_install() {
- default
-
- if use doc; then
- dohtml -r doc/html/*
- fi
-
- if use examples; then
- # rename installed bin files
- mv "${D}"/usr/bin/curves "${D}"/usr/bin/${PN}-curves || die "mv failed"
- mv "${D}"/usr/bin/simple "${D}"/usr/bin/${PN}-simple || die "mv failed"
-
- # install sources
- insinto /usr/share/doc/${PF}/examples/
- doins examples/{curves/curves,simple/simple}.cc
-
- elog "You can use examples by calling ${PN}-curves or ${PN}-simple."
- elog "Examples source code is in /usr/share/doc/${PF}/examples."
- fi
-}