summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-26 07:25:53 +0000
committerSam James <sam@gentoo.org>2023-01-26 07:55:23 +0000
commit4b2cb7b09bd5568a3a55aa3e0cff4dad63aa4ec0 (patch)
tree38fdcbc9543df12f59518f516be0def11dd9076e /sci-libs
parentsys-apps/superiotool: remove last-rited package (diff)
downloadgentoo-4b2cb7b09bd5568a3a55aa3e0cff4dad63aa4ec0.tar.gz
gentoo-4b2cb7b09bd5568a3a55aa3e0cff4dad63aa4ec0.tar.bz2
gentoo-4b2cb7b09bd5568a3a55aa3e0cff4dad63aa4ec0.zip
sci-libs/geos: fix build w/ gcc 13
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/geos/files/geos-3.11.1-gcc-13.patch111
-rw-r--r--sci-libs/geos/geos-3.11.1.ebuild6
2 files changed, 116 insertions, 1 deletions
diff --git a/sci-libs/geos/files/geos-3.11.1-gcc-13.patch b/sci-libs/geos/files/geos-3.11.1-gcc-13.patch
new file mode 100644
index 000000000000..45054e860082
--- /dev/null
+++ b/sci-libs/geos/files/geos-3.11.1-gcc-13.patch
@@ -0,0 +1,111 @@
+https://github.com/libgeos/geos/commit/0e8d4368b8bd72a7d361286e8523ebce5cff6146
+https://github.com/libgeos/geos/commit/bea3188be44075034fd349f5bb117c943bdb7fb1
+
+From 0e8d4368b8bd72a7d361286e8523ebce5cff6146 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyich@gmail.com>
+Date: Tue, 29 Nov 2022 23:10:22 +0000
+Subject: [PATCH] Add missing <cstdint> includes for gcc-13 (#743)
+
+Without the change build on `gcc-13` fails as:
+
+ geos/include/geos/geomgraph/TopologyLocation.h:143:52: error: 'uint32_t' has not been declared
+ 143 | bool isEqualOnSide(const TopologyLocation& le, uint32_t locIndex) const
+ | ^~~~~~~~
+--- a/include/geos/geomgraph/Depth.h
++++ b/include/geos/geomgraph/Depth.h
+@@ -24,6 +24,7 @@
+ #include <geos/geom/Location.h>
+ #include <geos/geom/Position.h>
+ #include <string>
++#include <cstdint>
+
+ // Forward declarations
+ namespace geos {
+--- a/include/geos/geomgraph/TopologyLocation.h
++++ b/include/geos/geomgraph/TopologyLocation.h
+@@ -27,6 +27,7 @@
+ #include <array>
+ #include <string>
+ #include <cassert>
++#include <cstdint>
+
+ #ifdef _MSC_VER
+ #pragma warning(push)
+--- a/include/geos/io/WKTWriter.h
++++ b/include/geos/io/WKTWriter.h
+@@ -24,6 +24,7 @@
+
+ #include <string>
+ #include <cctype>
++#include <cstdint>
+
+ #ifdef _MSC_VER
+ #pragma warning(push)
+--- a/include/geos/operation/overlayng/OverlayLabel.h
++++ b/include/geos/operation/overlayng/OverlayLabel.h
+@@ -14,6 +14,8 @@
+
+ #pragma once
+
++#include <cstdint>
++
+ #include <geos/geom/Location.h>
+ #include <geos/geom/Position.h>
+ #include <geos/export.h>
+--- a/include/geos/shape/fractal/HilbertCode.h
++++ b/include/geos/shape/fractal/HilbertCode.h
+@@ -17,6 +17,7 @@
+
+ #include <geos/export.h>
+ #include <string>
++#include <cstdint>
+
+ // Forward declarations
+ namespace geos {
+--- a/include/geos/shape/fractal/MortonCode.h
++++ b/include/geos/shape/fractal/MortonCode.h
+@@ -17,6 +17,7 @@
+
+ #include <geos/export.h>
+ #include <string>
++#include <cstdint>
+
+ // Forward declarations
+ namespace geos {
+
+From bea3188be44075034fd349f5bb117c943bdb7fb1 Mon Sep 17 00:00:00 2001
+From: Heiko Becker <mail@heiko-becker.de>
+Date: Mon, 23 Jan 2023 15:56:11 +0100
+Subject: [PATCH] Fix build with gcc 13 by including <cstdint> (#805)
+
+In addition to [1]. Otherwise geos fails to build with:
+"geos-3.11.1/include/geos/shape/fractal/HilbertEncoder.h:40:28: error: expected ')' before 'p_level'
+ 40 | HilbertEncoder(uint32_t p_level, geom::Envelope& extent);
+ | ~ ^~~~~~~~
+ | )
+/var/tmp/paludis/build/sci-libs-geos-3.11.1/work/geos-3.11.1/include/geos/shape/fractal/HilbertEncoder.h:41:5: error: 'uint32_t' does not name a type
+ 41 | uint32_t encode(const geom::Envelope* env);
+ | ^~~~~~~~"
+
+[1] 0e8d4368b8bd72a7d361286e8523ebce5cff6146
+--- a/include/geos/shape/fractal/HilbertEncoder.h
++++ b/include/geos/shape/fractal/HilbertEncoder.h
+@@ -19,6 +19,7 @@
+ #include <geos/geom/Geometry.h>
+ #include <string>
+ #include <vector>
++#include <cstdint>
+
+ // Forward declarations
+ namespace geos {
+--- a/tests/unit/capi/GEOSMakeValidTest.cpp
++++ b/tests/unit/capi/GEOSMakeValidTest.cpp
+@@ -9,6 +9,7 @@
+ #include <cstdlib>
+ #include <cmath>
+ #include <cstring>
++#include <cstdint>
+
+ #include "capi_test_utils.h"
+
+
diff --git a/sci-libs/geos/geos-3.11.1.ebuild b/sci-libs/geos/geos-3.11.1.ebuild
index dd84d4906b89..b560a1fb3e08 100644
--- a/sci-libs/geos/geos-3.11.1.ebuild
+++ b/sci-libs/geos/geos-3.11.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,6 +17,10 @@ RESTRICT="!test? ( test )"
BDEPEND="doc? ( app-doc/doxygen )"
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-13.patch
+)
+
src_configure() {
local mycmakeargs=(
-DBUILD_DOCUMENTATION=$(usex doc)