summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2019-03-25 19:50:48 +0000
committerStefan Strogin <steils@gentoo.org>2019-05-11 17:31:41 +0300
commit4b467cf776c315eb62a08cd19e0bfe054ec88600 (patch)
treeeae9c11762fa1ff7c7a04dafa3501643b41b17f3 /sci-libs
parentpackage.use.mask: mask festival useflag (diff)
downloadgentoo-4b467cf776c315eb62a08cd19e0bfe054ec88600.tar.gz
gentoo-4b467cf776c315eb62a08cd19e0bfe054ec88600.tar.bz2
gentoo-4b467cf776c315eb62a08cd19e0bfe054ec88600.zip
sci-libs/shapelib: version bump 1.5.0
Closes: https://bugs.gentoo.org/685232 Package-Manager: Portage-2.3.62, Repoman-2.3.11 Signed-off-by: Chris Mayo <aklhfex@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11506 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/shapelib/Manifest1
-rw-r--r--sci-libs/shapelib/shapelib-1.5.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/shapelib/Manifest b/sci-libs/shapelib/Manifest
index 52b9b34c4b66..bf41398c813c 100644
--- a/sci-libs/shapelib/Manifest
+++ b/sci-libs/shapelib/Manifest
@@ -1,2 +1,3 @@
DIST shapelib-1.4.0.tar.gz 548990 BLAKE2B 0e75481d35f8dc5687eee23696d46a780d4b185a81ca1246e5c19f01e58f4a55dc7b69347c9effa01ac1786c5271dfe3907798cc81fe9314979c502bcb9d982d SHA512 206b81fe859a837e821e449ab1b2dbd5a3aa7abd1871da4aec69e130b6fad6300697429884ce359c90e4b76bca90e2108f32b9fdbd3b92013fa5a39f3bedeeb1
DIST shapelib-1.4.1.tar.gz 549831 BLAKE2B e579704bd71c2525133f87628261e78f39e8063cd7e8a57997e90a8ca4a6ebb5de3a4d1ab8da5d00afe1363d9eb22e8c7a9a66ac109c300b72b6d26bd87b61fd SHA512 791c1a0d6c5ff09341176f68349ebd760ae91e8749a9f844299d7ac38a42c4f1131e63479c384a8a8b05a89e90d02e9fd92c526cab417eb80b171d639b4a4422
+DIST shapelib-1.5.0.tar.gz 547686 BLAKE2B 3f962ee701d8cfb86a56aa1c0b2156bc2288a2bc908bb1a8303e491812845241f5281b0b8650befcc53e9dfc408b652a56f5e2fdc5ac7c2ff6eb99170696e437 SHA512 6dbd5fc7929ca403e65017ef58211f351608d9ad08221bf68bde047ceecfd27013ce731f9ae4edcfd040bc3db7fe9054b5d96e46128d2968788bef19532b1721
diff --git a/sci-libs/shapelib/shapelib-1.5.0.ebuild b/sci-libs/shapelib/shapelib-1.5.0.ebuild
new file mode 100644
index 000000000000..91abc76af145
--- /dev/null
+++ b/sci-libs/shapelib/shapelib-1.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Library for manipulating ESRI Shapefiles"
+HOMEPAGE="http://shapelib.maptools.org/"
+SRC_URI="http://download.osgeo.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+src_prepare() {
+ default
+ rm -f m4/* || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --includedir="${EPREFIX}"/usr/include/libshp \
+ --prefix="${EPREFIX}"/usr
+}
+
+src_install() {
+ use doc && HTML_DOCS=( web/. )
+ default
+
+ if ! use static-libs; then
+ find "${ED}" \( -name '*.la' -o -name '*.a' \) -delete || die
+ fi
+}