summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-07 18:08:04 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-07 18:16:40 +0200
commit4e395289d603a579eb9f18fd02975b37e4e3ac87 (patch)
treea26f52f9d257bc0f519c91b9bd622b5964503ab2 /sci-libs
parentsci-libs/orocos_kdl: install package.xml file in /usr/share/ros_packages/$PN (diff)
downloadgentoo-4e395289d603a579eb9f18fd02975b37e4e3ac87.tar.gz
gentoo-4e395289d603a579eb9f18fd02975b37e4e3ac87.tar.bz2
gentoo-4e395289d603a579eb9f18fd02975b37e4e3ac87.zip
ci-libs/octomap: install package.xml in /usr/share/ros_packages/$PN
Package-Manager: portage-2.3.1
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/octomap/files/gentoo.patch39
-rw-r--r--sci-libs/octomap/octomap-1.8.0-r2.ebuild (renamed from sci-libs/octomap/octomap-1.8.0-r1.ebuild)1
-rw-r--r--sci-libs/octomap/octomap-9999.ebuild1
3 files changed, 41 insertions, 0 deletions
diff --git a/sci-libs/octomap/files/gentoo.patch b/sci-libs/octomap/files/gentoo.patch
new file mode 100644
index 000000000000..0fe7426c2855
--- /dev/null
+++ b/sci-libs/octomap/files/gentoo.patch
@@ -0,0 +1,39 @@
+Index: octomap-1.8.0/dynamicEDT3D/CMakeLists.txt
+===================================================================
+--- octomap-1.8.0.orig/dynamicEDT3D/CMakeLists.txt
++++ octomap-1.8.0/dynamicEDT3D/CMakeLists.txt
+@@ -62,7 +62,7 @@ file(GLOB dynamicEDT3D_HDRS ${PROJECT_SO
+ install(FILES ${dynamicEDT3D_HDRS} DESTINATION include/dynamicEDT3D)
+
+ # Install catkin package.xml, attention package.xml names the catkin package "dynamic_edt_3d", so this is also the location where it needs to be installed to (and not "dynamicEDT3D")
+-install(FILES package.xml DESTINATION share/dynamic_edt_3d)
++install(FILES package.xml DESTINATION share/ros_packages/dynamic_edt_3d)
+
+ #TODO: this conflicts with the octomap uninstall
+ #it is not only a target name problem, also both will use the same manifest file
+Index: octomap-1.8.0/octomap/CMakeLists.txt
+===================================================================
+--- octomap-1.8.0.orig/octomap/CMakeLists.txt
++++ octomap-1.8.0/octomap/CMakeLists.txt
+@@ -65,7 +65,7 @@ file(GLOB octomap_math_HDRS ${PROJECT_SO
+ install(FILES ${octomap_math_HDRS} DESTINATION include/octomap/math)
+
+ # Install catkin package.xml
+-install(FILES package.xml DESTINATION share/octomap)
++install(FILES package.xml DESTINATION share/ros_packages/octomap)
+
+ # uninstall target
+ configure_file(
+Index: octomap-1.8.0/octovis/CMakeLists.txt
+===================================================================
+--- octomap-1.8.0.orig/octovis/CMakeLists.txt
++++ octomap-1.8.0/octovis/CMakeLists.txt
+@@ -126,7 +126,7 @@ IF(BUILD_VIEWER)
+ install(FILES ${octovis_HDRS} DESTINATION include/octovis)
+
+ # Install catkin package.xml
+- install(FILES package.xml DESTINATION share/octovis)
++ install(FILES package.xml DESTINATION share/ros_packages/octovis)
+
+ ELSE()
+ MESSAGE ( "Unfortunately, the viewer (octovis) can not be built because some requirements are missing.")
diff --git a/sci-libs/octomap/octomap-1.8.0-r1.ebuild b/sci-libs/octomap/octomap-1.8.0-r2.ebuild
index 2b3509c9f9fb..19df370fdb02 100644
--- a/sci-libs/octomap/octomap-1.8.0-r1.ebuild
+++ b/sci-libs/octomap/octomap-1.8.0-r2.ebuild
@@ -40,6 +40,7 @@ DEPEND="${RDEPEND}
media-gfx/graphviz
)
"
+PATCHES=( "${FILESDIR}/gentoo.patch" )
src_prepare() {
sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
diff --git a/sci-libs/octomap/octomap-9999.ebuild b/sci-libs/octomap/octomap-9999.ebuild
index 2b3509c9f9fb..19df370fdb02 100644
--- a/sci-libs/octomap/octomap-9999.ebuild
+++ b/sci-libs/octomap/octomap-9999.ebuild
@@ -40,6 +40,7 @@ DEPEND="${RDEPEND}
media-gfx/graphviz
)
"
+PATCHES=( "${FILESDIR}/gentoo.patch" )
src_prepare() {
sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \