summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-11-22 20:33:05 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-22 20:33:59 +0100
commit5765d5ecff0fe767a6434d4e555965a65b5a87e3 (patch)
treedd422c60ef4015e717111f54ee1d6f0709aef300 /sci-libs
parentmedia-libs/libsndfile: Remove old (diff)
downloadgentoo-5765d5ecff0fe767a6434d4e555965a65b5a87e3.tar.gz
gentoo-5765d5ecff0fe767a6434d4e555965a65b5a87e3.tar.bz2
gentoo-5765d5ecff0fe767a6434d4e555965a65b5a87e3.zip
sci-libs/fftw: Use 'tc-check-openmp' for checking OpenMP support
Package-Manager: portage-2.3.2
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/fftw/fftw-2.1.5-r9.ebuild15
-rw-r--r--sci-libs/fftw/fftw-3.3.5-r2.ebuild15
2 files changed, 10 insertions, 20 deletions
diff --git a/sci-libs/fftw/fftw-2.1.5-r9.ebuild b/sci-libs/fftw/fftw-2.1.5-r9.ebuild
index bc142c731eb3..496c5e5d578e 100644
--- a/sci-libs/fftw/fftw-2.1.5-r9.ebuild
+++ b/sci-libs/fftw/fftw-2.1.5-r9.ebuild
@@ -29,18 +29,13 @@ PATCHES=(
"${FILESDIR}"/${P}-texinfo5.1.patch
)
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
- if ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected compiler"
-
- if tc-is-clang; then
- ewarn "OpenMP support in sys-devel/clang is provided by sys-libs/libomp,"
- ewarn "which you will need to build ${CATEGORY}/${PN} with USE=\"openmp\""
- fi
-
- die "need openmp capable compiler"
- fi
+ tc-check-openmp
FORTRAN_NEED_OPENMP=1
fi
diff --git a/sci-libs/fftw/fftw-3.3.5-r2.ebuild b/sci-libs/fftw/fftw-3.3.5-r2.ebuild
index e577bdcc4b54..c9f3b9a5e9c9 100644
--- a/sci-libs/fftw/fftw-3.3.5-r2.ebuild
+++ b/sci-libs/fftw/fftw-3.3.5-r2.ebuild
@@ -28,18 +28,13 @@ RDEPEND="
DEPEND="${RDEPEND}
test? ( dev-lang/perl )"
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
- if ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected compiler"
-
- if tc-is-clang; then
- ewarn "OpenMP support in sys-devel/clang is provided by sys-libs/libomp,"
- ewarn "which you will need to build ${CATEGORY}/${PN} with USE=\"openmp\""
- fi
-
- die "need openmp capable compiler"
- fi
+ tc-check-openmp
FORTRAN_NEED_OPENMP=1
fi