summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-01-17 00:33:29 +0100
committerDavid Seifert <soap@gentoo.org>2016-01-17 00:34:21 +0100
commit59caeae1788d18755336c605ffb35e3f0bf434a1 (patch)
treeb3d900e9859ab6636c9239fae3f8528a28d304b8 /sci-libs
parentdev-vcs/git: Conditionally add patches that improve MediaWiki cloning (diff)
downloadgentoo-59caeae1788d18755336c605ffb35e3f0bf434a1.tar.gz
gentoo-59caeae1788d18755336c605ffb35e3f0bf434a1.tar.bz2
gentoo-59caeae1788d18755336c605ffb35e3f0bf434a1.zip
sci-libs/getdata: Add and make dependencies explicit
Gentoo-Bug: 571752 * disable PHP bindings (previously automagic) * fix broken Python bindings handling * fix 'static-libs' handling * add 'cxx' C++ bindings generation * add 'flac' FLAC encoding generation * disable Matlab bindings (previously automagic) * disable libzzip encoding generation (previously automagic) Package-Manager: portage-2.2.26
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/getdata/files/getdata-0.9.0-remove-python-test.patch13
-rw-r--r--sci-libs/getdata/getdata-0.9.0-r1.ebuild65
2 files changed, 78 insertions, 0 deletions
diff --git a/sci-libs/getdata/files/getdata-0.9.0-remove-python-test.patch b/sci-libs/getdata/files/getdata-0.9.0-remove-python-test.patch
new file mode 100644
index 000000000000..98da89dfb8ec
--- /dev/null
+++ b/sci-libs/getdata/files/getdata-0.9.0-remove-python-test.patch
@@ -0,0 +1,13 @@
+Remove python test suite.
+
+--- getdata-0.9.0/bindings/python/Makefile.am
++++ getdata-0.9.0/bindings/python/Makefile.am
+@@ -20,8 +20,6 @@
+ #
+ AUTOMAKE_OPTIONS = foreign
+
+-SUBDIRS=test
+-
+ nodist_python_SCRIPTS = pygetdata.so
+
+ BUILT_SOURCES = pyconstants.c
diff --git a/sci-libs/getdata/getdata-0.9.0-r1.ebuild b/sci-libs/getdata/getdata-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..16e0ea55651f
--- /dev/null
+++ b/sci-libs/getdata/getdata-0.9.0-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+FORTRAN_STANDARD="95"
+FORTRAN_NEEDED=fortran
+
+inherit autotools eutils fortran-2 python-single-r1
+
+DESCRIPTION="Reference implementation of the Dirfile, format for time-ordered binary data"
+HOMEPAGE="http://getdata.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 cxx debug flac fortran lzma perl python static-libs"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ perl? ( dev-lang/perl )
+ python? ( dev-python/numpy[${PYTHON_USEDEP}] ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-remove-python-test.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-idl \
+ --disable-matlab \
+ --disable-php \
+ $(use_enable cxx cplusplus) \
+ $(use_enable debug) \
+ $(use_enable fortran) \
+ $(use_enable fortran fortran95) \
+ $(use_enable perl) \
+ $(use_enable python) \
+ $(use_enable static-libs static) \
+ --with-libz \
+ --without-libslim \
+ --without-libzzip \
+ $(use_with bzip2 libbz2) \
+ $(use_with flac libFLAC) \
+ $(use_with lzma liblzma) \
+ $(usex perl --with-perl-dir=vendor)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}