summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-01-15 22:52:41 +0000
committerJustin Lecher <jlec@gentoo.org>2017-01-15 22:52:54 +0000
commit5f34df490cc12bdb24e89fac3424d4e2ebb5596c (patch)
treea3daeba845668e934530b7b0e759424b3dd9f598 /sci-libs
parentsci-libs/shogun: Drop old (diff)
downloadgentoo-5f34df490cc12bdb24e89fac3424d4e2ebb5596c.tar.gz
gentoo-5f34df490cc12bdb24e89fac3424d4e2ebb5596c.tar.bz2
gentoo-5f34df490cc12bdb24e89fac3424d4e2ebb5596c.zip
sci-libs/mpir: Backport patch for newer sed
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=604764 Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/mpir/files/mpir-2.7.2-sed-backport.patch16
-rw-r--r--sci-libs/mpir/mpir-2.7.2.ebuild9
2 files changed, 24 insertions, 1 deletions
diff --git a/sci-libs/mpir/files/mpir-2.7.2-sed-backport.patch b/sci-libs/mpir/files/mpir-2.7.2-sed-backport.patch
new file mode 100644
index 000000000000..897642909ca0
--- /dev/null
+++ b/sci-libs/mpir/files/mpir-2.7.2-sed-backport.patch
@@ -0,0 +1,16 @@
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index a3821c5..15fa93d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2595,7 +2595,7 @@ for tmp_fn in $gmp_mpn_functions; do
+ sed -n 's/^[ ]*MULFUNC_PROLOGUE(\(.*\))/\1/p' $tmp_file ;
+ sed -n 's/^[ ]*PROLOGUE(\([^,]*\).*)/\1/p' $tmp_file ;
+ sed -n 's/^;[ ]*PROLOGUE(\([^,]*\).*)/\1/p' $tmp_file ;
+- sed -n 's/[^G]*GLOBAL_FUNC[:space:]*\(.*\)/\1/p' $tmp_file ;
++ sed -n 's/[^G]*GLOBAL_FUNC[[:space:]]*\(.*\)/\1/p' $tmp_file ;
+ `]
+ for gmp_tmp in $gmp_ep; do
+ AC_DEFINE_UNQUOTED(HAVE_NATIVE_$gmp_tmp)
diff --git a/sci-libs/mpir/mpir-2.7.2.ebuild b/sci-libs/mpir/mpir-2.7.2.ebuild
index 20408ff7574a..e49488b3c8b7 100644
--- a/sci-libs/mpir/mpir-2.7.2.ebuild
+++ b/sci-libs/mpir/mpir-2.7.2.ebuild
@@ -4,7 +4,7 @@
EAPI=6
-inherit autotools eutils toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="Library for arbitrary precision integer arithmetic (fork of gmp)"
HOMEPAGE="http://www.mpir.org/"
@@ -23,6 +23,7 @@ RDEPEND=""
PATCHES=(
"${FILESDIR}"/${P}-ABI-multilib.patch
+ "${FILESDIR}"/${P}-sed-backport.patch
)
src_prepare() {
@@ -63,6 +64,12 @@ src_configure() {
--with-system-yasm
$(use_enable cxx)
$(use_enable cpudetection fat)
+ $(use_enable static-libs static)
)
econf ${myeconfargs[@]}
}
+
+src_install() {
+ default
+ rm "${ED}"/usr/$(get_libdir)/*la || die
+}