summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2019-08-19 15:49:21 +0800
committerBenda Xu <heroxbd@gentoo.org>2019-08-19 15:49:51 +0800
commit77dd20308b4aca8c18f3964196af7252aa85bbc1 (patch)
treed2ade5a75605058d72d62e9ada527c3ada43f37f /sci-libs
parentdev-db/sqlcipher: restrict failing testsuite (diff)
downloadgentoo-77dd20308b4aca8c18f3964196af7252aa85bbc1.tar.gz
gentoo-77dd20308b4aca8c18f3964196af7252aa85bbc1.tar.bz2
gentoo-77dd20308b4aca8c18f3964196af7252aa85bbc1.zip
sci-libs/iml: import from the science overlay and bump to EAPI 7.
Closes: https://bugs.gentoo.org/563288 Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/iml/Manifest1
-rw-r--r--sci-libs/iml/files/iml-1.0.4-use-any-cblas-implementation.patch22
-rw-r--r--sci-libs/iml/iml-1.0.5.ebuild38
-rw-r--r--sci-libs/iml/metadata.xml9
4 files changed, 70 insertions, 0 deletions
diff --git a/sci-libs/iml/Manifest b/sci-libs/iml/Manifest
new file mode 100644
index 000000000000..268159880c63
--- /dev/null
+++ b/sci-libs/iml/Manifest
@@ -0,0 +1 @@
+DIST iml-1.0.5.tar.bz2 391757 BLAKE2B 5895b353269ce19e17e2522f78eb705c89a47ed3c6cce54d1b7ab3003f59d0a13050b30ce9cedbf38392c737c169740b6c2433f1a74856b0f9d4e6e007ebf804 SHA512 b5a85982636035cc50acba7dcff5478c6271be3669313f01915b2761302d4c77617c0dd7932daf74433098670d3ffdb2ef19eb24450b40709750a0b7c8f797f1
diff --git a/sci-libs/iml/files/iml-1.0.4-use-any-cblas-implementation.patch b/sci-libs/iml/files/iml-1.0.4-use-any-cblas-implementation.patch
new file mode 100644
index 000000000000..28d70bf91663
--- /dev/null
+++ b/sci-libs/iml/files/iml-1.0.4-use-any-cblas-implementation.patch
@@ -0,0 +1,22 @@
+Patch to detect ATLAS or cblas. Ported from 1.0.3 to 1.0.4.
+
+Patch by Marius Brehler.
+--- a/configure.ac
++++ b/configure.ac
+@@ -76,15 +76,7 @@ location with the options --with-gmp-inc
+ respectively when running configure.
+ )])
+
+-IML_CHECK_CBLAS(,,[AC_MSG_WARN(
+-CBLAS not found!
+-Please make sure that --with-cblas=<linker flags> and optional --with-cblas-include=<path> and --with-cblas-lib=<path> are correctly set.
+-Trying legacy ATLAS configuration.)
+-IML_CHECK_ATLAS(,,[AC_MSG_ERROR(
+-ATLAS not found!
+-ATLAS version 3.0 or greater is required for this library to compile. Please make sure ATLAS is installed and specify the header and libraries location with the options --with-atlas-include=<path> and --with-atlas-lib=<path> respectively when running configure.)
+-])
+-])
++PKG_CHECK_MODULES([ATLAS], [cblas])
+
+ AC_SUBST(LIBIML_LDFLAGS)
+ AC_SUBST(LDFLAGS)
diff --git a/sci-libs/iml/iml-1.0.5.ebuild b/sci-libs/iml/iml-1.0.5.ebuild
new file mode 100644
index 000000000000..25907543c005
--- /dev/null
+++ b/sci-libs/iml/iml-1.0.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Integer Matrix Library"
+HOMEPAGE="http://www.cs.uwaterloo.ca/~astorjoh/iml.html"
+SRC_URI="http://www.cs.uwaterloo.ca/~astorjoh/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RESTRICT="mirror"
+
+DEPEND="virtual/cblas"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.4-use-any-cblas-implementation.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-default="${EPREFIX}"/usr \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
diff --git a/sci-libs/iml/metadata.xml b/sci-libs/iml/metadata.xml
new file mode 100644
index 000000000000..673326db1e86
--- /dev/null
+++ b/sci-libs/iml/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>a free library of C source code which implements algorithms for computing exact solutions to dense systems of linear equations over the integers</longdescription>
+</pkgmetadata>