summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-08-04 09:59:56 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-08-04 09:59:56 +0200
commit7dd94587118b7333242a46b4f97c22ed69d6fc0d (patch)
tree6f1b8da06478848c1cbfc15aa142c8c5059684e6 /sci-libs
parentdev-python/bottle: Fix BDEPEND order (diff)
downloadgentoo-7dd94587118b7333242a46b4f97c22ed69d6fc0d.tar.gz
gentoo-7dd94587118b7333242a46b4f97c22ed69d6fc0d.tar.bz2
gentoo-7dd94587118b7333242a46b4f97c22ed69d6fc0d.zip
sci-libs/caffe2: filter lto
Closes: https://bugs.gentoo.org/862672 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/caffe2/caffe2-1.11.0-r2.ebuild2
-rw-r--r--sci-libs/caffe2/caffe2-1.12.0.ebuild5
2 files changed, 4 insertions, 3 deletions
diff --git a/sci-libs/caffe2/caffe2-1.11.0-r2.ebuild b/sci-libs/caffe2/caffe2-1.11.0-r2.ebuild
index 6ae8a8dc9187..b5c92d8e88df 100644
--- a/sci-libs/caffe2/caffe2-1.11.0-r2.ebuild
+++ b/sci-libs/caffe2/caffe2-1.11.0-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit python-r1 cmake
MYPN=pytorch
diff --git a/sci-libs/caffe2/caffe2-1.12.0.ebuild b/sci-libs/caffe2/caffe2-1.12.0.ebuild
index a7bc65b359da..d8b678dbc4e8 100644
--- a/sci-libs/caffe2/caffe2-1.12.0.ebuild
+++ b/sci-libs/caffe2/caffe2-1.12.0.ebuild
@@ -3,8 +3,8 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
-inherit python-r1 cmake
+PYTHON_COMPAT=( python3_{8..11} )
+inherit python-r1 cmake flag-o-matic
MYPN=pytorch
MYP=${MYPN}-${PV}
@@ -69,6 +69,7 @@ PATCHES=(
)
src_prepare() {
+ filter-lto #bug 862672
cmake_src_prepare
pushd torch/csrc/jit/serialization || die
flatc --cpp --gen-mutable --scoped-enums mobile_bytecode.fbs || die