summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2020-01-27 12:54:55 +0800
committerBenda Xu <heroxbd@gentoo.org>2020-01-27 12:59:38 +0800
commit809afd4a24533311ced5ecfb2f022b539a3b6dd2 (patch)
tree804d79150f4474ed731f31e31cf0da008fb3d5d5 /sci-libs
parentx11-misc/xmountains: Replace local patch with upstream patch (diff)
downloadgentoo-809afd4a24533311ced5ecfb2f022b539a3b6dd2.tar.gz
gentoo-809afd4a24533311ced5ecfb2f022b539a3b6dd2.tar.bz2
gentoo-809afd4a24533311ced5ecfb2f022b539a3b6dd2.zip
sci-libs/scipy: disable parallel build completely.
After 4 years discussion and debugging, we conclude that Python 3 is deeply broken in parallel builds for anything involving compiling of C/C++/fortran code. The problem is universal, regardless how dev-python/numpy is built. Numpy and scipy upstream cannot do anything about this. We bite the bullet and disable parallel build of scipy completely. Thanks to all who have contributed to this heroic marathon debugging. We regret that only a workaround can be provided at this moment. Credit: Andrés Becerra Sandoval, Hendrik v. Raven, younky.yang@yahoo.com Credit: matoro, Denis Descheneaux, Mathy Vanvoorden, email200202@yahoo.com Credit: jon R-B, Anton Kochkov, Jonas Stein, edes, David Duchesne Credit: thulle, Mathy Vanvoorden, Sasha Medvedev, rtgiskard@gmail.com Credit: Lukasz Ligowski, Zentoo, Jouni Kosonen, Neil, Harris Landgarten Credit: Markus Oehme, Andreas Proteus Suggested-By: François Bissey, Arfrever Frehtes Taifersar Arahesis Reference: https://github.com/numpy/numpy/issues/13080 Reference: https://github.com/scipy/scipy/issues/7112 Closes: https://bugs.gentoo.org/614464 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/scipy/scipy-1.4.1.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/sci-libs/scipy/scipy-1.4.1.ebuild b/sci-libs/scipy/scipy-1.4.1.ebuild
index a9e7e584875f..b176683c8870 100644
--- a/sci-libs/scipy/scipy-1.4.1.ebuild
+++ b/sci-libs/scipy/scipy-1.4.1.ebuild
@@ -108,6 +108,8 @@ python_prepare_all() {
python_compile() {
# FIXME: parallel python building fails, bug #614464
+ export MAKEOPTS=-j1
+
${EPYTHON} tools/cythonize.py || die
distutils-r1_python_compile \
${SCIPY_FCONFIG}