summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-01-19 13:50:19 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-01-19 13:50:19 +0100
commit82aecb580395c02c8f5411906452a4f01684165b (patch)
treeed300079730a4de736960ae18d90d8d30bb1bc2e /sci-libs
parentdev-ml/eliom: backport upstream patch to build with tyxml 3.6 (diff)
downloadgentoo-82aecb580395c02c8f5411906452a4f01684165b.tar.gz
gentoo-82aecb580395c02c8f5411906452a4f01684165b.tar.bz2
gentoo-82aecb580395c02c8f5411906452a4f01684165b.zip
sci-libs/fcl: bump to 0.4.0
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/fcl/Manifest1
-rw-r--r--sci-libs/fcl/fcl-0.4.0.ebuild42
-rw-r--r--sci-libs/fcl/fcl-9999.ebuild5
3 files changed, 43 insertions, 5 deletions
diff --git a/sci-libs/fcl/Manifest b/sci-libs/fcl/Manifest
index d77d7e4eea6c..05f86126eb6d 100644
--- a/sci-libs/fcl/Manifest
+++ b/sci-libs/fcl/Manifest
@@ -1 +1,2 @@
DIST fcl-0.3.2.tar.gz 5745349 SHA256 cf914f85b32cf8b63879907726df64e50da33f00d538759d789fe10fc5fbc95b SHA512 799c0f698c9d19ebd72c01b4bd51435feda1792462759249446ab968bf3b2b462537ce20135444c3e555da8564d0c93196f3f3448e2a4282afca710b67eaeb6e WHIRLPOOL 4d0694c7a27f117251709368542a5e7ed8ab3ec6e39e0400027f4409bf1b5cad3ff55c14ff529de19137c5dec6a4222799cc3bf0e1081c13105ea6dbc1e17c90
+DIST fcl-0.4.0.tar.gz 5762341 SHA256 1bea2cd5ee6034166d42860a6c5577f807c81f9f54d09dd680fb9bdf58d46747 SHA512 c565b4018a37449ce05b9189a97f2084a68caaa9247968fecdf933d8f5d87ed629d3fcb6ffccf928c4d339be1b70650b78706cc9d4a0c24864da529b25761684 WHIRLPOOL 2463490135ef16f29f608e68e2b2b0d86a7af59b54360275e73dae8d52aea3c7f9013e7a8be794a3fbb1981cf1470fe55866322aed188dd5c4bec0ba96512fa2
diff --git a/sci-libs/fcl/fcl-0.4.0.ebuild b/sci-libs/fcl/fcl-0.4.0.ebuild
new file mode 100644
index 000000000000..064b54f963d4
--- /dev/null
+++ b/sci-libs/fcl/fcl-0.4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/flexible-collision-library/fcl"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="https://github.com/flexible-collision-library/fcl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="The Flexible Collision Library"
+HOMEPAGE="http://gamma.cs.unc.edu/FCL/"
+LICENSE="BSD"
+SLOT="0"
+IUSE="cpu_flags_x86_sse"
+
+RDEPEND="
+ sci-libs/octomap
+ sci-libs/flann
+ dev-libs/boost:=[threads]
+ sci-libs/libccd"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DFCL_USE_SSE=$(usex cpu_flags_x86_sse TRUE FALSE)"
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-libs/fcl/fcl-9999.ebuild b/sci-libs/fcl/fcl-9999.ebuild
index 227af31f64f5..064b54f963d4 100644
--- a/sci-libs/fcl/fcl-9999.ebuild
+++ b/sci-libs/fcl/fcl-9999.ebuild
@@ -34,11 +34,6 @@ RDEPEND="
DEPEND="${RDEPEND}
virtual/pkgconfig"
-src_prepare() {
- sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/g' \
- -i src/CMakeLists.txt || die
-}
-
src_configure() {
local mycmakeargs=(
"-DFCL_USE_SSE=$(usex cpu_flags_x86_sse TRUE FALSE)"