summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZhang Zongyu <zongyu@novazy.net>2021-11-29 14:51:39 +0800
committerBenda Xu <heroxbd@gentoo.org>2021-12-02 12:44:09 +0800
commit89178d7ff98a92ac779a6911ea948ef372c789c1 (patch)
tree6ba9136c7b7fbdf33c20e458dc445611da8d608e /sci-libs
parentmedia-sound/sidplayfp: add musl patch (diff)
downloadgentoo-89178d7ff98a92ac779a6911ea948ef372c789c1.tar.gz
gentoo-89178d7ff98a92ac779a6911ea948ef372c789c1.tar.bz2
gentoo-89178d7ff98a92ac779a6911ea948ef372c789c1.zip
sci-libs/blis: bump version to 0.8.1
Closes: https://github.com/gentoo/gentoo/pull/23106 Closes: https://bugs.gentoo.org/764098 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Zhang Zongyu <zongyu@novazy.net> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/blis/Manifest1
-rw-r--r--sci-libs/blis/blis-0.8.1.ebuild112
-rw-r--r--sci-libs/blis/files/blis-0.8.1-pkg-config.patch9
3 files changed, 122 insertions, 0 deletions
diff --git a/sci-libs/blis/Manifest b/sci-libs/blis/Manifest
index 470da790704a..ec8f4283416a 100644
--- a/sci-libs/blis/Manifest
+++ b/sci-libs/blis/Manifest
@@ -1 +1,2 @@
DIST blis-0.6.0.tar.gz 5107257 BLAKE2B cd589ad1216486e8bb0cf574cc096c1e1f2bb9587b182c2bcff44db322468d9f027323c0bf2d22ea0fabb1902dc047d2bf62253ef1c2797fc3de9ba53d7fc34a SHA512 74e9da5146f7986cbd11651d7cd0837562a1603c667b9e6d3f79b5057443de657b60d7463cb2d64daf3eff7d33fc05a64e6d8eb807f4cabe0c3121517924a206
+DIST blis-0.8.1.tar.gz 13442609 BLAKE2B cc4167aaa6461b73876f428de2ab02107803fd6d63df101bf30de4c6ca57241e29f09dfb82fe1cfec8c661b2d9efe65ab854ad7719bf36e27f8a33bf3dd4bb92 SHA512 f920e6ae699af899caca27274b55bb944c886c882dfc06bc2f66d069c08e6d4999c130626cd96297308c1b7e85e77e6552bf981cce37dbbaa5acdf0cb5078e02
diff --git a/sci-libs/blis/blis-0.8.1.ebuild b/sci-libs/blis/blis-0.8.1.ebuild
new file mode 100644
index 000000000000..e94157178cb8
--- /dev/null
+++ b/sci-libs/blis/blis-0.8.1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-any-r1
+
+DESCRIPTION="BLAS-like Library Instantiation Software Framework"
+HOMEPAGE="https://github.com/flame/blis"
+SRC_URI="https://github.com/flame/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="doc eselect-ldso openmp pthread serial static-libs 64bit-index"
+REQUIRED_USE="
+ ?? ( openmp pthread serial )
+ ?? ( eselect-ldso 64bit-index )"
+
+DEPEND="
+ eselect-ldso? (
+ !app-eselect/eselect-cblas
+ >=app-eselect/eselect-blas-0.2
+ )"
+
+RDEPEND="${DEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.0-rpath.patch
+ "${FILESDIR}"/${PN}-0.6.0-blas-provider.patch
+ "${FILESDIR}"/${P}-pkg-config.patch
+)
+
+src_configure() {
+ local BLIS_FLAGS=()
+ local confname
+ # determine flags
+ if use openmp; then
+ BLIS_FLAGS+=( -t openmp )
+ elif use pthread; then
+ BLIS_FLAGS+=( -t pthreads )
+ else
+ BLIS_FLAGS+=( -t no )
+ fi
+ use 64bit-index && BLIS_FLAGS+=( -b 64 -i 64 )
+ # determine config name
+ case "${ARCH}" in
+ "x86" | "amd64")
+ confname=auto ;;
+ "ppc64")
+ confname=generic ;;
+ *)
+ confname=generic ;;
+ esac
+ # This is not an autotools configure file. We don't use econf here.
+ ./configure \
+ --enable-verbose-make \
+ --prefix="${BROOT}"/usr \
+ --libdir="${BROOT}"/usr/$(get_libdir) \
+ $(use_enable static-libs static) \
+ --enable-blas \
+ --enable-cblas \
+ "${BLIS_FLAGS[@]}" \
+ --enable-shared \
+ $confname || die
+}
+
+src_compile() {
+ DEB_LIBBLAS=libblas.so.3 DEB_LIBCBLAS=libcblas.so.3 \
+ LDS_BLAS="${FILESDIR}"/blas.lds LDS_CBLAS="${FILESDIR}"/cblas.lds \
+ default
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+ use doc && dodoc README.md docs/*.md
+
+ if use eselect-ldso; then
+ insinto /usr/$(get_libdir)/blas/blis
+ doins lib/*/lib{c,}blas.so.3
+ dosym libblas.so.3 usr/$(get_libdir)/blas/blis/libblas.so
+ dosym libcblas.so.3 usr/$(get_libdir)/blas/blis/libcblas.so
+ fi
+}
+
+pkg_postinst() {
+ use eselect-ldso || return
+
+ local libdir=$(get_libdir) me="blis"
+
+ # check blas
+ eselect blas add ${libdir} "${EROOT}"/usr/${libdir}/blas/${me} ${me}
+ local current_blas=$(eselect blas show ${libdir} | cut -d' ' -f2)
+ if [[ ${current_blas} == "${me}" || -z ${current_blas} ]]; then
+ eselect blas set ${libdir} ${me}
+ elog "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
+ else
+ elog "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
+ elog "To use blas [${me}] implementation, you have to issue (as root):"
+ elog "\t eselect blas set ${libdir} ${me}"
+ fi
+}
+
+pkg_postrm() {
+ use eselect-ldso && eselect blas validate
+}
diff --git a/sci-libs/blis/files/blis-0.8.1-pkg-config.patch b/sci-libs/blis/files/blis-0.8.1-pkg-config.patch
new file mode 100644
index 000000000000..2e1f189422a3
--- /dev/null
+++ b/sci-libs/blis/files/blis-0.8.1-pkg-config.patch
@@ -0,0 +1,9 @@
+diff -Nur a/blis.pc.in b/blis.pc.in
+--- a/blis.pc.in 2021-11-29 13:23:43.692800836 +0800
++++ b/blis.pc.in 2021-11-29 13:25:52.150795803 +0800
+@@ -7,5 +7,4 @@
+ Description: BLAS-like Library Instantiation Software Framework
+ Version: @PACKAGE_VERSION@
+ Libs: -L${libdir} -lblis
+-Libs.private: @LDFLAGS@
+ Cflags: -I${includedir}/blis