summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2017-01-13 20:39:42 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-15 11:12:06 +0100
commit920c14942473074b0f5c53cd81081b6915df73df (patch)
tree053d94849284c6e04b67ed1dd908dc4d15dade72 /sci-libs
parentsci-libs/libtifiles2: Removing EAPI 4 file 1.1.5 (diff)
downloadgentoo-920c14942473074b0f5c53cd81081b6915df73df.tar.gz
gentoo-920c14942473074b0f5c53cd81081b6915df73df.tar.bz2
gentoo-920c14942473074b0f5c53cd81081b6915df73df.zip
sci-libs/libticables2: Version bump to 1.3.5, EAPI bump 5 -> 6
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/3456
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libticables2/Manifest1
-rw-r--r--sci-libs/libticables2/libticables2-1.3.5.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sci-libs/libticables2/Manifest b/sci-libs/libticables2/Manifest
index 6960f89d469f..0b85bbfa0c8c 100644
--- a/sci-libs/libticables2/Manifest
+++ b/sci-libs/libticables2/Manifest
@@ -1,2 +1,3 @@
DIST libticables2-1.3.3.tar.bz2 495883 SHA256 e31ffc2324884aeec37b0cc220e62c78a44c43ab874a933939bfe80c4e84071e SHA512 19c9a6bb8319ccf9e9004e10c4addffbee605c3735e53e4a5628b360b0c2e8575076208d14d00d6304eb894d3c69aede6de00120cd26f8c543c6e6cc4adb21a9 WHIRLPOOL ca916a99942097518fa686b1c68d9260852fa5f88ed4b60649471590c94e84e60ffc2f5cd74c91ec1f11393a0e65a5675ad06ae4d0879c41124f307cb03bb11c
DIST libticables2-1.3.4.tar.bz2 920163 SHA256 45cae91ad9ee1cc2ebc0f5865923ff77f1e0adf0793d3010eeb802efc140e5b0 SHA512 fbea9ed2041a04f79e02045d40e88a3ab20edc8d86ecef4ae6a181063f3609b8b2c3aeb2ce2f4508be56655accba60eab7379116ac341921f233f469eb99b461 WHIRLPOOL 1ce06ad05ffc9919dfc24a6f5ee1f31555d61b1693b994c7b2970d8a8ba551b0744c51d60d8d288c2df607b8961a8826543e2edac17090f692c4d36d7828b05d
+DIST libticables2-1.3.5.tar.bz2 187416 SHA256 0c6fb6516e72ccab081ddb3aecceff694ed93aec689ddd2edba9c7c7406c4522 SHA512 171abdf41f496891c62da17a2b84d929ac32021b0f2abc0c37ed73ec93806d4a14df37a8ffbe2b0c172ff3461aa6c639fc1ba23aafb19e024b99448dd66c63bd WHIRLPOOL 9f4c4451035040767f7fff7186978dd69101b311930db88c72291273a45f28809591eff0210296fe016591f81de3424f8979f6469fb1d80656b2d156f5f3f58e
diff --git a/sci-libs/libticables2/libticables2-1.3.5.ebuild b/sci-libs/libticables2/libticables2-1.3.5.ebuild
new file mode 100644
index 000000000000..0f86b9312b0f
--- /dev/null
+++ b/sci-libs/libticables2/libticables2-1.3.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Library to handle different link cables for TI calculators"
+HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
+SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug doc nls static-libs usb"
+
+RDEPEND="
+ dev-libs/glib:2
+ usb? ( virtual/libusb:1 )
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # --disable-libusb $(use_enable usb libusb10) would enable virtual/libusb:1
+ econf \
+ --disable-rpath \
+ $(use_enable static-libs static) \
+ $(use_enable debug logging) \
+ $(use_enable nls) \
+ $(use_enable usb libusb) \
+ $(use_enable usb libusb10)
+}
+
+src_install() {
+ use doc && HTML_DOCS+=( docs/html/. )
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "Please read README in ${EROOT%/}/usr/share/doc/${PF}"
+ elog "if you encounter any problem with a link cable"
+}