summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2019-08-21 06:57:11 +0200
committerSlawomir Lis <slis@gentoo.org>2019-08-21 06:57:27 +0200
commit9ef07e5b3c16d401d55a22723073926a2fdde6df (patch)
tree4c3116d336459374c2ecdb382ca3b14e7ca2ed7b /sci-libs
parentsys-auth/oath-toolkit-2.6.2: x86 stable (diff)
downloadgentoo-9ef07e5b3c16d401d55a22723073926a2fdde6df.tar.gz
gentoo-9ef07e5b3c16d401d55a22723073926a2fdde6df.tar.bz2
gentoo-9ef07e5b3c16d401d55a22723073926a2fdde6df.zip
sci-libs/Shapely: version bump to 1.6.4_p2
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Slawek Lis <slis@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/Shapely/Manifest1
-rw-r--r--sci-libs/Shapely/Shapely-1.6.4_p2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sci-libs/Shapely/Manifest b/sci-libs/Shapely/Manifest
index 358734296469..ab1a676fbf86 100644
--- a/sci-libs/Shapely/Manifest
+++ b/sci-libs/Shapely/Manifest
@@ -1,3 +1,4 @@
DIST Shapely-1.3.0.tar.gz 118863 BLAKE2B 6a35060b6593519b62b479fdb21047e0a44976109e27a55dbdf7583952666c8cfecf775975be54701696d57d3c5b1082110dd474df265ccf5b467acddcd2a629 SHA512 106f9773a5b00e7269a84c760f3a2b867c48139c48eebeecd524c8216d75c28daaf46eff45c118c1809999e33a317e9aca278a8d83605dc7273877a7ed3edd82
DIST Shapely-1.3.2.tar.gz 120179 BLAKE2B bc10e017a546e715c05c4edb1aab4f86cb0fd6f1f35ab23f1d8dcdf402c96bbbbaca92668cf9bc788387dac8cabd958cfa3ffff5a90045f2f2a7a6798383cb2d SHA512 23d65c5a7137726e05e0399dc49f05e5ad9b582d4adcdf30215f72ae75989e85daf30ea2a5010d6a5a086cb6bbb5b4599b5065080b845c833776812f6e46566d
DIST Shapely-1.5.17.tar.gz 180663 BLAKE2B 1a41de8c264989abeac27fe9b63abd81ad6f03f0eecd313131d04190b8bbebc6c6bd6b45b1782fbfd163025cda4977b7e93a24a711c76fddfaedb0fe880cea53 SHA512 eea241942ffbf377001445fab4017c9a2746d6bc0baa6c801a08ca95e608bbdaea7ad9568f00cbecdb559e634402bc6d213ebccb4074e59325e1cc4b3771626d
+DIST Shapely-1.6.4.post2.tar.gz 225745 BLAKE2B 96e995db6dd1464bac7c2562efdc7f298a5f23c388e44f334db685b1cfa1025ff403db870e11328977a267483726504e03b6d7c47fe4234a3a5966a13b2b7311 SHA512 027c816ef2104f654569ca658b52b87c60e5ba6a45927fcc51c23dd1922f3f9f7fdcea3601160b0a999e39611617142833ccac790777093be8b96a0d9083f78f
diff --git a/sci-libs/Shapely/Shapely-1.6.4_p2.ebuild b/sci-libs/Shapely/Shapely-1.6.4_p2.ebuild
new file mode 100644
index 000000000000..50528d9087df
--- /dev/null
+++ b/sci-libs/Shapely/Shapely-1.6.4_p2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1 eapi7-ver
+
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="https://pypi.org/project/Shapely/"
+
+MY_PV="$(ver_cut 1-3).post$(ver_cut 5)"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/Toblerity/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=sci-libs/geos-3.3
+ dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+python_prepare_all() {
+ # fix install path for Cython definition file
+ sed -i \
+ -e "s|\(data_files.*\)'shapely'|\1'share/shapely'|" \
+ setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}/lib" || die
+ cp -r "${S}/tests" . || die
+ py.test tests || die
+}