summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-24 23:21:44 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-01 10:52:53 +0100
commit9f06a152740a830a50d35207b3f89fa440f06e5f (patch)
treef5af0c1b9b7fd7bf8c51e499917447dfe095f079 /sci-libs
parentsci-libs/rocBLAS: drop 5.0.2-r2 (diff)
downloadgentoo-9f06a152740a830a50d35207b3f89fa440f06e5f.tar.gz
gentoo-9f06a152740a830a50d35207b3f89fa440f06e5f.tar.bz2
gentoo-9f06a152740a830a50d35207b3f89fa440f06e5f.zip
sci-libs/rocFFT: drop 5.0.2-r1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/rocFFT/Manifest1
-rw-r--r--sci-libs/rocFFT/files/rocFFT-5.0.2-unbundle-sqlite.patch54
-rw-r--r--sci-libs/rocFFT/rocFFT-5.0.2-r1.ebuild148
3 files changed, 0 insertions, 203 deletions
diff --git a/sci-libs/rocFFT/Manifest b/sci-libs/rocFFT/Manifest
index 1eadc3e838dc..f93c38954772 100644
--- a/sci-libs/rocFFT/Manifest
+++ b/sci-libs/rocFFT/Manifest
@@ -1,2 +1 @@
-DIST rocFFT-5.0.2.tar.gz 837508 BLAKE2B b74d0c6edd7b232f775bffefbca829d88d9d7cd9108c27a0698f45d7fe2760d40463bcda8c710e923874b3bbfb1e83e0fe8622db4dfa28afb29392b3e135e9a5 SHA512 d6810a92a10a27dbcac8a04e8fcd56c7fa198f208da626d8938d5ff28b6ab8b89a058c7a56b5666464165e8f6bd7c4c031a94315625a3613eb02a9b8eccd9eb9
DIST rocFFT-5.1.3.tar.gz 845470 BLAKE2B 86060ce4f8612869fedc5bc92ed6a5bb7fbc539b26c7f5ab0ded5406ab6c340f64116782285d040824e54557af87d9ddb6f907fd1550b80c3da903d3c1d5e5c0 SHA512 175402856bd4753e74ce14326569be99221e21d0ce675e007900f6982c53e1566ad0b060eec545e0f17ff4dc4811688cc1003dc986226205ee95ee6f22d1ca43
diff --git a/sci-libs/rocFFT/files/rocFFT-5.0.2-unbundle-sqlite.patch b/sci-libs/rocFFT/files/rocFFT-5.0.2-unbundle-sqlite.patch
deleted file mode 100644
index 4da2b2092906..000000000000
--- a/sci-libs/rocFFT/files/rocFFT-5.0.2-unbundle-sqlite.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-Disable rocFFT fetching SQLite3 and link to system libsqlite.so
---- rocFFT-rocm-5.0.2/library/src/CMakeLists.txt
-+++ rocFFT-rocm-5.0.2/library/src/CMakeLists.txt
-@@ -134,31 +134,7 @@ set( rocfft_source
- rtcsubprocess.cpp
- )
-
--# SQLite 3.36.0 enabled the backup API by default, which we need
--# for cache serialization. We also want to use a static SQLite,
--# and distro static libraries aren't typically built
--# position-independent.
--include( FetchContent )
--
--# embed SQLite
--FetchContent_Declare(sqlite_local
-- URL https://sqlite.org/2021/sqlite-amalgamation-3360000.zip
-- URL_HASH SHA256=999826fe4c871f18919fdb8ed7ec9dd8217180854dd1fe21eea96aed36186729
--)
--FetchContent_MakeAvailable(sqlite_local)
--add_library( sqlite3 STATIC ${sqlite_local_SOURCE_DIR}/sqlite3.c )
--set_target_properties( sqlite3 PROPERTIES
-- C_VISIBILITY_PRESET "hidden"
-- VISIBILITY_INLINES_HIDDEN ON
-- POSITION_INDEPENDENT_CODE ON
-- )
--
--# we don't need extensions, and omitting them from SQLite removes the
--# need for dlopen/dlclose from within rocFFT
--target_compile_options(
-- sqlite3
-- PRIVATE -DSQLITE_OMIT_LOAD_EXTENSION
--)
-+find_package( SQLite3 REQUIRED )
-
- set_property(
- SOURCE rtc.cpp
-@@ -170,7 +146,7 @@ prepend_path( ".." rocfft_headers_public
- add_library( rocfft ${rocfft_source} ${relative_rocfft_headers_public} )
- add_library( roc::rocfft ALIAS rocfft )
-
--target_link_libraries( rocfft PRIVATE stockham_gen sqlite3 )
-+target_link_libraries( rocfft PRIVATE stockham_gen ${SQLite3_LIBRARIES} )
- if( NOT WIN32 )
- target_link_libraries( rocfft PRIVATE -lstdc++fs )
- endif()
-@@ -203,7 +179,7 @@ endif()
- target_include_directories( rocfft
- PRIVATE $<BUILD_INTERFACE:${PROJECT_SOURCE_DIR}/library/src/include>
- $<BUILD_INTERFACE:${PROJECT_BINARY_DIR}/library/src/device>
-- ${sqlite_local_SOURCE_DIR}
-+ ${SQLite3_LIBRARIES}
- PUBLIC $<BUILD_INTERFACE:${PROJECT_SOURCE_DIR}/library/include>
- $<BUILD_INTERFACE:${PROJECT_BINARY_DIR}/include>
- $<INSTALL_INTERFACE:include/rocFFT>
diff --git a/sci-libs/rocFFT/rocFFT-5.0.2-r1.ebuild b/sci-libs/rocFFT/rocFFT-5.0.2-r1.ebuild
deleted file mode 100644
index 2e0fe7421d2b..000000000000
--- a/sci-libs/rocFFT/rocFFT-5.0.2-r1.ebuild
+++ /dev/null
@@ -1,148 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit cmake check-reqs multiprocessing python-r1
-
-DESCRIPTION="Next generation FFT implementation for ROCm"
-HOMEPAGE="https://github.com/ROCmSoftwarePlatform/rocFFT"
-SRC_URI="https://github.com/ROCmSoftwarePlatform/rocFFT/archive/rocm-${PV}.tar.gz -> rocFFT-${PV}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~amd64"
-SLOT="0/$(ver_cut 1-2)"
-
-# RDEPEND: perfscripts? dev-python/plotly[${PYTHON_USEDEP}] # currently masked by arch/amd64/x32/package.mask
-RDEPEND="
-perfscripts? (
- >=media-gfx/asymptote-2.61
- dev-texlive/texlive-latex
- dev-tex/latexmk
- sys-apps/texinfo
- dev-python/sympy[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}] )
-${PYTHON_DEPS}"
-
-DEPEND="dev-util/hip:=
- ${PYTHON_DEPS}"
-
-BDEPEND="
- test? ( dev-cpp/gtest dev-libs/boost
- >=sci-libs/fftw-3 sys-libs/libomp )
- >=dev-util/cmake-3.22
- >=dev-util/rocm-cmake-${PV}-r1:${SLOT}
-"
-
-CHECKREQS_DISK_BUILD="7G"
-
-IUSE="benchmark perfscripts test"
-REQUIRED_USE="perfscripts? ( benchmark ) ${PYTHON_REQUIRED_USE}"
-
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/rocFFT-rocm-${PV}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-4.2.0-add-functional-header.patch"
- "${FILESDIR}/${PN}-5.0.2-unbundle-sqlite.patch"
- "${FILESDIR}/${PN}-5.0.2-add-math-header.patch" )
-
-required_mem() {
- if use test; then
- echo "52G"
- else
- if [[ -n "${AMDGPU_TARGETS}" ]]; then
- local NARCH=$(($(awk -F";" '{print NF-1}' <<< "${AMDGPU_TARGETS}" || die)+1)) # count how many archs user specified in ${AMDGPU_TARGETS}
- else
- local NARCH=7 # The default number of AMDGPU_TARGETS for rocFFT-4.3.0. May change in the future.
- fi
- echo "$(($(makeopts_jobs)*${NARCH}*25+2200))M" # A linear function estimating how much memory required
- fi
-}
-
-pkg_pretend() {
- return # leave the disk space check to pkg_setup phase
-}
-
-pkg_setup() {
- export CHECKREQS_MEMORY=$(required_mem)
- check-reqs_pkg_setup
- python_setup
-}
-
-src_prepare() {
- sed -e "s/PREFIX rocfft//" \
- -e "/rocm_install_symlink_subdir/d" \
- -e "/<INSTALL_INTERFACE/s,include,include/rocFFT," \
- -i library/src/CMakeLists.txt || die
-
- sed -e "/rocm_install_symlink_subdir/d" \
- -e "$!N;s:PREFIX\n[ ]*rocfft:# PREFIX rocfft\n:;P;D" \
- -i library/src/device/CMakeLists.txt || die
-
- if use perfscripts; then
- pushd scripts/perf || die
- sed -e "/\/opt\/rocm/d" -e "/rocmversion/s,rocm_info.strip(),\"${PV}\"," -i perflib/specs.py || dir
- sed -e "/^top/,+1d" -i rocfft-perf suites.py || die
- sed -e "s,perflib,${PN}_perflib,g" -i rocfft-perf suites.py perflib/*.py || die
- sed -e "/^top = /s,__file__).*$,\"${EPREFIX}/usr/share/${PN}-perflib\")," -i perflib/pdf.py perflib/generators.py || die
- popd
- fi
-
- cmake_src_prepare
-}
-
-src_configure() {
- # Grant access to the device
- addwrite /dev/kfd
- addpredict /dev/dri/
-
- # Compiler to use
- export CXX=hipcc
-
- local mycmakeargs=(
- -Wno-dev
- -DCMAKE_INSTALL_INCLUDEDIR="include/rocFFT/"
- -DCMAKE_SKIP_RPATH=ON
- -DBUILD_CLIENTS_TESTS=$(usex test ON OFF)
- -DBUILD_CLIENTS_SELFTEST=$(usex test ON OFF)
- -DBUILD_CLIENTS_RIDER=$(usex benchmark ON OFF)
- ${AMDGPU_TARGETS+-DAMDGPU_TARGETS="${AMDGPU_TARGETS}"}
- )
-
- cmake_src_configure
-}
-
-src_test() {
- addwrite /dev/kfd
- addpredict /dev/dri
- cd "${BUILD_DIR}/clients/staging" || die
- einfo "Running rocfft-test"
- LD_LIBRARY_PATH=${BUILD_DIR}/library/src/:${BUILD_DIR}/library/src/device ./rocfft-test || die
-
- einfo "Running rocfft-selftest"
- LD_LIBRARY_PATH=${BUILD_DIR}/library/src/:${BUILD_DIR}/library/src/device ./rocfft-selftest || die
-}
-
-src_install() {
- cmake_src_install
-
- if use benchmark; then
- cd "${BUILD_DIR}"/clients/staging || die
- dobin *rider
- fi
-
- if use perfscripts; then
- cd "${S}"/scripts/perf || die
- python_foreach_impl python_doexe rocfft-perf
- python_moduleinto ${PN}_perflib
- python_foreach_impl python_domodule perflib/*.py
- insinto /usr/share/${PN}-perflib
- doins *.asy suites.py
- fi
-}