summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2022-09-18 18:52:22 -0700
committerJason Zaman <perfinion@gentoo.org>2022-09-22 20:06:45 -0700
commita65bfc870c43d99cd08d4da3de319b2e5245dd06 (patch)
tree1ad8a48c82450e0b3cc701a7ea4d90b27ff29691 /sci-libs
parentsci-visualization/tensorboard: add 2.10.0 (diff)
downloadgentoo-a65bfc870c43d99cd08d4da3de319b2e5245dd06.tar.gz
gentoo-a65bfc870c43d99cd08d4da3de319b2e5245dd06.tar.bz2
gentoo-a65bfc870c43d99cd08d4da3de319b2e5245dd06.zip
sci-libs/tensorflow-estimator: add 2.10
Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/tensorflow-estimator/Manifest1
-rw-r--r--sci-libs/tensorflow-estimator/tensorflow-estimator-2.10.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/sci-libs/tensorflow-estimator/Manifest b/sci-libs/tensorflow-estimator/Manifest
index c272eb0e409c..6e57a118cf8d 100644
--- a/sci-libs/tensorflow-estimator/Manifest
+++ b/sci-libs/tensorflow-estimator/Manifest
@@ -1,4 +1,5 @@
DIST bazelbuild-rules_cc-b1c40e1de81913a3c40e5948f78719c28152486d.zip 201360 BLAKE2B 0173a8edb17f344b18e42026e2f8a62a1909d4694ab0be83562b6437a3f1ef38889f069269ddd2308b41062e5f375f791be0d2631a8e52ede668203779813b56 SHA512 2ba1dc316d88947c1d17ec67154c052700e3571b8d03370a9f204cf9fe94a1bd58f93a2c4a3c0b02233ee3250053a4c30a4133b5b38745858c1d04be8c9d973f
DIST bazelbuild-rules_java-7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip 9422 BLAKE2B bbc45c97551ee8126335b611ffca6574dac843d4db9b3221b10d26487f8eecfe38ba0cd67a4039a3ad921c25fea6294c43e4f4e7a57a060a30791acd6c4f9d39 SHA512 ba06242feb711e7fb6e821fd9ac029248b4f3e466fb1acf971d0db8196f3efe4d114ef137acbe4913073f8cbe8ccab4d47d8bafa21b867b2d6a6d57f5a647f0c
+DIST tensorflow-estimator-2.10.tar.gz 655011 BLAKE2B 465b405bfc5b776bc9722407f0d475b4ce8a520bded4b6f0db4c9fc771b9486a4ef08ae460f2e1c8c4be1d2882b942fff79f7f08a458eaa444f1bb44eb66e91c SHA512 63cdc97d9abf3551a931372ab91e86b1cab761ea7476182ed82ac7c56884d315107b1873376385bcdfc531465c11fe0273aefe8b88e8b333d8e7b54e7d0a09eb
DIST tensorflow-estimator-2.8.0.tar.gz 691913 BLAKE2B 7c8059ec3c5e94f67b7fbb49b508e313f0a12eac0627b04471fe1ac82c26aaae2a120a834ce3dc5a16931119ffc31a9d96935b8f727d851885fa132eb08fa2ea SHA512 02a3009fd8f9f560dea6190989af7c58402777a414cd4bf036d24546fc4a747bb8a5515a5d6fea3bdb848cb9604239b19d43096c5f125a1fa434ae8fee44cf0a
DIST tensorflow-estimator-2.9.0.tar.gz 654755 BLAKE2B 24cd6fc0b78144f8b529ef5b502cdbf9702dc630ac28256a99d68b98b51518b65af533897e837ced6a6da11e1260847aa0e4ebdf90d37aa22bb3bcd2841bd3ea SHA512 277e398104ac92a48e481e0ee4d3bbc607ae79d0a03c6685723a2430117461c1f17090f56ab88b2ae1c86c8dfc6ec1b44a478a1b606b4432bd68d79ac0720475
diff --git a/sci-libs/tensorflow-estimator/tensorflow-estimator-2.10.ebuild b/sci-libs/tensorflow-estimator/tensorflow-estimator-2.10.ebuild
new file mode 100644
index 000000000000..df19c5f9a037
--- /dev/null
+++ b/sci-libs/tensorflow-estimator/tensorflow-estimator-2.10.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+MY_PN="estimator"
+MY_PV=${PV/_rc/-rc}
+MY_P=${MY_PN}-${MY_PV}
+
+inherit bazel distutils-r1
+
+DESCRIPTION="A high-level TensorFlow API that greatly simplifies machine learning programming"
+HOMEPAGE="https://www.tensorflow.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+bazel_external_uris="
+ https://github.com/bazelbuild/rules_cc/archive/b1c40e1de81913a3c40e5948f78719c28152486d.zip -> bazelbuild-rules_cc-b1c40e1de81913a3c40e5948f78719c28152486d.zip
+ https://github.com/bazelbuild/rules_java/archive/7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip -> bazelbuild-rules_java-7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip"
+
+SRC_URI="https://github.com/tensorflow/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz
+ ${bazel_external_uris}"
+
+RDEPEND="
+ sci-libs/tensorflow[python,${PYTHON_USEDEP}]
+ sci-libs/keras[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/unzip
+ dev-java/java-config
+ >=dev-util/bazel-4.2.2"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ bazel_load_distfiles "${bazel_external_uris}"
+}
+
+src_prepare() {
+ bazel_setup_bazelrc
+ default
+ python_copy_sources
+}
+
+python_compile() {
+ pushd "${BUILD_DIR}" >/dev/null || die
+
+ ebazel build //tensorflow_estimator/tools/pip_package:build_pip_package
+ ebazel shutdown
+
+ local srcdir="${T}/src-${EPYTHON/./_}"
+ mkdir -p "${srcdir}" || die
+ bazel-bin/tensorflow_estimator/tools/pip_package/build_pip_package --src "${srcdir}" || die
+
+ popd || die
+}
+
+src_compile() {
+ export JAVA_HOME=$(java-config --jre-home)
+ distutils-r1_src_compile
+}
+
+python_install() {
+ pushd "${T}/src-${EPYTHON/./_}" >/dev/null || die
+ esetup.py install
+ python_optimize
+ popd || die
+}