summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-06-10 22:45:45 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2020-07-15 18:53:11 +0200
commita7b1a26e27b5291e347baf5f9ba579e3db0b00b0 (patch)
tree3cac710a789168893ae9f6a9db42bcddcecc6a27 /sci-libs
parentx11-libs/libQGLViewer: version bump 2.7.2 (diff)
downloadgentoo-a7b1a26e27b5291e347baf5f9ba579e3db0b00b0.tar.gz
gentoo-a7b1a26e27b5291e347baf5f9ba579e3db0b00b0.tar.bz2
gentoo-a7b1a26e27b5291e347baf5f9ba579e3db0b00b0.zip
sci-libs/octomap: version bump 1.9.5
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/octomap/Manifest1
-rw-r--r--sci-libs/octomap/octomap-1.9.5.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/sci-libs/octomap/Manifest b/sci-libs/octomap/Manifest
index 8f52f98c8b55..8b77e9933585 100644
--- a/sci-libs/octomap/Manifest
+++ b/sci-libs/octomap/Manifest
@@ -1 +1,2 @@
DIST octomap-1.9.0.tar.gz 1682421 BLAKE2B a299b4a956d5f9b6a67b05548f2239ad1181a4a1e673e5868d56d6e2d8f0101b2c75b114d1b7995c244c138fe04c8972104c25ca2f4ca6f75639f7326f06d8d7 SHA512 335a4ee3fe20f456afd2d8491f8fe6cfc2527d6e26aa690a69a39c1468e41d312fd84c85a1247deb11f513b9d50b8c69d34b46876f8257c205b0a99bac826237
+DIST octomap-1.9.5.tar.gz 1682781 BLAKE2B 1ced023160d10c424d4bff76a0481ffe6c87c5bf8133480afe6c47ee0ee116304a811293cc0af0b303ebcad370b7ce433e85212f070ac921a9c5be41905a94ea SHA512 e58c6d33c351b14e9596e18a8702715d167c136fd029b1078ddd13a5926fe451d3b619231b5a8ccfb64b6e5fc6db8b57e6ef329099828d2f5195c0988700b581
diff --git a/sci-libs/octomap/octomap-1.9.5.ebuild b/sci-libs/octomap/octomap-1.9.5.ebuild
new file mode 100644
index 000000000000..38cae5f67707
--- /dev/null
+++ b/sci-libs/octomap/octomap-1.9.5.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="An Efficient Probabilistic 3D Mapping Framework Based on Octrees"
+HOMEPAGE="http://octomap.github.io/"
+SRC_URI="https://github.com/OctoMap/octomap/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD qt5? ( GPL-2 )"
+SLOT="0/19"
+KEYWORDS="~amd64 ~arm"
+IUSE="qt5 dynamicEDT3D doc"
+
+RDEPEND="
+ qt5? (
+ virtual/opengl
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ x11-libs/libQGLViewer:=
+ )
+"
+BDEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+"
+
+# https://github.com/OctoMap/octomap/issues/194
+PATCHES=( "${FILESDIR}/qglqt5.patch" )
+
+src_prepare() {
+ rm -r octovis/src/extern
+
+ sed --in-place \
+ --expression='s/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
+ */CMakeLists.txt */CMakeModules/InstallPkgConfigFile.cmake || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "-DBUILD_OCTOVIS_SUBPROJECT=$(usex qt5 ON OFF)"
+ "-DOCTOVIS_QT5=ON"
+ "-DBUILD_DYNAMICETD3D_SUBPROJECT=$(usex dynamicEDT3D ON OFF)"
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc ; then
+ cd "${BUILD_DIR}/octomap"
+ emake docs
+ if use dynamicEDT3D ; then
+ cd "${BUILD_DIR}/dynamicEDT3D"
+ emake docs_dynamicEDT3D
+ fi
+ fi
+}
+
+src_install() {
+ cmake_src_install
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/html/octomap
+ doins -r "${S}/octomap/doc/html/"*
+ if use dynamicEDT3D ; then
+ insinto /usr/share/doc/${PF}/html/dynamicEDT3D
+ doins -r "${S}/dynamicEDT3D/doc/html/"*
+ fi
+ fi
+
+ insinto /usr/share/ros_packages/${PN}
+ doins "${ED}/usr/share/${PN}/package.xml"
+ if use qt5; then
+ insinto /usr/share/ros_packages/octovis
+ doins "${ED}/usr/share/octovis/package.xml"
+ fi
+}
+
+src_test() {
+ # override parallel mode only for tests
+ local myctestargs=( "-j 1" )
+ cmake_src_test
+}