summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-02 18:43:29 +0000
committerSam James <sam@gentoo.org>2021-12-02 18:43:29 +0000
commitb72907b97d61fec2c9c3c10e1cc7bced23fd6741 (patch)
tree685aff013043b922c71816f5dc120c03c0465258 /sci-libs
parentmedia-libs/mesa: Version bump to 21.3.1 (diff)
downloadgentoo-b72907b97d61fec2c9c3c10e1cc7bced23fd6741.tar.gz
gentoo-b72907b97d61fec2c9c3c10e1cc7bced23fd6741.tar.bz2
gentoo-b72907b97d61fec2c9c3c10e1cc7bced23fd6741.zip
sci-libs/gmsh: add GCC 11 patch
Seems to build fine without this for me but it's reasonable, upstream, and seems to help others. Closes: https://bugs.gentoo.org/800536 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/gmsh/files/gmsh-4.8.4-gcc11.patch80
-rw-r--r--sci-libs/gmsh/gmsh-4.8.4.ebuild4
2 files changed, 84 insertions, 0 deletions
diff --git a/sci-libs/gmsh/files/gmsh-4.8.4-gcc11.patch b/sci-libs/gmsh/files/gmsh-4.8.4-gcc11.patch
new file mode 100644
index 000000000000..3f16ef476d7f
--- /dev/null
+++ b/sci-libs/gmsh/files/gmsh-4.8.4-gcc11.patch
@@ -0,0 +1,80 @@
+https://gitlab.onelab.info/gmsh/gmsh/-/commit/e7cd675083f72c6c01701cb0f16d1639aca121ba
+https://bugs.gentoo.org/800536
+
+From: Tristan Carel <tristan.carel@epfl.ch>
+Date: Wed, 28 Jul 2021 10:55:40 +0200
+Subject: [PATCH] Fix symbol conflict in picojson with GCC 11 internal macro
+
+Build issue on MacOS with GCC 11 from brew:
+```
+/usr/local/Cellar/gcc/11.1.0_1/lib/gcc/11/gcc/x86_64-apple-darwin20/11.1.0/include/serializeintrin.h:37: note: macro "_serialize" defined here
+ 37 | #define _serialize() __builtin_ia32_serialize ()
+ |
+```
+--- a/Common/picojson.h
++++ b/Common/picojson.h
+@@ -186,8 +186,8 @@ public:
+ private:
+ template <typename T> value(const T *); // intentionally defined to block implicit conversion of pointer to bool
+ template <typename Iter> static void _indent(Iter os, int indent);
+- template <typename Iter> void _serialize(Iter os, int indent) const;
+- std::string _serialize(int indent) const;
++ template <typename Iter> void serialize_(Iter os, int indent) const;
++ std::string serialize_(int indent) const;
+ void clear();
+ };
+
+@@ -549,11 +549,11 @@ template <typename Iter> void serialize_str(const std::string &s, Iter oi) {
+ }
+
+ template <typename Iter> void value::serialize(Iter oi, bool prettify) const {
+- return _serialize(oi, prettify ? 0 : -1);
++ return serialize_(oi, prettify ? 0 : -1);
+ }
+
+ inline std::string value::serialize(bool prettify) const {
+- return _serialize(prettify ? 0 : -1);
++ return serialize_(prettify ? 0 : -1);
+ }
+
+ template <typename Iter> void value::_indent(Iter oi, int indent) {
+@@ -563,7 +563,7 @@ template <typename Iter> void value::_indent(Iter oi, int indent) {
+ }
+ }
+
+-template <typename Iter> void value::_serialize(Iter oi, int indent) const {
++template <typename Iter> void value::serialize_(Iter oi, int indent) const {
+ switch (type_) {
+ case string_type:
+ serialize_str(*u_.string_, oi);
+@@ -580,7 +580,7 @@ template <typename Iter> void value::_serialize(Iter oi, int indent) const {
+ if (indent != -1) {
+ _indent(oi, indent);
+ }
+- i->_serialize(oi, indent);
++ i->serialize_(oi, indent);
+ }
+ if (indent != -1) {
+ --indent;
+@@ -608,7 +608,7 @@ template <typename Iter> void value::_serialize(Iter oi, int indent) const {
+ if (indent != -1) {
+ *oi++ = ' ';
+ }
+- i->second._serialize(oi, indent);
++ i->second.serialize_(oi, indent);
+ }
+ if (indent != -1) {
+ --indent;
+@@ -628,9 +628,9 @@ template <typename Iter> void value::_serialize(Iter oi, int indent) const {
+ }
+ }
+
+-inline std::string value::_serialize(int indent) const {
++inline std::string value::serialize_(int indent) const {
+ std::string s;
+- _serialize(std::back_inserter(s), indent);
++ serialize_(std::back_inserter(s), indent);
+ return s;
+ }
+
+GitLab
diff --git a/sci-libs/gmsh/gmsh-4.8.4.ebuild b/sci-libs/gmsh/gmsh-4.8.4.ebuild
index df5ea5533a0a..0c32a563f7a1 100644
--- a/sci-libs/gmsh/gmsh-4.8.4.ebuild
+++ b/sci-libs/gmsh/gmsh-4.8.4.ebuild
@@ -40,6 +40,10 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P}-source
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc11.patch
+)
+
pkg_setup() {
fortran-2_pkg_setup
}