summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-03-23 21:02:20 -0500
committerMatthias Maier <tamiko@gentoo.org>2018-03-23 21:25:34 -0500
commitc8cf40cd6eaecf49f5fe851f7612849394ca8dcf (patch)
tree552ee933292751407649d1c118fd9f39033f7e31 /sci-libs
parentsci-libs/arpack: update homepage (diff)
downloadgentoo-c8cf40cd6eaecf49f5fe851f7612849394ca8dcf.tar.gz
gentoo-c8cf40cd6eaecf49f5fe851f7612849394ca8dcf.tar.bz2
gentoo-c8cf40cd6eaecf49f5fe851f7612849394ca8dcf.zip
sci-libs/arpack: Add a live ebuild; ebuild maintenance
* add a live ebuild * remove unused variable Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/arpack/arpack-3.4.0.ebuild2
-rw-r--r--sci-libs/arpack/arpack-3.5.0.ebuild2
-rw-r--r--sci-libs/arpack/arpack-9999.ebuild56
3 files changed, 56 insertions, 4 deletions
diff --git a/sci-libs/arpack/arpack-3.4.0.ebuild b/sci-libs/arpack/arpack-3.4.0.ebuild
index 13480a596525..3f0d563fe717 100644
--- a/sci-libs/arpack/arpack-3.4.0.ebuild
+++ b/sci-libs/arpack/arpack-3.4.0.ebuild
@@ -5,8 +5,6 @@ EAPI=6
inherit autotools eutils fortran-2 toolchain-funcs
-MY_P="${PN}-ng_${PV}"
-
DESCRIPTION="Arnoldi package library to solve large scale eigenvalue problems"
HOMEPAGE="http://www.caam.rice.edu/software/ARPACK/ https://github.com/opencollab/arpack-ng"
SRC_URI="
diff --git a/sci-libs/arpack/arpack-3.5.0.ebuild b/sci-libs/arpack/arpack-3.5.0.ebuild
index 13480a596525..3f0d563fe717 100644
--- a/sci-libs/arpack/arpack-3.5.0.ebuild
+++ b/sci-libs/arpack/arpack-3.5.0.ebuild
@@ -5,8 +5,6 @@ EAPI=6
inherit autotools eutils fortran-2 toolchain-funcs
-MY_P="${PN}-ng_${PV}"
-
DESCRIPTION="Arnoldi package library to solve large scale eigenvalue problems"
HOMEPAGE="http://www.caam.rice.edu/software/ARPACK/ https://github.com/opencollab/arpack-ng"
SRC_URI="
diff --git a/sci-libs/arpack/arpack-9999.ebuild b/sci-libs/arpack/arpack-9999.ebuild
new file mode 100644
index 000000000000..56b384c53431
--- /dev/null
+++ b/sci-libs/arpack/arpack-9999.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils fortran-2 toolchain-funcs
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/opencollab/arpack-ng"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/opencollab/${PN}-ng/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+ S="${WORKDIR}/${PN}-ng-${PV}"
+fi
+
+DESCRIPTION="Arnoldi package library to solve large scale eigenvalue problems"
+HOMEPAGE="http://www.caam.rice.edu/software/ARPACK/ https://github.com/opencollab/arpack-ng"
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples mpi static-libs"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack
+ mpi? ( virtual/mpi[fortran] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)" \
+ $(use_enable mpi)
+}
+
+src_install() {
+ default
+
+ dodoc DOCUMENTS/*.doc
+ newdoc DOCUMENTS/README README.doc
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r EXAMPLES
+ if use mpi; then
+ insinto /usr/share/doc/${PF}/EXAMPLES/PARPACK
+ doins -r PARPACK/EXAMPLES/MPI
+ fi
+ fi
+}