summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-03-06 23:58:40 +0100
committerDavid Seifert <soap@gentoo.org>2016-03-07 00:04:55 +0100
commite4cad4b39c4b1f35a2ffe4a7c747fa1ac1a6f9cc (patch)
treeb95aebdb143d761773c3f87eba17c8b3bdef6046 /sci-mathematics/calc/calc-2.12.5.4.ebuild
parentmedia-libs/babl: Add use flag for CPU feature f16c (bug #576388) (diff)
downloadgentoo-e4cad4b39c4b1f35a2ffe4a7c747fa1ac1a6f9cc.tar.gz
gentoo-e4cad4b39c4b1f35a2ffe4a7c747fa1ac1a6f9cc.tar.bz2
gentoo-e4cad4b39c4b1f35a2ffe4a7c747fa1ac1a6f9cc.zip
sci-mathematics/calc: Version bump to 2.12.5.4
Gentoo-Bug: 524544 * EAPI=6 Package-Manager: portage-2.2.27
Diffstat (limited to 'sci-mathematics/calc/calc-2.12.5.4.ebuild')
-rw-r--r--sci-mathematics/calc/calc-2.12.5.4.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sci-mathematics/calc/calc-2.12.5.4.ebuild b/sci-mathematics/calc/calc-2.12.5.4.ebuild
new file mode 100644
index 000000000000..14bfe65800eb
--- /dev/null
+++ b/sci-mathematics/calc/calc-2.12.5.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Arbitrary precision C-like arithmetic system"
+HOMEPAGE="http://www.isthe.com/chongo/tech/comp/calc/"
+SRC_URI="http://www.isthe.com/chongo/src/calc/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE=""
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-as-needed.patch"
+)
+
+src_prepare() {
+ default
+ ln -sf libcustcalc.so.${PV} custom/libcustcalc.so || die
+ sed -i -e "/DIR/s:/usr:${EPREFIX}/usr:g" Makefile || die
+}
+
+src_compile() {
+ # parallel compilation hard to fix. better to leave upstream.
+ emake -j1 \
+ CC="$(tc-getCC)" \
+ DEBUG="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CALCPAGER="${PAGER}" \
+ USE_READLINE="-DUSE_READLINE" \
+ READLINE_LIB="-lreadline -lhistory $(pkg-config --libs ncurses) -L\"${S}\"/custom -lcustcalc" \
+ all
+}
+
+src_test() {
+ if echo "${LD_PRELOAD}" | grep -q "sandbox"; then
+ ewarn "Can't run check when running in sandbox - see bug #59676"
+ else
+ emake chk
+ fi
+}
+
+src_install() {
+ emake \
+ T="${D}" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ install
+ dodoc BUGS CHANGES LIBRARY README
+}