summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-06-25 20:37:09 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-06-25 20:41:30 +0000
commit553750d950477340ab2f269efecb4a90921c7fe0 (patch)
tree5c0661293f89bbd3b44c910511b98036179430fe /sci-mathematics/coq
parentnet-analyzer/echoping: Old. (diff)
downloadgentoo-553750d950477340ab2f269efecb4a90921c7fe0.tar.gz
gentoo-553750d950477340ab2f269efecb4a90921c7fe0.tar.bz2
gentoo-553750d950477340ab2f269efecb4a90921c7fe0.zip
sci-mathematics/coq: Stable for amd64. Retroactively mark stable for the remaining arches using the ALLARCHES policy.
Package-Manager: portage-2.2.28 Gentoo-Bug: https://bugs.gentoo.org/586932
Diffstat (limited to 'sci-mathematics/coq')
-rw-r--r--sci-mathematics/coq/coq-8.5.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/sci-mathematics/coq/coq-8.5.ebuild b/sci-mathematics/coq/coq-8.5.ebuild
index 1dffb390cc78..040cc88a8944 100644
--- a/sci-mathematics/coq/coq-8.5.ebuild
+++ b/sci-mathematics/coq/coq-8.5.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=5
inherit eutils multilib
@@ -15,7 +15,7 @@ SRC_URI="http://${PN}.inria.fr/distrib/V${MY_PV}/files/${MY_P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ppc x86"
IUSE="gtk debug +ocamlopt doc camlp5"
RDEPEND="
@@ -23,6 +23,7 @@ RDEPEND="
camlp5? ( >=dev-ml/camlp5-6.02.3:=[ocamlopt?] )
!camlp5? ( dev-ml/camlp4:= )
gtk? ( >=dev-ml/lablgtk-2.10.1:=[sourceview,ocamlopt?] )"
+
DEPEND="${RDEPEND}
doc? (
media-libs/netpbm[png,zlib]
@@ -34,11 +35,15 @@ DEPEND="${RDEPEND}
dev-texlive/texlive-latexextra
)"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-8.5-do-not-install-revision.patch"
+ "${FILESDIR}/${PN}-8.4_p5-no-clean-before-test.patch"
+)
src_prepare() {
- epatch "${FILESDIR}/${PN}-8.5-do-not-install-revision.patch"
- epatch "${FILESDIR}/${PN}-8.4_p5-no-clean-before-test.patch"
+ epatch "${PATCHES[@]}"
}
src_configure() {